libraries/libpri: Updated for version 1.4.10.1

This commit is contained in:
Alan Hicks 2010-05-13 00:31:38 +02:00 committed by Robby Workman
parent 13cb632d7e
commit 1dc4705a19
4 changed files with 45 additions and 14 deletions

View file

@ -7,4 +7,4 @@ Lucent.
Please note that there are no man pages and precious little documentation
for this library. The build is simple and straight forward though.
libpri is an optional requirement to Asterisk
libpri is an optional requirement to Asterisk.

View file

@ -0,0 +1,12 @@
diff -Nur libpri-1.4.10.1.orig/Makefile libpri-1.4.10.1/Makefile
--- libpri-1.4.10.1.orig/Makefile 2008-08-06 13:20:51.000000000 -0500
+++ libpri-1.4.10.1/Makefile 2009-07-05 15:11:09.417405564 -0500
@@ -43,7 +43,7 @@
DYNAMIC_LIBRARY:=libpri.so.$(SONAME)
STATIC_OBJS=copy_string.o pri.o q921.o prisched.o q931.o pri_facility.o version.o
DYNAMIC_OBJS=copy_string.lo pri.lo q921.lo prisched.lo q931.lo pri_facility.lo version.lo
-CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -g -fPIC $(ALERTING) $(LIBPRI_COUNTERS)
+CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -g -fPIC $(EXTRA_CFLAGS) $(ALERTING) $(LIBPRI_COUNTERS)
INSTALL_PREFIX=$(DESTDIR)
INSTALL_BASE=/usr
libdir?=$(INSTALL_BASE)/lib

View file

@ -22,19 +22,31 @@
# Modified by Robby Workman <rworkman@slackbuilds.org>
# No additional license terms :)
set -e
PRGNAM="libpri"
VERSION="1.4.3"
PRGNAM=libpri
VERSION=1.4.10.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG="$TMP/pkg-$PRGNAM"
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
set -e
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
# "-fPIC" is already in the Makefile
SLKCFLAGS="-O2"
LIBDIRSUFFIX="64"
fi
rm -fr $PKG $TMP/$PRGNAM-$VERSION
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@ -43,12 +55,17 @@ cd $PRGNAM-$VERSION
chmod -R a-s,u+w,go+r-w .
chown -R root:root .
make
make install DESTDIR=$PKG
# Allow using our SLKCFLAGS
patch -p1 < $CWD/libpri-1.4.10.1-add_extra_cflags.patch
make libdir=/usr/lib${LIBDIRSUFFIX} EXTRA_CFLAGS="$SLKCFLAGS"
make libdir=/usr/lib${LIBDIRSUFFIX} install DESTDIR=$PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/install $PKG/usr/doc/$PRGNAM-$VERSION
@ -58,4 +75,4 @@ cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,8 +1,10 @@
PRGNAM="libpri"
VERSION="1.4.3"
VERSION="1.4.10.1"
HOMEPAGE="http://www.digium.com"
DOWNLOAD="http://downloads.digium.com/pub/libpri/old/libpri-1.4.3.tar.gz"
MD5SUM="c5be91fc98f1638ba0365bf87f696cd1"
DOWNLOAD="http://downloads.digium.com/pub/libpri/libpri-1.4.10.1.tar.gz"
MD5SUM="55ce81cd0b2cf0c40e287fc5bd5b4883"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Alan Hicks"
EMAIL="alan@lizella.net"
APPROVED="rworkman"