mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
misc/funny-manpages: Added to 12.1 repository
This commit is contained in:
parent
37274113c3
commit
1ce14296d1
5 changed files with 362 additions and 0 deletions
5
misc/funny-manpages/README
Normal file
5
misc/funny-manpages/README
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
More funny manpages
|
||||||
|
|
||||||
|
A set of miscellaneous humorous manpages (don't take them too seriously!).
|
||||||
|
Includes, amongst others, rtfm (1). Warning! Some of these manpages might
|
||||||
|
be treated offensive. You've been warned.
|
86
misc/funny-manpages/funny-manpages.SlackBuild
Normal file
86
misc/funny-manpages/funny-manpages.SlackBuild
Normal file
|
@ -0,0 +1,86 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# Slackware build script for funny-manpages
|
||||||
|
# Copyright 2007-2008 Michiel van Wessem, Manchester, United Kingdom
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use in source and binary forms, with or without
|
||||||
|
# modification, are permitted provided that the following conditions are
|
||||||
|
# met:
|
||||||
|
#
|
||||||
|
# * Redistributions of source code must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||||
|
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||||
|
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||||
|
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||||
|
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||||
|
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||||
|
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||||
|
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||||
|
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||||
|
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
|
PRGNAM=funny-manpages
|
||||||
|
VERSION=1.3.5
|
||||||
|
SRC_VERSION=1.3
|
||||||
|
DEB_VERSION=1.3-5
|
||||||
|
|
||||||
|
|
||||||
|
ARCH=${ARCH:-noarch}
|
||||||
|
BUILD=${BUILD:-1}
|
||||||
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
CWD=$(pwd)
|
||||||
|
TMP=${TMP:-/tmp/SBo}
|
||||||
|
PKG=$TMP/package-$PRGNAM
|
||||||
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
rm -rf $PKG
|
||||||
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
|
cd $TMP
|
||||||
|
rm -rf $PRGNAM-$VERSION
|
||||||
|
tar xvf $CWD/${PRGNAM}_$SRC_VERSION.orig.tar.gz
|
||||||
|
cd $PRGNAM-$SRC_VERSION.orig
|
||||||
|
chown -R root:root .
|
||||||
|
find . \
|
||||||
|
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
|
||||||
|
-exec chmod 755 {} \; -o \
|
||||||
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
|
# Patch the manpages to the latest version.
|
||||||
|
patch -p1 < $CWD/${PRGNAM}_$DEB_VERSION.diff
|
||||||
|
|
||||||
|
# Create the directories we need
|
||||||
|
mkdir -p $PKG/usr/man/man{1,3,6}
|
||||||
|
|
||||||
|
for manpage in $(echo *fun); do
|
||||||
|
section=$(echo $manpage | awk -F. '{print $2}' | colrm 2 4)
|
||||||
|
install -m 0644 $manpage $PKG/usr/man/man$section/$manpage
|
||||||
|
done
|
||||||
|
|
||||||
|
( cd $PKG/usr/man/man1
|
||||||
|
ln -sf grope.1fun egrope.1fun
|
||||||
|
ln -sf grope.1fun fgrope.1fun
|
||||||
|
)
|
||||||
|
|
||||||
|
( cd $PKG/usr/man
|
||||||
|
find . -type f -exec gzip -9 {} \;
|
||||||
|
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||||
|
)
|
||||||
|
|
||||||
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cp -a debian/README.Debian debian/changelog debian/copyright \
|
||||||
|
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
mkdir -p $PKG/install
|
||||||
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
|
||||||
|
cd $PKG
|
||||||
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
|
8
misc/funny-manpages/funny-manpages.info
Normal file
8
misc/funny-manpages/funny-manpages.info
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
PRGNAM="funny-manpages"
|
||||||
|
VERSION="1.3.5"
|
||||||
|
HOMEPAGE="http://packages.debian.org/etch/funny-manpages"
|
||||||
|
DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/f/funny-manpages/funny-manpages_1.3.orig.tar.gz"
|
||||||
|
MD5SUM="bed1deef82218d42fb230a2176a11ed4"
|
||||||
|
MAINTAINER="Michiel van Wessem"
|
||||||
|
EMAIL="michiel@slackbuilds.org"
|
||||||
|
APPROVED="rworkman"
|
244
misc/funny-manpages/funny-manpages_1.3-5.diff
Normal file
244
misc/funny-manpages/funny-manpages_1.3-5.diff
Normal file
|
@ -0,0 +1,244 @@
|
||||||
|
--- funny-manpages-1.3.orig/debian/README.Debian
|
||||||
|
+++ funny-manpages-1.3/debian/README.Debian
|
||||||
|
@@ -0,0 +1,9 @@
|
||||||
|
+funny-manpages for Debian
|
||||||
|
+----------------------
|
||||||
|
+
|
||||||
|
+The sources for funny manpages were collected from various sources.
|
||||||
|
+This basically means that the only 'original' thing in .orig.tar.gz is the
|
||||||
|
+fact, that there are debian control files and some manpages' contents have
|
||||||
|
+bugs fixed in the package.
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org>, Fri, 15 Dec 2000 12:13:37 +0100
|
||||||
|
--- funny-manpages-1.3.orig/debian/changelog
|
||||||
|
+++ funny-manpages-1.3/debian/changelog
|
||||||
|
@@ -0,0 +1,77 @@
|
||||||
|
+funny-manpages (1.3-5) unstable; urgency=low
|
||||||
|
+
|
||||||
|
+ * Added lintian override to remove reports of missing manpage for woman (as
|
||||||
|
+ this is intentional) (closes: #219907)
|
||||||
|
+ * Changed Build-Depends to Build-Depends-Indep (as per policy)
|
||||||
|
+ * Updated standards version (no changes required)
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Thu, 12 Feb 2004 14:49:22 +0100
|
||||||
|
+
|
||||||
|
+funny-manpages (1.3-4) unstable; urgency=low
|
||||||
|
+
|
||||||
|
+ * Changed description so it's less confusing (closes: #129502)
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Wed, 23 Jan 2002 13:17:44 +0100
|
||||||
|
+
|
||||||
|
+funny-manpages (1.3-3) unstable; urgency=low
|
||||||
|
+
|
||||||
|
+ * Added sumlinks for [ef]grope.1fun.gz (closes: #99528)
|
||||||
|
+ * Now compliant with 3.5.5 policy
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Fri, 8 Jun 2001 09:27:43 +0200
|
||||||
|
+
|
||||||
|
+funny-manpages (1.3-2) unstable; urgency=low
|
||||||
|
+
|
||||||
|
+ * Corrected Build-Depends line in debian/control (was missing debhelper
|
||||||
|
+ version)
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Tue, 22 May 2001 12:38:20 +0200
|
||||||
|
+
|
||||||
|
+funny-manpages (1.3-1) unstable; urgency=low
|
||||||
|
+
|
||||||
|
+ * Rebuilt source -- all manpages are now in fun subsection (closes: #96463)
|
||||||
|
+ * General cleaning (standards version, etc.)
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Mon, 7 May 2001 10:59:02 +0200
|
||||||
|
+
|
||||||
|
+funny-manpages (1.2-1) unstable frozen; urgency=low
|
||||||
|
+
|
||||||
|
+ * Rebuilt source -- added date.1fun, echo.1fun, rm.1fun, strfry.3fun,
|
||||||
|
+ xkill.1fun (closes: #28990)
|
||||||
|
+ * uubp.1 now in orig source
|
||||||
|
+ * should no longer create sex.1 (closes: #52543)
|
||||||
|
+ * fixes to party.1 (closes: #52659)
|
||||||
|
+ * added woman.6 (closes: #63862)
|
||||||
|
+ * updated to newest standards version and moved to debhelper
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Fri, 15 Dec 2000 12:26:02 +0100
|
||||||
|
+
|
||||||
|
+funny-manpages (1.1-3) unstable frozen; urgency=low
|
||||||
|
+
|
||||||
|
+ * Minor fixes in manpages for sex (fixes bugs #45120)
|
||||||
|
+ * Changed section for sex from 1 to 6 (fixes #30977, #37897, #45120)
|
||||||
|
+ * Updated standards version to 3.0.1
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Tue, 26 Oct 1999 21:11:51 +0200
|
||||||
|
+
|
||||||
|
+funny-manpages (1.1-2) unstable frozen; urgency=low
|
||||||
|
+
|
||||||
|
+ * Changed path in rtfm.1 as suggested by Yann Dirson (fixes bug #25393)
|
||||||
|
+ * Updated Standards-Version
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@debian.org> Sat, 31 Oct 1998 22:13:20 +0100
|
||||||
|
+
|
||||||
|
+funny-manpages (1.1-1) unstable; urgency=low
|
||||||
|
+
|
||||||
|
+ * Added uubp(1) which was previously in asr-manpages.
|
||||||
|
+ * Removed strfry (conflicted with libc) - this closes bugs #16785 and
|
||||||
|
+ #16840.
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@pwr.wroc.pl> Tue, 23 Dec 1997 00:05:14 +0100
|
||||||
|
+
|
||||||
|
+funny-manpages (1.0-1) unstable; urgency=low
|
||||||
|
+
|
||||||
|
+ * Initial Release.
|
||||||
|
+
|
||||||
|
+ -- Pawel Wiecek <coven@pwr.wroc.pl> Wed, 10 Dec 1997 01:10:17 +0100
|
||||||
|
+
|
||||||
|
--- funny-manpages-1.3.orig/debian/copyright
|
||||||
|
+++ funny-manpages-1.3/debian/copyright
|
||||||
|
@@ -0,0 +1,32 @@
|
||||||
|
+This package was debianized by Pawel Wiecek coven@pwr.wroc.pl on
|
||||||
|
+Wed, 10 Dec 1997 01:10:17 +0100.
|
||||||
|
+
|
||||||
|
+This set of manpages was collected from all over the net. No specific
|
||||||
|
+location can be given.
|
||||||
|
+
|
||||||
|
+Copyright:
|
||||||
|
+
|
||||||
|
+To the best of my knowledge all of these manpages are free to use and
|
||||||
|
+redistribute.
|
||||||
|
+
|
||||||
|
+The authors are:
|
||||||
|
+
|
||||||
|
+baby.1fun - unknown, based on man page by Joe Beck <beck@cs.ualberta.ca>
|
||||||
|
+celibacy.1fun - unknown
|
||||||
|
+condom.1fun - Ken Maupin <maupin@cs.washington.edu>
|
||||||
|
+flame.1fun - unknown
|
||||||
|
+flog.1fun - unknown
|
||||||
|
+gong.1fun - unknown
|
||||||
|
+grope.1fun - unknown
|
||||||
|
+party.1fun - unknown
|
||||||
|
+rescrog.1fun - unknown
|
||||||
|
+rtfm.1fun - unknown
|
||||||
|
+sex.1fun - unknown
|
||||||
|
+tm.1fun - unknown
|
||||||
|
+xlart.1fun - James McPherson
|
||||||
|
+date.1fun - Glen Overby <overby@sendit.nodak.edu>
|
||||||
|
+echo.1fun - unknown
|
||||||
|
+rm.1fun - Matthew Farwell <dylan@ibmpcug.co.uk>
|
||||||
|
+strfry.3fun - <chuck@druco.att.com>
|
||||||
|
+xkill.1fun - Claudio Calvelli <Claudio@edinburgh.ac.uk>
|
||||||
|
+uubp.1fun - unknown
|
||||||
|
--- funny-manpages-1.3.orig/debian/dirs
|
||||||
|
+++ funny-manpages-1.3/debian/dirs
|
||||||
|
@@ -0,0 +1,2 @@
|
||||||
|
+/usr/share/man/man1
|
||||||
|
+/usr/share/lintian/overrides
|
||||||
|
--- funny-manpages-1.3.orig/debian/lintian
|
||||||
|
+++ funny-manpages-1.3/debian/lintian
|
||||||
|
@@ -0,0 +1 @@
|
||||||
|
+funny-manpages: link-to-undocumented-manpage usr/share/man/man6/woman.6fun.gz
|
||||||
|
--- funny-manpages-1.3.orig/debian/control
|
||||||
|
+++ funny-manpages-1.3/debian/control
|
||||||
|
@@ -0,0 +1,15 @@
|
||||||
|
+Source: funny-manpages
|
||||||
|
+Section: doc
|
||||||
|
+Priority: optional
|
||||||
|
+Maintainer: Pawel Wiecek <coven@debian.org>
|
||||||
|
+Build-Depends-Indep: debhelper (>> 3.0.0)
|
||||||
|
+Standards-Version: 3.6.1
|
||||||
|
+
|
||||||
|
+Package: funny-manpages
|
||||||
|
+Architecture: all
|
||||||
|
+Suggests: asr-manpages (>=1.3-4)
|
||||||
|
+Description: more funny manpages
|
||||||
|
+ A set of miscellaneous humorous manpages (don't take them too seriously!).
|
||||||
|
+ Includes, amongst others, rtfm (1).
|
||||||
|
+ Warning! Some of these manpages might be treated offensive.
|
||||||
|
+ You've been warned.
|
||||||
|
--- funny-manpages-1.3.orig/debian/rules
|
||||||
|
+++ funny-manpages-1.3/debian/rules
|
||||||
|
@@ -0,0 +1,87 @@
|
||||||
|
+#!/usr/bin/make -f
|
||||||
|
+# Sample debian/rules that uses debhelper.
|
||||||
|
+# GNU copyright 1997 to 1999 by Joey Hess.
|
||||||
|
+
|
||||||
|
+# Uncomment this to turn on verbose mode.
|
||||||
|
+#export DH_VERBOSE=1
|
||||||
|
+
|
||||||
|
+# This is the debhelper compatability version to use.
|
||||||
|
+export DH_COMPAT=3
|
||||||
|
+
|
||||||
|
+configure: configure-stamp
|
||||||
|
+configure-stamp:
|
||||||
|
+ dh_testdir
|
||||||
|
+ # Add here commands to configure the package.
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+ touch configure-stamp
|
||||||
|
+
|
||||||
|
+build: configure-stamp build-stamp
|
||||||
|
+build-stamp:
|
||||||
|
+ dh_testdir
|
||||||
|
+
|
||||||
|
+ # Add here commands to compile the package.
|
||||||
|
+# $(MAKE)
|
||||||
|
+ #/usr/bin/docbook-to-man debian/funny-manpages.sgml > funny-manpages.1
|
||||||
|
+
|
||||||
|
+ touch build-stamp
|
||||||
|
+
|
||||||
|
+clean:
|
||||||
|
+ dh_testdir
|
||||||
|
+ dh_testroot
|
||||||
|
+ rm -f build-stamp configure-stamp
|
||||||
|
+
|
||||||
|
+ # Add here commands to clean up after the build process.
|
||||||
|
+# -$(MAKE) clean
|
||||||
|
+
|
||||||
|
+ dh_clean
|
||||||
|
+
|
||||||
|
+install: build
|
||||||
|
+ dh_testdir
|
||||||
|
+ dh_testroot
|
||||||
|
+ dh_clean -k
|
||||||
|
+ dh_installdirs
|
||||||
|
+
|
||||||
|
+ # Add here commands to install the package into debian/tmp.
|
||||||
|
+# $(MAKE) install DESTDIR=`pwd`/debian/tmp
|
||||||
|
+ ln -s grope.1fun.gz debian/funny-manpages/usr/share/man/man1/egrope.1fun.gz
|
||||||
|
+ ln -s grope.1fun.gz debian/funny-manpages/usr/share/man/man1/fgrope.1fun.gz
|
||||||
|
+ cp debian/lintian debian/funny-manpages/usr/share/lintian/overrides/$(package)
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+# Build architecture-independent files here.
|
||||||
|
+binary-indep: build install
|
||||||
|
+# We have nothing to do by default.
|
||||||
|
+
|
||||||
|
+# Build architecture-dependent files here.
|
||||||
|
+binary-arch: build install
|
||||||
|
+ dh_testdir
|
||||||
|
+ dh_testroot
|
||||||
|
+# dh_installdebconf
|
||||||
|
+ dh_installdocs
|
||||||
|
+# dh_installexamples
|
||||||
|
+# dh_installmenu
|
||||||
|
+# dh_installemacsen
|
||||||
|
+# dh_installpam
|
||||||
|
+# dh_installinit
|
||||||
|
+# dh_installcron
|
||||||
|
+ dh_installmanpages
|
||||||
|
+# dh_installinfo
|
||||||
|
+ dh_undocumented woman.6fun
|
||||||
|
+ dh_installchangelogs
|
||||||
|
+# dh_link
|
||||||
|
+ dh_strip
|
||||||
|
+ dh_compress
|
||||||
|
+ dh_fixperms
|
||||||
|
+ # You may want to make some executables suid here.
|
||||||
|
+# dh_suidregister
|
||||||
|
+# dh_makeshlibs
|
||||||
|
+ dh_installdeb
|
||||||
|
+# dh_perl
|
||||||
|
+ dh_shlibdeps
|
||||||
|
+ dh_gencontrol
|
||||||
|
+ dh_md5sums
|
||||||
|
+ dh_builddeb
|
||||||
|
+
|
||||||
|
+binary: binary-indep binary-arch
|
||||||
|
+.PHONY: build clean binary-indep binary-arch binary install configure
|
19
misc/funny-manpages/slack-desc
Normal file
19
misc/funny-manpages/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
# HOW TO EDIT THIS FILE:
|
||||||
|
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||||
|
# up the first '|' above the ':' following the base package name, and the '|'
|
||||||
|
# on the right side marks the last column you can put a character in. You must
|
||||||
|
# make exactly 11 lines for the formatting to be correct. It's also
|
||||||
|
# customary to leave one space after the ':'.
|
||||||
|
|
||||||
|
|-----handy-ruler------------------------------------------------------|
|
||||||
|
funny-manpages: funny-manpages (more funny manpages)
|
||||||
|
funny-manpages:
|
||||||
|
funny-manpages: A set of miscellaneous humorous manpages (don't take them too
|
||||||
|
funny-manpages: seriously!).
|
||||||
|
funny-manpages:
|
||||||
|
funny-manpages: Includes, amongst others, rtfm (1). Warning! Some of these
|
||||||
|
funny-manpages: manpages might be treated offensive. You've been warned.
|
||||||
|
funny-manpages:
|
||||||
|
funny-manpages: manpages collected by: Pawel Wiecek
|
||||||
|
funny-manpages:
|
||||||
|
funny-manpages:
|
Loading…
Reference in a new issue