mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
libraries/tlsh: Updated for version 4.8.2.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
091e57953d
commit
1c12190b9d
4 changed files with 12 additions and 38 deletions
|
@ -3,7 +3,3 @@ length of 256 bytes, TLSH generates a hash value which can be used for
|
|||
similarity comparisons.
|
||||
|
||||
("TLSH" stands for Trend Micro Locality Sensitive Hash.)
|
||||
|
||||
python3 is an optional dependency. You need to set PYTHON3=yes,
|
||||
for example:
|
||||
PYTHON3=yes ./python-libarchive-c.SlackBuild
|
||||
|
|
|
@ -1,23 +0,0 @@
|
|||
From fb71fc45992a9adf73b3c8194bdd691391ca34d7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Bobbio?= <lunar@debian.org>
|
||||
Date: Wed, 27 Jan 2016 17:44:06 +0100
|
||||
Subject: [PATCH] install the library in expected directories
|
||||
|
||||
We add CMake install directives in order to see the library files installed in
|
||||
the expected multiarch compatible locations.
|
||||
---
|
||||
src/CMakeLists.txt | 4 ++++
|
||||
1 file changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
|
||||
index b1c92fb..c8d3fd9 100644
|
||||
--- a/src/CMakeLists.txt
|
||||
+++ b/src/CMakeLists.txt
|
||||
@@ -21,3 +21,7 @@ set_target_properties(tlsh_shared PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_SO
|
||||
set_target_properties(tlsh_shared PROPERTIES OUTPUT_NAME tlsh${BUILD_POSTFIX})
|
||||
set_target_properties(tlsh_shared PROPERTIES VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}"
|
||||
SOVERSION "0")
|
||||
+
|
||||
+include(GNUInstallDirs)
|
||||
+install(TARGETS tlsh_shared DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
||||
+install(FILES ../include/tlsh.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
|
|
@ -25,7 +25,7 @@
|
|||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=tlsh
|
||||
VERSION=${VERSION:-3.4.5}
|
||||
VERSION=${VERSION:-4.8.2}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
@ -79,8 +79,10 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# From Arch Linux (thanks!), but tweaked to omit static lib
|
||||
patch -p1 < $CWD/install-libraries.patch
|
||||
sed '/set(CMAKE_EXE_LINKER_FLAGS/d' -i CMakeLists.txt
|
||||
sed '/set(CMAKE_CXX_FLAGS/d' -i CMakeLists.txt
|
||||
sed 's|TLSH_SHARED_LIBRARY 0|TLSH_SHARED_LIBRARY 1|' -i src/CMakeLists.txt
|
||||
sed "s|DESTINATION\ lib|DESTINATION lib$LIBDIRSUFFIX|" -i src/CMakeLists.txt
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
|
@ -88,19 +90,18 @@ cd build
|
|||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
cd ..
|
||||
|
||||
mkdir -p $PKG/usr/bin
|
||||
install -D -m755 bin/tlsh_unittest $PKG/usr/bin
|
||||
ln -s tlsh_unittest $PKG/usr/bin/tlsh
|
||||
#mkdir -p $PKG/usr/bin
|
||||
#install -D -m755 bin/tlsh_unittest $PKG/usr/bin
|
||||
#ln -s tlsh_unittest $PKG/usr/bin/tlsh
|
||||
|
||||
cd py_ext
|
||||
python setup.py install --root=$PKG
|
||||
if [ "${PYTHON3:-no}" == "yes" ]; then
|
||||
if [ "${PYTHON3:-yes}" == "yes" ]; then
|
||||
rm -rf build
|
||||
python3 setup.py install --root=$PKG
|
||||
fi
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="tlsh"
|
||||
VERSION="3.4.5"
|
||||
VERSION="4.8.2"
|
||||
HOMEPAGE="https://github.com/trendmicro/tlsh"
|
||||
DOWNLOAD="https://github.com/trendmicro/tlsh/archive/v3.4.5/tlsh-3.4.5.tar.gz"
|
||||
MD5SUM="9e23c525cf5a1b0b44d9c161b2a637f8"
|
||||
DOWNLOAD="https://github.com/trendmicro/tlsh/archive/4.8.2/tlsh-4.8.2.tar.gz"
|
||||
MD5SUM="27106dfc3f90954ba3831d357ed7335d"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue