graphics/paraview: Updated for version 5.2.0

Signed-off-by: Christoph Willing <chris.willing@iinet.net.au>
This commit is contained in:
Christoph Willing 2016-11-19 09:04:10 +10:00 committed by Willy Sudiarto Raharjo
parent 5d9e349319
commit 1c05aebc82
No known key found for this signature in database
GPG key ID: 887B8374D7333381
8 changed files with 69 additions and 84 deletions

View file

@ -1,25 +1,27 @@
--- Qt/ApplicationComponents/pqParaViewMenuBuilders.cxx.orig 2016-07-27 12:54:37.000000000 +1000 --- Qt/ApplicationComponents/pqParaViewMenuBuilders.cxx.orig 2016-11-15 01:41:57.000000000 +1000
+++ Qt/ApplicationComponents/pqParaViewMenuBuilders.cxx 2016-07-28 15:10:34.755501222 +1000 +++ Qt/ApplicationComponents/pqParaViewMenuBuilders.cxx 2016-11-16 11:34:49.709313333 +1000
@@ -323,8 +323,8 @@ @@ -322,9 +322,9 @@
#else
QString appdir = QCoreApplication::applicationDirPath(); QString appdir = QCoreApplication::applicationDirPath();
QString documentationPath = QFileInfo(appdir).fileName() == "bin" ? QString documentationPath = QFileInfo(appdir).fileName() == "bin"
- /* w/o shared forwarding */ appdir + "/../share/paraview-" PARAVIEW_VERSION "/doc" : ?
- /* w/o shared forwarding */ appdir + "/../share/paraview-" PARAVIEW_VERSION "/doc"
+ /* w/o shared forwarding */ appdir + "/../doc/paraview-" PARAVIEW_VERSION_FULL
:
- /* w/ shared forwarding */ appdir + "/../../share/paraview-" PARAVIEW_VERSION "/doc"; - /* w/ shared forwarding */ appdir + "/../../share/paraview-" PARAVIEW_VERSION "/doc";
+ /* w/o shared forwarding */ appdir + "/../doc/paraview-" PARAVIEW_VERSION_FULL :
+ /* w/ shared forwarding */ appdir + "/../../doc/paraview-" PARAVIEW_VERSION_FULL ; + /* w/ shared forwarding */ appdir + "/../../doc/paraview-" PARAVIEW_VERSION_FULL ;
#endif #endif
QString paraViewGuideFile = documentationPath + "/Guide.pdf"; QString paraViewGuideFile = documentationPath + "/Guide.pdf";
--- Qt/ApplicationComponents/pqWelcomeDialog.cxx.orig 2016-07-27 12:54:37.000000000 +1000 --- Qt/ApplicationComponents/pqWelcomeDialog.cxx.orig 2016-11-15 01:41:57.000000000 +1000
+++ Qt/ApplicationComponents/pqWelcomeDialog.cxx 2016-07-28 15:14:43.187484954 +1000 +++ Qt/ApplicationComponents/pqWelcomeDialog.cxx 2016-11-16 11:37:26.936328667 +1000
@@ -44,8 +44,8 @@ @@ -45,9 +45,9 @@
#else
QString appdir = QCoreApplication::applicationDirPath(); QString appdir = QCoreApplication::applicationDirPath();
QString documentationPath = QFileInfo(appdir).fileName() == "bin" ? QString documentationPath = QFileInfo(appdir).fileName() == "bin"
- /* w/o shared forwarding */ appdir + "/../share/paraview-" PARAVIEW_VERSION "/doc" : ?
- /* w/o shared forwarding */ appdir + "/../share/paraview-" PARAVIEW_VERSION "/doc"
+ /* w/o shared forwarding */ appdir + "/../doc/paraview-" PARAVIEW_VERSION_FULL
:
- /* w/ shared forwarding */ appdir + "/../../share/paraview-" PARAVIEW_VERSION "/doc"; - /* w/ shared forwarding */ appdir + "/../../share/paraview-" PARAVIEW_VERSION "/doc";
+ /* w/o shared forwarding */ appdir + "/../doc/paraview-" PARAVIEW_VERSION_FULL :
+ /* w/ shared forwarding */ appdir + "/../../doc/paraview-" PARAVIEW_VERSION_FULL ; + /* w/ shared forwarding */ appdir + "/../../doc/paraview-" PARAVIEW_VERSION_FULL ;
#endif #endif
QString paraViewGettingStartedFile = documentationPath + "/GettingStarted.pdf"; QString paraViewGettingStartedFile = documentationPath + "/GettingStarted.pdf";

View file

@ -1,11 +0,0 @@
--- Plugins/GeodesicMeasurementPlugin/FmmMesh/CMakeLists.txt.orig 2016-07-27 12:54:37.000000000 +1000
+++ Plugins/GeodesicMeasurementPlugin/FmmMesh/CMakeLists.txt 2016-07-28 10:09:59.293353301 +1000
@@ -59,6 +59,6 @@
install(TARGETS ${PROJECT_NAME}
RUNTIME DESTINATION bin
- LIBRARY DESTINATION lib
- ARCHIVE DESTINATION lib
+ LIBRARY DESTINATION lib${LIB_SUFFIX}
+ ARCHIVE DESTINATION lib${LIB_SUFFIX}
)

View file

@ -1,11 +0,0 @@
--- Plugins/PythonQtPlugin/wrapped_methods.txt.orig 2016-07-27 12:54:37.000000000 +1000
+++ Plugins/PythonQtPlugin/wrapped_methods.txt 2016-08-10 13:29:43.934593466 +1000
@@ -19,7 +19,7 @@
pqServerManagerModel* pqApplicationCore::getServerManagerModel() const
-QWidget* pqRenderViewBase::getWidget()
+QWidget* pqRenderViewBase::widget()
void pqRenderView::resetCamera()

View file

@ -0,0 +1,35 @@
# Upstream patch to fix building of PythonQt plugin.
# From http://gitlab.kitware.com/paraview/paraview/merge_requests/1201/diffs
#
diff --git a/Plugins/PythonQtPlugin/CMakeLists.txt b/Plugins/PythonQtPlugin/CMakeLists.txt
index d87853b..d249961 100644
--- a/Plugins/PythonQtPlugin/CMakeLists.txt
+++ b/Plugins/PythonQtPlugin/CMakeLists.txt
@@ -7,6 +7,8 @@ else()
include(${PARAVIEW_USE_FILE})
endif()
+include(ParaViewQt)
+pv_find_package_qt(qt_targets REQUIRED QT4_COMPONENTS QtGui QT5_COMPONENTS Widgets)
set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR})
find_package(PythonQt REQUIRED)
@@ -23,17 +25,7 @@ set(PythonQtPlugin_MOC_SRCS
pqPythonEventFilter.h
)
-if (PARAVIEW_QT_VERSION VERSION_GREATER "4")
- qt5_wrap_cpp(MOC_SRCS
- ${PythonQtPlugin_MOC_SRCS}
- ${decorator_file}
- )
-else ()
- qt4_wrap_cpp(MOC_SRCS
- ${PythonQtPlugin_MOC_SRCS}
- ${decorator_file}
- )
-endif ()
+pv_qt_wrap_cpp(MOC_SRCS ${PythonQtPlugin_MOC_SRCS} ${decorator_file})
set(srcs
pqPythonQtPlugin.cxx

View file

@ -13,10 +13,3 @@ Optional embedding with PythonQt may be enabled by setting
PYTHONQT=yes PYTHONQT=yes
in the build environment. This requires the SBo PythonQt package to be in the build environment. This requires the SBo PythonQt package to be
installed at build time. installed at build time.
This build incorporates the ParaView "Getting Started" and "Tutorial"
documentation. In addition, the official ParaView Guide is available from:
http://www.paraview.org/files/v5.1/ParaViewGuide-5.1.0.pdf
For access to the Guide directly from the ParaView graphical interface
(using Help menu or F1 key), it should be stored as
/usr/doc/paraview-5.1.2/Guide.pdf

View file

@ -1,26 +0,0 @@
The source tarball was generated from the official Paraview git repository at
https://gitlab.kitware.com/paraview/paraview
with third party modules (e.g. VTK) already included, rather than retrieving
them at build time. Should this need to be replicated, checkout the 5.1.2 branch
of the ParaView git repository and initialise the submodules as shown in the
session output below:
chris@d6:/tmp/paraview-5.1.2$ git br
* 5.1.2
master
chris@d6:/tmp/paraview-5.1.2$ git submodule update --init
Submodule 'ThirdParty/IceT/vtkicet' (https://gitlab.kitware.com/icet/icet.git) registered for path 'ThirdParty/IceT/vtkicet'
Submodule 'ThirdParty/QtTesting/vtkqttesting' (https://github.com/Kitware/QtTesting.git) registered for path 'ThirdParty/QtTesting/vtkqttesting'
Submodule 'ThirdParty/protobuf/vtkprotobuf' (https://gitlab.kitware.com/paraview/protobuf.git) registered for path 'ThirdParty/protobuf/vtkprotobuf'
Submodule 'Utilities/VisItBridge' (https://gitlab.kitware.com/paraview/visitbridge.git) registered for path 'Utilities/VisItBridge'
Submodule 'VTK' (https://gitlab.kitware.com/vtk/vtk.git) registered for path 'VTK'
Cloning into '/tmp/paraview-5.1.2/ThirdParty/IceT/vtkicet'...
Cloning into '/tmp/paraview-5.1.2/ThirdParty/QtTesting/vtkqttesting'...
Cloning into '/tmp/paraview-5.1.2/ThirdParty/protobuf/vtkprotobuf'...
Cloning into '/tmp/paraview-5.1.2/Utilities/VisItBridge'...
Cloning into '/tmp/paraview-5.1.2/VTK'...
Submodule path 'ThirdParty/IceT/vtkicet': checked out '0d08b037f3fa8b6e1a82ed2beb84e024c06f895f'
Submodule path 'ThirdParty/QtTesting/vtkqttesting': checked out '706d5cd1bbdd0658802da63b940c8bb2d1f3d192'
Submodule path 'ThirdParty/protobuf/vtkprotobuf': checked out '3637bc9efc2c29c54ee907e4341e39127599c4ec'
Submodule path 'Utilities/VisItBridge': checked out 'f8dd33fcfd025fd5b878b07f4d2e7deb5573e379'
Submodule path 'VTK': checked out '31b13ea55f8db68b64e9412b7896e0e8110aedfe'

View file

@ -23,9 +23,10 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=paraview PRGNAM=paraview
VERSION=${VERSION:-5.1.2} SRCNAM=ParaView
SHORT_VERSION=${SHORT_VERSION:-5.1} VERSION=${VERSION:-5.2.0}
BUILD=${BUILD:-3} SHORT_VERSION=${SHORT_VERSION:-5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo} TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then if [ -z "$ARCH" ]; then
@ -69,12 +70,11 @@ set -e
rm -rf $PKG rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT mkdir -p $TMP $PKG $OUTPUT
cd $TMP cd $TMP
rm -rf $PRGNAM-$VERSION rm -rf $SRCNAM-v$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz tar xvf $CWD/$SRCNAM-v$VERSION.tar.gz
cd $PRGNAM-$VERSION cd $SRCNAM-v$VERSION
patch -p0 < $CWD/010_doc_path.diff patch -p0 < $CWD/010_doc_path.diff
patch -p0 < $CWD/020_fmmmesh_lib_path.diff patch -p1 < $CWD/1201.diff
patch -p0 < $CWD/030_pythonqt-getWidget.diff
sed -i -e 's/@PARAVIEW_VERSION_FULL@/1.0/' Applications/ParaView/paraview.desktop.in sed -i -e 's/@PARAVIEW_VERSION_FULL@/1.0/' Applications/ParaView/paraview.desktop.in
echo "Exec=paraview" >> Applications/ParaView/paraview.desktop.in echo "Exec=paraview" >> Applications/ParaView/paraview.desktop.in
echo "Categories=Development;Graphics" >> Applications/ParaView/paraview.desktop.in echo "Categories=Development;Graphics" >> Applications/ParaView/paraview.desktop.in
@ -147,7 +147,8 @@ cp -a \
CONTRIBUTING.* Copyright.* License_v1.2.txt README.* version.txt \ CONTRIBUTING.* Copyright.* License_v1.2.txt README.* version.txt \
$PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/doc/$PRGNAM-$VERSION
cp $CWD/ParaViewTutorial.pdf $PKG/usr/doc/$PRGNAM-$VERSION/Tutorial.pdf cp $CWD/ParaViewTutorial.pdf $PKG/usr/doc/$PRGNAM-$VERSION/Tutorial.pdf
cp $CWD/ParaViewGettingStarted-5.1.0.pdf $PKG/usr/doc/$PRGNAM-$VERSION/GettingStarted.pdf cp $CWD/ParaViewGettingStarted-5.2.0.pdf $PKG/usr/doc/$PRGNAM-$VERSION/GettingStarted.pdf
cp $CWD/ParaViewGuide-5.2.0.pdf $PKG/usr/doc/$PRGNAM-$VERSION/Guide.pdf
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install mkdir -p $PKG/install

View file

@ -1,13 +1,15 @@
PRGNAM="paraview" PRGNAM="paraview"
VERSION="5.1.2" VERSION="5.2.0"
HOMEPAGE="http://www.paraview.org" HOMEPAGE="http://www.paraview.org"
DOWNLOAD="http://sourceforge.net/projects/slackbuildsdirectlinks/files/ParaView/paraview-5.1.2.tar.gz \ DOWNLOAD="http://www.paraview.org/files/v5.2/ParaView-v5.2.0.tar.gz \
http://www.paraview.org/Wiki/images/5/5d/ParaViewTutorialData.tar.gz \ http://www.paraview.org/Wiki/images/5/5d/ParaViewTutorialData.tar.gz \
http://www.paraview.org/files/v5.1/ParaViewTutorial.pdf \ http://www.paraview.org/files/v5.2/ParaViewGuide-5.2.0.pdf \
http://www.paraview.org/files/v5.1/ParaViewGettingStarted-5.1.0.pdf" http://www.paraview.org/files/v5.2/ParaViewTutorial.pdf \
MD5SUM="6df8f5d6a5ce2d82d6d75b76308c65ad \ http://www.paraview.org/files/v5.2/ParaViewGettingStarted-5.2.0.pdf"
MD5SUM="4570d1a2a183026adb65b73c7125b8b0 \
0a4c2a37b8e566ccdb3b1eaaa949477a \ 0a4c2a37b8e566ccdb3b1eaaa949477a \
4b1c410cd461f68a3bac5839c22bee93 \ 08b1d0dafbe50f2241da7a4a4e2b0b75 \
1b3d975eac73bca412414efb2af9974c \
7ce54ce8a8b36c746035c2b228713074" 7ce54ce8a8b36c746035c2b228713074"
DOWNLOAD_x86_64="" DOWNLOAD_x86_64=""
MD5SUM_x86_64="" MD5SUM_x86_64=""