mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
games/chocolate-doom: Updated for version 2.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
294efdfe65
commit
1b873a3c65
6 changed files with 55 additions and 33 deletions
|
@ -1,11 +1,27 @@
|
|||
Chocolate Doom is a Doom source port that accurately reproduces the
|
||||
experience of Doom as it was played in the 1990s
|
||||
experience of Doom as it was played in the 1990s.
|
||||
|
||||
To play the game, you will need at least one of:
|
||||
Starting with version 2.0.0, Chocolate Doom also supports Heretic, Hexen,
|
||||
and Strife.
|
||||
|
||||
doom2.wad from Doom II
|
||||
doom.wad from Registered Doom or Ultimate Doom
|
||||
tnt.wad or plutonia.wad from Final Doom
|
||||
doom1.wad from Shareware Doom (available on SBo as doom_shareware_data)
|
||||
To play chocolate-doom, you need at least one of:
|
||||
doom2.wad from Doom II
|
||||
doom.wad from Registered Doom or Ultimate Doom
|
||||
tnt.wad or plutonia.wad from Final Doom
|
||||
doom1.wad from Shareware Doom (doom_shareware_data on SBo)
|
||||
|
||||
For chocolate-heretic:
|
||||
heretic.wad from Registered Heretic
|
||||
heretic1.wad from Shareware Heretic (heretic_shareware_data on SBo)
|
||||
|
||||
For chocolate-hexen:
|
||||
hexen.wad from Registered Hexen
|
||||
hexdemo.wad from the Hexen demo (hexen_demo_data on SBo)
|
||||
|
||||
For chocolate-strife:
|
||||
strife1.wad from Registered Strife
|
||||
|
||||
Place the WAD file(s) in /usr/share/games/doom.
|
||||
|
||||
freedoom doesn't work with Chocolate Doom. Neither does strife0.wad from
|
||||
the Strife demo. Chex Quest might work (not tested by SlackBuild author).
|
||||
|
|
|
@ -4,11 +4,11 @@
|
|||
|
||||
# Written by B. Watson (yalhcru@gmail.com)
|
||||
|
||||
# Licensed under the WTFPL. See http://sam.zoy.org/wtfpl/ for details.
|
||||
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
|
||||
|
||||
PRGNAM=chocolate-doom
|
||||
VERSION=${VERSION:-1.7.0}
|
||||
BUILD=${BUILD:-2}
|
||||
VERSION=${VERSION:-2.0.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -70,19 +70,33 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
make install-strip DESTDIR=$PKG
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
# install-strip fails to strip the *-setup binaries.
|
||||
strip $PKG/usr/games/*
|
||||
|
||||
# Grrr. --docdir is being ignored.
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rm -rf $PKG/usr/share/doc
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
gzip -9 $PKG/usr/man/man?/*
|
||||
|
||||
# Move icons to standard Slackware pixmap icon dir:
|
||||
mv $PKG/usr/share/icons $PKG/usr/share/pixmaps
|
||||
|
||||
# Upstream doesn't include .desktop files or icons for the other games,
|
||||
# we'll generate them.
|
||||
cd $PKG/usr/share/applications
|
||||
for GAME in Heretic Hexen Strife; do
|
||||
game="$( echo $GAME | tr A-Z a-z )"
|
||||
sed -e "s,Doom,$GAME,g" -e "s,doom,$game,g" \
|
||||
$PRGNAM.desktop \
|
||||
> chocolate-$game.desktop
|
||||
ln -s $PRGNAM.png $PKG/usr/share/pixmaps/chocolate-$game.png
|
||||
done
|
||||
cd -
|
||||
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="chocolate-doom"
|
||||
VERSION="1.7.0"
|
||||
VERSION="2.0.0"
|
||||
HOMEPAGE="http://www.chocolate-doom.org/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/chocolate-doom/chocolate-doom-1.7.0.tar.gz"
|
||||
MD5SUM="c0a8b240e5c1db9fc1d4772ed6669fda"
|
||||
DOWNLOAD="http://www.chocolate-doom.org/downloads/2.0.0/chocolate-doom-2.0.0.tar.gz"
|
||||
MD5SUM="5551fe8e319ff4a49848234faaa6df4f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
diff -Naur chocolate-doom-1.6.0/configure.in chocolate-doom-1.6.0.patched/configure.in
|
||||
--- chocolate-doom-1.6.0/configure.in 2011-05-17 19:01:50.000000000 -0400
|
||||
+++ chocolate-doom-1.6.0.patched/configure.in 2012-09-20 01:32:26.000000000 -0400
|
||||
@@ -103,7 +103,7 @@
|
||||
esac
|
||||
diff -Naur chocolate-doom-2.0.0/configure.ac chocolate-doom-2.0.0.patched/configure.ac
|
||||
--- chocolate-doom-2.0.0/configure.ac 2013-12-09 00:40:53.000000000 -0500
|
||||
+++ chocolate-doom-2.0.0.patched/configure.ac 2014-03-20 14:54:11.000000000 -0400
|
||||
@@ -90,7 +90,7 @@
|
||||
AC_CHECK_TOOL(WINDRES, windres, )
|
||||
AC_CHECK_TOOL(STRIP, strip, )
|
||||
|
||||
AM_CONDITIONAL(WINDOWS_CE, $WINDOWS_CE)
|
||||
-AM_CONDITIONAL(HAVE_WINDRES, test "$WINDRES" != "")
|
||||
+AM_CONDITIONAL(HAVE_WINDRES, false)
|
||||
AM_CONDITIONAL(HAVE_PYTHON, $HAVE_PYTHON)
|
||||
|
|
|
@ -1,11 +1,3 @@
|
|||
|
||||
if [ -x /usr/bin/update-desktop-database ]; then
|
||||
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
|
||||
fi
|
||||
|
||||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
||||
|
||||
|
|
|
@ -9,10 +9,10 @@
|
|||
chocolate-doom: chocolate-doom (Doom source port)
|
||||
chocolate-doom:
|
||||
chocolate-doom: Chocolate Doom is a Doom source port that accurately reproduces the
|
||||
chocolate-doom: experience of Doom as it was played in the 1990s
|
||||
chocolate-doom:
|
||||
chocolate-doom:
|
||||
chocolate-doom:
|
||||
chocolate-doom: experience of Doom as it was played in the 1990s.
|
||||
chocolate-doom:
|
||||
chocolate-doom: Starting with version 2.0.0, Chocolate Doom also supports Heretic,
|
||||
chocolate-doom: Hexen, and Strife.
|
||||
chocolate-doom:
|
||||
chocolate-doom:
|
||||
chocolate-doom:
|
||||
|
|
Loading…
Reference in a new issue