mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
graphics/mangohud: Updated for version 0.6.8.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
4828180411
commit
18ce2e1a43
6 changed files with 32 additions and 15 deletions
|
@ -14,7 +14,7 @@ the build script.
|
|||
This SlackBuild defaults to building mangoapp as well. To
|
||||
disable this behavior, pass MANGOAPP=false to the build
|
||||
script. This removes the dependency on glfw3 and
|
||||
nlohmann_json's include.zip
|
||||
nlohmann_json.
|
||||
|
||||
If you would like multilib support, pass COMPAT32=yes to
|
||||
the build script. Please note that this only adds 32bit
|
||||
|
|
5
graphics/mangohud/doinst.sh
Normal file
5
graphics/mangohud/doinst.sh
Normal file
|
@ -0,0 +1,5 @@
|
|||
if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
|
||||
fi
|
||||
fi
|
|
@ -26,8 +26,8 @@ cd $(dirname $0) ; CWD=$(pwd)
|
|||
|
||||
PRGNAM=mangohud
|
||||
SRCNAM=MangoHud
|
||||
VERSION=${VERSION:-0.6.7.1}
|
||||
SRCVER=${SRCVER:-0.6.7-1}
|
||||
VERSION=${VERSION:-0.6.8}
|
||||
SRCVER=${SRCVER:-0.6.8}
|
||||
IMGUIVER=${IMGUIVER:-1.81}
|
||||
SPDLOGVER=${SPDLOGVER:-1.8.5}
|
||||
BUILD=${BUILD:-1}
|
||||
|
@ -82,18 +82,19 @@ tar xvf $CWD/imgui-$IMGUIVER.tar.gz
|
|||
unzip $CWD/imgui_$IMGUIVER-1_patch.zip
|
||||
tar xvf $CWD/spdlog-$SPDLOGVER.tar.gz
|
||||
unzip $CWD/spdlog_$SPDLOGVER-1_patch.zip
|
||||
if [ "$MANGOAPP" = "true" ]; then
|
||||
unzip $CWD/include.zip -d nlohmann_json-3.10.5
|
||||
fi
|
||||
cd ..
|
||||
chown -R root:root .
|
||||
|
||||
#Slackware 15.0 ships meson 59.4, and mangohud requires 60.0, so we patch it.
|
||||
patch -p0 <$CWD/meson594.patch
|
||||
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
|
||||
mkdir build
|
||||
cd build
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
@ -155,6 +156,8 @@ rm -rf $PKG/usr/share/doc
|
|||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
||||
|
|
|
@ -1,20 +1,18 @@
|
|||
PRGNAM="mangohud"
|
||||
VERSION="0.6.7.1"
|
||||
VERSION="0.6.8"
|
||||
HOMEPAGE="https://github.com/flightlessmango/MangoHud"
|
||||
DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.7-1/MangoHud-0.6.7-1.tar.gz \
|
||||
DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.8/MangoHud-0.6.8.tar.gz \
|
||||
https://github.com/ocornut/imgui/archive/v1.81/imgui-1.81.tar.gz \
|
||||
https://github.com/mesonbuild/wrapdb/releases/download/imgui_1.81-1/imgui_1.81-1_patch.zip \
|
||||
https://github.com/gabime/spdlog/archive/v1.8.5/spdlog-1.8.5.tar.gz \
|
||||
https://github.com/mesonbuild/wrapdb/releases/download/spdlog_1.8.5-1/spdlog_1.8.5-1_patch.zip \
|
||||
https://github.com/nlohmann/json/releases/download/v3.10.5/include.zip"
|
||||
MD5SUM="61f3a5e392cb08fc1c263ea89781b0d4 \
|
||||
https://github.com/mesonbuild/wrapdb/releases/download/spdlog_1.8.5-1/spdlog_1.8.5-1_patch.zip"
|
||||
MD5SUM="414f8b321ec9e548e4f9ebed4f0d645c \
|
||||
9b48ac38829b538233f99c0aa8cacf50 \
|
||||
ea266ae77ac14290ceb2eafa56c1de83 \
|
||||
8755cdbc857794730a022722a66d431a \
|
||||
73a3c3149a4aa2b105aeef3a1d45bcb0 \
|
||||
3cea575f0b559e2609507a5ee6469dea"
|
||||
73a3c3149a4aa2b105aeef3a1d45bcb0"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="glfw3 %README%"
|
||||
REQUIRES="glfw3 nlohmann_json %README%"
|
||||
MAINTAINER="Steven Voges"
|
||||
EMAIL="svoges.sbo@gmail.com"
|
||||
|
|
11
graphics/mangohud/meson594.patch
Normal file
11
graphics/mangohud/meson594.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- meson.build 2022-07-31 18:27:11.000000000 -0700
|
||||
+++ meson.build 2022-08-14 01:07:17.385862414 -0700
|
||||
@@ -2,7 +2,7 @@
|
||||
['c', 'cpp'],
|
||||
version : 'v0.6.8',
|
||||
license : 'MIT',
|
||||
- meson_version: '>=0.60.0',
|
||||
+ meson_version: '>=0.59.4',
|
||||
default_options : ['buildtype=release', 'c_std=c99', 'cpp_std=c++14', 'warning_level=2']
|
||||
)
|
||||
|
|
@ -6,7 +6,7 @@
|
|||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
mangohud: mangohud (Vulkan/OpenGL Overlay)
|
||||
mangohud: mangohud (Performance Overlay)
|
||||
mangohud:
|
||||
mangohud: MangoHud is a Vulkan and OpenGL overlay for monitoring FPS,
|
||||
mangohud: temperatures, CPU/GPU load and more.
|
||||
|
|
Loading…
Reference in a new issue