mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-25 10:03:03 +01:00
network/nagios: Updated for version 3.4.3, cleanups.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
c1001c96d0
commit
17243302b7
3 changed files with 7 additions and 29 deletions
|
@ -3,7 +3,7 @@
|
|||
# Slackware build script for nagios:
|
||||
# IT infrastructure monitoring system
|
||||
|
||||
# Copyright 2009-2011 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# Copyright 2009-2012 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,10 +23,10 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# revision date 2011/07/26
|
||||
# revision date 2012/12/27
|
||||
|
||||
PRGNAM=nagios
|
||||
VERSION=${VERSION:-3.3.1}
|
||||
VERSION=${VERSION:-3.4.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -54,23 +54,15 @@ OUTPUT=${OUTPUT:-/tmp}
|
|||
if [ "$ARCH" = "i486" ]; then
|
||||
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
ARCHQUADLET=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
ARCHQUADLET=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
ARCHQUADLET=""
|
||||
elif [ "$ARCH" = "arm" ]; then
|
||||
SLKCFLAGS="-O2 -march=armv4t"
|
||||
LIBDIRSUFFIX=""
|
||||
ARCHQUADLET="-gnueabi"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
ARCHQUADLET=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
@ -92,9 +84,6 @@ cd $PRGNAM
|
|||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
#Solve a silly bug in the Makefile
|
||||
patch -p1 < $CWD/nagios_makeinstall.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
|
@ -105,7 +94,7 @@ CFLAGS="$SLKCFLAGS" \
|
|||
--sysconfdir=/etc/$PRGNAM \
|
||||
--localstatedir=/var/$PRGNAM \
|
||||
--mandir=/usr/man \
|
||||
--build=$ARCH-slackware-linux$ARCHQUADLET \
|
||||
--build=$ARCH-slackware-linux \
|
||||
--with-httpd-conf=/etc/httpd/extra \
|
||||
--with-checkresult-dir=/var/spool/$PRGNAM \
|
||||
--with-init-dir=/etc/rc.d \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="nagios"
|
||||
VERSION="3.3.1"
|
||||
VERSION="3.4.3"
|
||||
HOMEPAGE="http://www.nagios.org/"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/nagios/nagios-3.3.1.tar.gz"
|
||||
MD5SUM="c935354ce0d78a63bfabc3055fa77ad5"
|
||||
DOWNLOAD="http://downloads.sourceforge.net/nagios/nagios-3.4.3.tar.gz"
|
||||
MD5SUM="adb04a255a3bb1574840ebd4a0f2eb76"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- nagios/html/Makefile.in 2011-07-24 14:53:52.000000000 -0300
|
||||
+++ nagios_patched/html/Makefile.in 2011-07-26 20:56:28.000000000 -0300
|
||||
@@ -75,7 +75,7 @@
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images/logos; done
|
||||
for file in includes/*.*; \
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes; done
|
||||
- for file in includes/rss/*; \
|
||||
+ for file in $$(find includes/rss -type f -maxdepth 1); \
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss; done
|
||||
for file in includes/rss/extlib/*; \
|
||||
do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/includes/rss/extlib; done
|
Loading…
Reference in a new issue