mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
network/deis: Updated for version 1.6.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
parent
7f1d5edd71
commit
1719eeb1ee
3 changed files with 5 additions and 32 deletions
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=deis
|
||||
VERSION=${VERSION:-1.6.0}
|
||||
VERSION=${VERSION:-1.6.1}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -69,8 +69,6 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/setup.patch
|
||||
|
||||
python setup.py install --root=$PKG
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="deis"
|
||||
VERSION="1.6.0"
|
||||
VERSION="1.6.1"
|
||||
HOMEPAGE="http://deis.io/"
|
||||
DOWNLOAD="https://pypi.python.org/packages/source/d/deis/deis-1.6.0.tar.gz"
|
||||
MD5SUM="587cbc1ab9ea7d6c1436b0309e634f72"
|
||||
DOWNLOAD="https://pypi.python.org/packages/source/d/deis/deis-1.6.1.tar.gz"
|
||||
MD5SUM="dda95188c7bb4562c97eeeefc4eed8f9"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="docopt python-dateutil python-requests termcolor PyYAML python-tabulate python-urllib3"
|
||||
REQUIRES="docopt python-dateutil python-requests termcolor PyYAML python-tabulate python-urllib3 ndg_httpsclient"
|
||||
MAINTAINER="Dimitris Zlatanidis"
|
||||
EMAIL="d.zlatanidis@gmail.com"
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
--- deis-1.6.0/setup.orig.py 2015-05-09 03:43:01.776728194 +0300
|
||||
+++ deis-1.6.0/setup.py 2015-05-09 03:44:20.037749797 +0300
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
"""Install the Deis command-line client."""
|
||||
|
||||
+import os
|
||||
|
||||
try:
|
||||
from setuptools import setup
|
||||
@@ -27,9 +28,11 @@
|
||||
KWARGS = {'scripts': ['deis']}
|
||||
|
||||
|
||||
-with open('requirements.txt') as f:
|
||||
- required = f.read().splitlines()
|
||||
- required = [r for r in required if r.strip() and not r.startswith('#')]
|
||||
+required = ""
|
||||
+if os.path.isfile('requirements.txt'):
|
||||
+ with open('requirements.txt') as f:
|
||||
+ required = f.read().splitlines()
|
||||
+ required = [r for r in required if r.strip() and not r.startswith('#')]
|
||||
|
||||
|
||||
setup(name='deis',
|
Loading…
Reference in a new issue