mirror of
https://github.com/Ponce/slackbuilds
synced 2024-12-02 13:04:42 +01:00
games/openclonk: Updated for version 7.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
This commit is contained in:
parent
f65c79aed4
commit
15ad456d8c
4 changed files with 50 additions and 18 deletions
|
@ -1,11 +0,0 @@
|
|||
--- openclonk-5.5.1/CMakeLists.orig 2015-02-20 12:19:12.760304874 +0200
|
||||
+++ openclonk-5.5.1/CMakeLists.txt 2015-02-20 12:20:39.503220438 +0200
|
||||
@@ -1347,7 +1347,7 @@
|
||||
endif()
|
||||
|
||||
if(USE_BOOST_REGEX)
|
||||
- SET(Boost_USE_STATIC_LIBS ${USE_STATIC_BOOST})
|
||||
+ SET(Boost_USE_STATIC_LIBS/usr/include/boost ${USE_STATIC_BOOST})
|
||||
find_package(Boost 1.40.0 REQUIRED COMPONENTS regex)
|
||||
# Disable automatic linking, we'll do it ourselves
|
||||
add_definitions(-DBOOST_REGEX_NO_LIB)
|
42
games/openclonk/findreadline.patch
Normal file
42
games/openclonk/findreadline.patch
Normal file
|
@ -0,0 +1,42 @@
|
|||
--- openclonk-7.0/cmake/FindReadline.orig.cmake 2016-02-15 06:17:40.060057466 +0200
|
||||
+++ openclonk-7.0/cmake/FindReadline.cmake 2016-02-15 06:20:18.585067004 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
# OpenClonk, http://www.openclonk.org
|
||||
#
|
||||
-# Copyright (c) 2011-2013, The OpenClonk Team and contributors
|
||||
+# Copyright (c) 2011-2016, The OpenClonk Team and contributors
|
||||
#
|
||||
# Distributed under the terms of the ISC license; see accompanying file
|
||||
# "COPYING" for details.
|
||||
@@ -26,6 +26,14 @@
|
||||
|
||||
FIND_PATH(READLINE_INCLUDE_DIR readline.h PATH_SUFFIXES readline)
|
||||
|
||||
+# Unmodified readline depends on symbols from termcap without explicitly
|
||||
+# linking to it. Several distributions patch this to make it link against
|
||||
+# terminfo from ncurses or another termcap library, but some don't. To avoid
|
||||
+# having to run link tests, we'll just look for and use any termcap providing
|
||||
+# library.
|
||||
+FIND_LIBRARY(TERMCAP_LIBRARY NAMES tinfo termcap ncursesw ncurses cursesw curses)
|
||||
+
|
||||
+
|
||||
SET(READLINE_NAMES readline libreadline)
|
||||
FIND_LIBRARY(READLINE_LIBRARY NAMES ${READLINE_NAMES} )
|
||||
|
||||
@@ -35,10 +43,13 @@
|
||||
FIND_PACKAGE_HANDLE_STANDARD_ARGS(READLINE DEFAULT_MSG READLINE_LIBRARY READLINE_INCLUDE_DIR)
|
||||
|
||||
IF(READLINE_FOUND)
|
||||
- SET( READLINE_LIBRARIES ${READLINE_LIBRARY} )
|
||||
+ if(TERMCAP_LIBRARY)
|
||||
+ set(READLINE_LIBRARIES ${READLINE_LIBRARY} ${TERMCAP_LIBRARY})
|
||||
+ else()
|
||||
+ set(READLINE_LIBRARIES ${READLINE_LIBRARY})
|
||||
+ endif()
|
||||
ELSE(READLINE_FOUND)
|
||||
SET( READLINE_LIBRARIES )
|
||||
ENDIF(READLINE_FOUND)
|
||||
|
||||
-MARK_AS_ADVANCED( READLINE_LIBRARY READLINE_INCLUDE_DIR )
|
||||
-
|
||||
+MARK_AS_ADVANCED( READLINE_LIBRARY TERMINFO_LIBRARY READLINE_INCLUDE_DIR )
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for openclonk
|
||||
|
||||
# Copyright 2014-2015 Dimitris Zlatanidis Orestiada, Greece
|
||||
# Copyright 2014-2016 Dimitris Zlatanidis Orestiada, Greece
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=openclonk
|
||||
VERSION=${VERSION:-6.0}
|
||||
VERSION=${VERSION:-7.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -69,13 +69,14 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
patch -p1 < $CWD/boost.patch
|
||||
patch -p1 < $CWD/findreadline.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||
-DREADLINE_LIBRARIES="/usr/lib$LIBDIRSUFFIX" \
|
||||
-DCMAKE_INSTALL_PREFIX=/usr \
|
||||
-DCMAKE_BUILD_TYPE=Release ..
|
||||
make
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="openclonk"
|
||||
VERSION="6.0"
|
||||
VERSION="7.0"
|
||||
HOMEPAGE="http://www.openclonk.org/"
|
||||
DOWNLOAD="https://github.com/openclonk/openclonk/archive/v6.0.tar.gz"
|
||||
MD5SUM="3e5e37c8ae2e9a9e3fc3b6d4b3803cf1"
|
||||
DOWNLOAD="https://github.com/openclonk/openclonk/archive/v7.0.tar.gz"
|
||||
MD5SUM="eae6414c4b55d14657443a8396731f52"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="freealut gtksourceview libupnp gtest"
|
||||
REQUIRES="freealut gtksourceview3 libupnp"
|
||||
MAINTAINER="Dimitris Zlatanidis"
|
||||
EMAIL="d.zlatanidis@gmail.com"
|
||||
|
|
Loading…
Reference in a new issue