libraries/miniupnpc: Added (UPnP Control Point library)

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Larry Hajali 2011-12-17 22:10:44 -06:00 committed by Robby Workman
parent 654558a4b3
commit 140fa35076
5 changed files with 143 additions and 0 deletions

View file

@ -0,0 +1,3 @@
MiniUPnPc, the client library, enabling applications to access the
services provided by an UPnP "Internet Gateway Device" present on
the network. In UPnP terminology, it is a UPnP Control Point.

View file

@ -0,0 +1,83 @@
#!/bin/sh
# Slackware build script for miniupnpc
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=miniupnpc
VERSION=${VERSION:-1.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Slackware/Slackbuilds.org specific info.
patch -p1 < $CWD/slackware-version.patch
sed -i -e "/^CFLAGS/ s|-O|$SLKCFLAGS|" Makefile
# Upstream Cmake causes build problems. We're going to use the makefile instead.
make
make install PREFIX=$PKG INSTALLDIRLIB="$PKG/usr/lib$LIBDIRSUFFIX"
python setup.py install --root=$PKG
# Remove static library.
rm -f $PKG/usr/lib$LIBDIRSUFFIX/lib$PRGNAM.a
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
install -D -m 0644 man3/$PRGNAM.3 $PKG/usr/man/man3/$PRGNAM.3
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
Changelog.txt LICENSE README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -0,0 +1,10 @@
PRGNAM="miniupnpc"
VERSION="1.6"
HOMEPAGE="http://miniupnp.free.fr/"
DOWNLOAD="http://miniupnp.free.fr/files/miniupnpc-1.6.tar.gz"
MD5SUM="88055f2d4a061cfd4cfe25a9eae22f67"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"
APPROVED="rworkman"

View file

@ -0,0 +1,19 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
miniupnpc: miniupnpc (UPnP Control Point library)
miniupnpc:
miniupnpc: MiniUPnPc, the client library, enabling applications to access the
miniupnpc: services provided by an UPnP "Internet Gateway Device" present on the
miniupnpc: network. In UPnP terminology, it is a UPnP Control Point.
miniupnpc:
miniupnpc: Homepage: http://miniupnp.free.fr/
miniupnpc:
miniupnpc:
miniupnpc:
miniupnpc:

View file

@ -0,0 +1,28 @@
diff -Naur miniupnpc-1.6.orig/updateminiupnpcstrings.sh miniupnpc-1.6/updateminiupnpcstrings.sh
--- miniupnpc-1.6.orig/updateminiupnpcstrings.sh 2011-01-27 17:50:40.000000000 +0000
+++ miniupnpc-1.6/updateminiupnpcstrings.sh 2011-12-04 20:55:22.313144966 +0000
@@ -14,19 +14,11 @@
OS_NAME=Debian
OS_VERSION=`cat /etc/debian_version`
fi
-# use lsb_release (Linux Standard Base) when available
-LSB_RELEASE=`which lsb_release`
-if [ 0 -eq $? -a -x "${LSB_RELEASE}" ]; then
- OS_NAME=`${LSB_RELEASE} -i -s`
- OS_VERSION=`${LSB_RELEASE} -r -s`
- case $OS_NAME in
- Debian)
- #OS_VERSION=`${LSB_RELEASE} -c -s`
- ;;
- Ubuntu)
- #OS_VERSION=`${LSB_RELEASE} -c -s`
- ;;
- esac
+
+# Slackware specific stuff.
+if [ -f /etc/slackware-version ]; then
+ OS_NAME=`cat /etc/slackware-version | cut -d' ' -f1`
+ OS_VERSION=`cat /etc/slackware-version | cut -d' ' -f2`
fi
# on AmigaOS 3, uname -r returns "unknown", so we use uname -v