mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-16 19:50:19 +01:00
misc/langdrill: Added (language drill tests).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
b95c1cf740
commit
12e3c47e47
15 changed files with 1841 additions and 0 deletions
21
misc/langdrill/000_pkg_config.diff
Normal file
21
misc/langdrill/000_pkg_config.diff
Normal file
|
@ -0,0 +1,21 @@
|
|||
diff -ru langdrill-0.3-orig/src/Makefile langdrill-0.3/src/Makefile
|
||||
--- langdrill-0.3-orig/src/Makefile 2006-03-14 23:46:31.000000000 -0800
|
||||
+++ langdrill-0.3/src/Makefile 2006-03-14 23:48:17.000000000 -0800
|
||||
@@ -16,7 +16,7 @@
|
||||
DEF_FLAGS = -DTARGET='"$(TARGET)"' \
|
||||
-DDRILL_DEF='"$(DRILL_DEF)"' \
|
||||
-DDRILL_DIR='"$(DRILL_DIR)"' \
|
||||
- -I /usr/include/gtk-2.0/
|
||||
+ `pkg-config --cflags gtk+-2.0`
|
||||
|
||||
###### Test for Debian GNU/Linux
|
||||
# If your system is not Debian GNU/Linux please modify the values after
|
||||
@@ -37,7 +37,7 @@
|
||||
endif
|
||||
|
||||
CC = g++
|
||||
-LFLAGS = `vdk-config-2 --libs`
|
||||
+LFLAGS = `vdk-config-2 --libs` `pkg-config --libs gtk+-2.0`
|
||||
|
||||
|
||||
####### Implicit rules
|
33
misc/langdrill/010_cxx_standard.diff
Normal file
33
misc/langdrill/010_cxx_standard.diff
Normal file
|
@ -0,0 +1,33 @@
|
|||
--- langdrill-0.3.orig/src/config.hh
|
||||
+++ langdrill-0.3/src/config.hh
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
-#include <fstream.h>
|
||||
+#include <fstream>
|
||||
#include <stdlib.h>
|
||||
#include <vdk/dlist.h>
|
||||
|
||||
--- langdrill-0.3.orig/src/main.hh
|
||||
+++ langdrill-0.3/src/main.hh
|
||||
@@ -29,7 +29,7 @@
|
||||
#ifndef __main_hh__
|
||||
#define __main_hh__
|
||||
|
||||
-#include <fstream.h>
|
||||
+#include <fstream>
|
||||
#include <unistd.h>
|
||||
#include <time.h>
|
||||
|
||||
--- langdrill-0.3.orig/src/config.cc
|
||||
+++ langdrill-0.3/src/config.cc
|
||||
@@ -347,7 +347,7 @@
|
||||
char message[MAX_CHARS_FOR_MESSAGE];
|
||||
iconv_t direct = (iconv_t)-1, reverse = (iconv_t)-1;
|
||||
|
||||
- ifstream in(_name);
|
||||
+ std::ifstream in(_name);
|
||||
while(1){
|
||||
in.getline(buff,MAX_CHARS_FOR_STRING);
|
||||
lineNr++;
|
21
misc/langdrill/010_min_max.diff
Normal file
21
misc/langdrill/010_min_max.diff
Normal file
|
@ -0,0 +1,21 @@
|
|||
The minimum and maximum operators were never terribly portable and have
|
||||
been dropped by GCC 4.2.
|
||||
Index: langdrill-0.3/src/main.cc
|
||||
===================================================================
|
||||
--- langdrill-0.3.orig/src/main.cc 2007-07-15 12:52:38.000000000 +0100
|
||||
+++ langdrill-0.3/src/main.cc 2007-07-15 12:54:01.000000000 +0100
|
||||
@@ -460,9 +460,11 @@
|
||||
// keys. In such a case, we must take some precations
|
||||
setActiveButtons( keyTotalNr );
|
||||
|
||||
- // is this minimum operator portable ??
|
||||
- // it should work with egcs at least !!
|
||||
- int cols = keyTotalNr <? atoi(_setup.quizzAnswerNr);
|
||||
+ int cols;
|
||||
+ if (keyTotalNr < atoi(_setup.quizzAnswerNr))
|
||||
+ cols = keyTotalNr;
|
||||
+ else
|
||||
+ cols = atoi(_setup.quizzAnswerNr);
|
||||
|
||||
int rows = keyTotalNr;
|
||||
int *set = new int[cols];
|
61
misc/langdrill/010_vdk_updates.diff
Normal file
61
misc/langdrill/010_vdk_updates.diff
Normal file
|
@ -0,0 +1,61 @@
|
|||
--- langdrill-0.3.orig/src/main.cc
|
||||
+++ langdrill-0.3/src/main.cc
|
||||
@@ -962,17 +962,17 @@
|
||||
MyLangForm::AboutClicked( VDKObject*)
|
||||
{
|
||||
Application()->
|
||||
- MessageBox( " Let's talk about Language Drills",
|
||||
- " Brought to you by\n"
|
||||
- " Ionutz Borcoman\n"
|
||||
- " <borco@usa.net>\n"
|
||||
- " <borco@borco-ei.eng.hokudai.ac.jp>\n"
|
||||
- " \n"
|
||||
- " Nothing would have been possible without\n"
|
||||
- " Mario Motta's VDK\n"
|
||||
- " <mmotta@guest.net>"
|
||||
- "\n",
|
||||
- MB_OK | MB_ICONINFORMATION ) ;
|
||||
+ VDKMessageBox( " Let's talk about Language Drills",
|
||||
+ " Brought to you by\n"
|
||||
+ " Ionutz Borcoman\n"
|
||||
+ " <borco@usa.net>\n"
|
||||
+ " <borco@borco-ei.eng.hokudai.ac.jp>\n"
|
||||
+ " \n"
|
||||
+ " Nothing would have been possible without\n"
|
||||
+ " Mario Motta's VDK\n"
|
||||
+ " <mmotta@guest.net>"
|
||||
+ "\n",
|
||||
+ VDK_OK | VDK_ICONINFORMATION ) ;
|
||||
return true;
|
||||
}
|
||||
|
||||
@@ -985,12 +985,12 @@
|
||||
if( _timerRunning==true
|
||||
|| _timerCheck->Checked==true ){
|
||||
bool answ = ( Application()->
|
||||
- MessageBox("Language Drill Message",
|
||||
- " Are you sure you want to close \n"
|
||||
- " the Language Drills ?\n"
|
||||
- " The Timer seems to be active !",
|
||||
- MB_YESNO)
|
||||
- == IDYES );
|
||||
+ VDKMessageBox("Language Drill Message",
|
||||
+ " Are you sure you want to close \n"
|
||||
+ " the Language Drills ?\n"
|
||||
+ " The Timer seems to be active !",
|
||||
+ VDK_YESNO)
|
||||
+ == VDK_IDYES );
|
||||
if( answ == false ){
|
||||
return true;
|
||||
} else {
|
||||
@@ -1052,8 +1052,9 @@
|
||||
gtk_signal_emit_stop_by_name( GTK_OBJECT(_simpleQuizzText->WrappedWidget()),
|
||||
"key_press_event");
|
||||
QuizzAnswerClicked( obj );
|
||||
+ return true;
|
||||
}
|
||||
- return true;
|
||||
+ return false;
|
||||
}
|
||||
|
||||
|
15
misc/langdrill/020_documentation.diff
Normal file
15
misc/langdrill/020_documentation.diff
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- langdrill-0.3.orig/README
|
||||
+++ langdrill-0.3/README
|
||||
@@ -1,9 +1,9 @@
|
||||
This is langrill, a language drill program. It is used to test your
|
||||
-vocabulary in foreign languages. It has some Japanese support included.
|
||||
+vocabulary in foreign languages. It has Japanese support included.
|
||||
|
||||
-http://borco-ei.eng.hokudai.ac.jp/~borco/vdk/langdrill.html
|
||||
+http://storm.prohosting.com/borco/programming/langdrill.html
|
||||
|
||||
-Mail suggestions and bug reports to borco@borco-ei.eng.hokudai.ac.jp.
|
||||
+Mail suggestions and bug reports to Ionutz Borcoman <borco@go.ro>.
|
||||
|
||||
This program is inspired from JavaDrill. However no code from JavaDrill
|
||||
was used. JavaDrill can be found at:
|
40
misc/langdrill/030_french_utf8.diff
Normal file
40
misc/langdrill/030_french_utf8.diff
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- langdrill-0.3.orig/src/french.drill
|
||||
+++ langdrill-0.3/src/french.drill
|
||||
@@ -2,9 +2,6 @@
|
||||
sense=0
|
||||
directSenseName=French
|
||||
reverseSenseName=English
|
||||
-# UTF-8 is the default encoding
|
||||
-directEncoding=ISO-8859-1
|
||||
-reverseEncoding=UTF-8
|
||||
quizzAnswerNr=8
|
||||
hQuizz=40
|
||||
wQuizz=300
|
||||
@@ -24,7 +21,7 @@
|
||||
useTimer=1
|
||||
|
||||
[Numbers]
|
||||
-zéro=zero
|
||||
+zéro=zero
|
||||
un=one
|
||||
deux=two
|
||||
trois=three
|
||||
@@ -95,15 +92,15 @@
|
||||
[Time: Months]
|
||||
|
||||
janvier=January
|
||||
-février=February
|
||||
+février=February
|
||||
mars=March
|
||||
avril=April
|
||||
mai=May
|
||||
juin=June
|
||||
juillet=July
|
||||
-août=August
|
||||
+août=August
|
||||
septembre=September
|
||||
octobre=October
|
||||
novembre=November
|
||||
-décembre=December
|
||||
+décembre=December
|
||||
|
1126
misc/langdrill/030_japanese.diff
Normal file
1126
misc/langdrill/030_japanese.diff
Normal file
File diff suppressed because it is too large
Load diff
248
misc/langdrill/030_swedish.diff
Normal file
248
misc/langdrill/030_swedish.diff
Normal file
|
@ -0,0 +1,248 @@
|
|||
--- langdrill-0.3.orig/src/Makefile
|
||||
+++ langdrill-0.3/src/Makefile
|
||||
@@ -11,7 +11,7 @@
|
||||
MAN_PAGE = ../docs/langdrill.1
|
||||
|
||||
DRILL_DEF = default.drill
|
||||
-DRILL_SUP = japanese.drill romaji.drill french.drill
|
||||
+DRILL_SUP = japanese.drill romaji.drill french.drill swedish.drill
|
||||
|
||||
DEF_FLAGS = -DTARGET='"$(TARGET)"' \
|
||||
-DDRILL_DEF='"$(DRILL_DEF)"' \
|
||||
--- langdrill-0.3.orig/src/swedish.drill
|
||||
+++ langdrill-0.3/src/swedish.drill
|
||||
@@ -0,0 +1,234 @@
|
||||
+[Application]
|
||||
+sense=0
|
||||
+directSenseName=Swedish
|
||||
+reverseSenseName=English
|
||||
+quizzAnswerNr=8
|
||||
+hQuizz=40
|
||||
+wQuizz=300
|
||||
+# the timer value is given in minutes.
|
||||
+# it represents the time between the automatical
|
||||
+# activation of the langdrill.
|
||||
+timer=10
|
||||
+# use this to set how many good answers the langdrill
|
||||
+# waits till hides by itself. limitedAnswer must be 1
|
||||
+# for this to take effect
|
||||
+limitedAnswerNr=25
|
||||
+limitedAnswers=1
|
||||
+
|
||||
+# set to 1 if you want the window to be hidden when you
|
||||
+# try to close it and the useTimer is 1
|
||||
+hideWindow=0
|
||||
+useTimer=1
|
||||
+
|
||||
+[Numbers]
|
||||
+noll=zero
|
||||
+ett=one
|
||||
+två=two
|
||||
+tre=three
|
||||
+fyra=four
|
||||
+fem=five
|
||||
+sex=six
|
||||
+sju=seven
|
||||
+åtta=eight
|
||||
+nio=nine
|
||||
+tio=ten
|
||||
+elva=eleven
|
||||
+tolv=twelve
|
||||
+tretton=thirteen
|
||||
+fjorton=fourteen
|
||||
+femton=fifteen
|
||||
+sexton=sixteen
|
||||
+sjutton=seventeen
|
||||
+arton=eighteen
|
||||
+nitton=nineteen
|
||||
+tjugo=twenty
|
||||
+tjugoett=twenty-one
|
||||
+tjugotvå=twenty-two
|
||||
+tjugotre=twenty-three
|
||||
+tjugofyra=twenty-four
|
||||
+tjugofem=twenty-five
|
||||
+tjugosex=twenty-six
|
||||
+tjugosju=twenty-seven
|
||||
+tjugoåtta=twenty-eight
|
||||
+tjugonio=twenty-nine
|
||||
+trettio=thirty
|
||||
+fyrtio=forty
|
||||
+femtio=fifty
|
||||
+sextio=sixty
|
||||
+sjuttio=seventy
|
||||
+åttio=eighty
|
||||
+nittio=ninety
|
||||
+hundra=one hundred
|
||||
+tvåhundra=two hundred
|
||||
+trehundra=three hundred
|
||||
+fyrahundra=four hundred
|
||||
+femhundra=five hundred
|
||||
+sexhundra=six hundred
|
||||
+sjuhundra=seven hundred
|
||||
+åttahundra=eight hundred
|
||||
+niohundra=nine hundred
|
||||
+tusen=one thousand
|
||||
+tvåtusen=two thousand
|
||||
+tretusen=three thousand
|
||||
+fyratusen=four thousand
|
||||
+femtusen=five thousand
|
||||
+sextusen=six thousand
|
||||
+sjutusen=seven thousand
|
||||
+åttatusen=eight thousand
|
||||
+niotusen=nine thousand
|
||||
+tiotusen=ten thousand
|
||||
+
|
||||
+
|
||||
+[Time: Days of the week]
|
||||
+
|
||||
+måndag=Monday
|
||||
+tisdag=Tuesday
|
||||
+onsdag=Wednesday
|
||||
+torsdag=Thursday
|
||||
+fredag=Friday
|
||||
+lördag=Saturday
|
||||
+söndag=Sunday
|
||||
+
|
||||
+
|
||||
+[Time: Months]
|
||||
+
|
||||
+januari=January
|
||||
+februari=February
|
||||
+mars=March
|
||||
+april=April
|
||||
+maj=May
|
||||
+juni=June
|
||||
+juli=July
|
||||
+augusti=August
|
||||
+september=September
|
||||
+oktober=October
|
||||
+november=November
|
||||
+december=December
|
||||
+
|
||||
+
|
||||
+[Expressions]
|
||||
+
|
||||
+Hej!=Hi!
|
||||
+Hejdå! (alt. Adjö!)=Goodbye!
|
||||
+Tack så mycket!=Thank you very much! (when reciving things, etc.)
|
||||
+Hur är det? (alt. Hur står det till?)=How are you?
|
||||
+Ursäkta.=Excuse me.
|
||||
+Förlåt (så mycket). (alt. Jag är ledsen.)=I'm (really) sorry.
|
||||
+Godmorgon!=Goodmorning!
|
||||
+
|
||||
+
|
||||
+[Words: Pronouns]
|
||||
+
|
||||
+jag=I
|
||||
+mig (alt. mej)=me
|
||||
+du=you
|
||||
+dig (alt. dej)=you (obj.)
|
||||
+hon=she
|
||||
+henne=her (obj.)
|
||||
+han=he
|
||||
+honom=him
|
||||
+det/den=it
|
||||
+vi=we
|
||||
+oss=us
|
||||
+ni=you (pl.)
|
||||
+er=you (pl. obj.)
|
||||
+de (alt. dom)=they
|
||||
+dem (alt. dom)=them
|
||||
+
|
||||
+
|
||||
+[Words: Nature]
|
||||
+
|
||||
+ett träd=a tree
|
||||
+en sjö=a lake
|
||||
+en fågel=a bird
|
||||
+en sten=a stone
|
||||
+en blomma=a flower
|
||||
+ett djur=an animal
|
||||
+ett hav=a sea
|
||||
+en buske=a shrub
|
||||
+en katt=a cat
|
||||
+ett berg=a mountain
|
||||
+en fjäril=a butterfly
|
||||
+en drake=a dragon
|
||||
+en fisk=a fish
|
||||
+
|
||||
+
|
||||
+[Words: Verbs]
|
||||
+
|
||||
+att vara (jag/du/.. är)=to be (I/you/.. am/are/..)
|
||||
+att ha (jag/du/.. har)=to have (I/you/.. have/..)
|
||||
+att se (jag/du/.. ser)=to see (I/you/.. see/..)
|
||||
+att säga (jag/du/.. säger)=to say (I/you/.. say/..)
|
||||
+att fråga (jag/du/.. frågar)=to ask (I/you/.. ask/..)
|
||||
+att gå (jag/du/.. går)=to walk (I/you/.. walk/..)
|
||||
+att sova (jag/du/.. sover)=to sleep (I/you/.. sleep/..)
|
||||
+att äta (jag/du/.. äter)=to eat (I/you/.. eat/..)
|
||||
+att komma (jag/du/.. kommer)=to come (I/you/.. come)
|
||||
+att ge (jag/du/.. ger)=to give (I/you/.. give)
|
||||
+
|
||||
+
|
||||
+[Lesson: ?]
|
||||
+
|
||||
+Jag frågar dej (en sak).=I am asking you (something).
|
||||
+Ser du honom?=Are you seeing him?
|
||||
+Jag ser honom.=I am seeing him.
|
||||
+Jag är en fisk.=I'm a fish.
|
||||
+Vi sover här.=We are sleeping here.
|
||||
+Hon ger en sten till mej.=She is giving me a stone.
|
||||
+
|
||||
+
|
||||
+[Words: ?]
|
||||
+
|
||||
+en sak=a thing
|
||||
+hur=how
|
||||
+till=to
|
||||
+var=where
|
||||
+
|
||||
+
|
||||
+[Lesson: Age]
|
||||
+
|
||||
+en ålder=an age
|
||||
+ett år=a year
|
||||
+gammal=old
|
||||
+ung=young
|
||||
+Hur gammal är du?=How old are you?
|
||||
+Jag är fyrtiotvå år (gammal).=I am forty-two years (old).
|
||||
+Du är tjugosju år (gammal).=You are twenty-seven years (old).
|
||||
+De är arton år (gammla).=They are eighteen years (old).
|
||||
+Hon är femtio år (gammal).=She is fifty years (old).
|
||||
+Han är trettionio år (gammal).=He is thirty-nine years (old).
|
||||
+Jag är åtta år (gammal).=I am eight years (old).
|
||||
+Det är tre år (gammalt).=It is three years (old).
|
||||
+Du är ung.=You are young.
|
||||
+Du är gammal.=You are old.
|
||||
+
|
||||
+
|
||||
+[Words: Countries]
|
||||
+
|
||||
+Australien=Australia
|
||||
+Brasilien=Brazil
|
||||
+Italien=Italy
|
||||
+Spanien=Spain
|
||||
+Rumänien=Romania
|
||||
+Danmark=Denmark
|
||||
+Sverige=Sweden
|
||||
+Norge=Norway
|
||||
+Kina=China
|
||||
+Kanada=Canada
|
||||
+Frankrike=France
|
||||
+Japan=Japan
|
||||
+Grönland=Greenland
|
||||
+Island=Iceland
|
||||
+Tyskland=Germany
|
||||
+Ryssland=Russia
|
||||
+Greekland=Greece
|
||||
+England=England
|
||||
+USA=USA
|
||||
+Amerika=America
|
||||
+
|
||||
+
|
||||
+[Lesson: ?2]
|
||||
+
|
||||
+Var kommer du ifrån?=Where are you from?
|
||||
+Jag kommer ifrån Grönland.=I am from Greenland.
|
||||
+
|
21
misc/langdrill/040_link.diff
Normal file
21
misc/langdrill/040_link.diff
Normal file
|
@ -0,0 +1,21 @@
|
|||
From: Markus Koschany <apo@debian.org>
|
||||
Date: Fri, 19 Jan 2018 10:39:45 +0100
|
||||
Subject: link against only needed libraries
|
||||
|
||||
---
|
||||
src/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/Makefile b/src/Makefile
|
||||
index c0b467b..aec5e4e 100644
|
||||
--- a/src/Makefile
|
||||
+++ b/src/Makefile
|
||||
@@ -37,7 +37,7 @@ else
|
||||
endif
|
||||
|
||||
CC = g++
|
||||
-LFLAGS = `vdk-config-2 --libs` `pkg-config --libs gtk+-2.0`
|
||||
+LFLAGS = -Wl,--as-needed `vdk-config-2 --libs` `pkg-config --libs gtk+-2.0`
|
||||
|
||||
|
||||
####### Implicit rules
|
61
misc/langdrill/050_cflags.diff
Normal file
61
misc/langdrill/050_cflags.diff
Normal file
|
@ -0,0 +1,61 @@
|
|||
diff -ur langdrill-0.3/src/Makefile langdrill-0.3/src/Makefile
|
||||
--- langdrill-0.3/src/Makefile 2018-03-19 10:15:09.855912688 -0700
|
||||
+++ langdrill-0.3/src/Makefile 2018-03-19 10:13:38.535093214 -0700
|
||||
@@ -16,7 +16,9 @@
|
||||
DEF_FLAGS = -DTARGET='"$(TARGET)"' \
|
||||
-DDRILL_DEF='"$(DRILL_DEF)"' \
|
||||
-DDRILL_DIR='"$(DRILL_DIR)"' \
|
||||
- `pkg-config --cflags gtk+-2.0`
|
||||
+ `pkg-config --cflags gtk+-2.0` \
|
||||
+ `vdk-config-2 --cflags` \
|
||||
+ -Wall
|
||||
|
||||
###### Test for Debian GNU/Linux
|
||||
# If your system is not Debian GNU/Linux please modify the values after
|
||||
@@ -27,16 +29,15 @@
|
||||
DRILL_DIR=$(DESTDIR)/usr/share/langdrill
|
||||
BIN_DIR=$(DESTDIR)/usr/bin
|
||||
MAN_DIR=$(DESTDIR)/usr/share/man/man1
|
||||
- CFLAGS = -Wall `vdk-config-2 --cflags` $(DEF_FLAGS)
|
||||
else
|
||||
MY_MESSAGE_OF_THE_DAY=">>" $(TARGET) compilled for NON-Debian GNU/Linux system. "<<"
|
||||
DRILL_DIR=$(DESTDIR)/usr/local/share/langdrill
|
||||
BIN_DIR=$(DESTDIR)/usr/local/bin
|
||||
MAN_DIR=$(DESTDIR)/usr/local/man/man1
|
||||
- CFLAGS = -Wall -g `vdk-config-2 --cflags` $(DEF_FLAGS)
|
||||
endif
|
||||
|
||||
CC = g++
|
||||
+CFLAGS = -g
|
||||
LFLAGS = -Wl,--as-needed `vdk-config-2 --libs` `pkg-config --libs gtk+-2.0`
|
||||
|
||||
|
||||
@@ -45,7 +46,7 @@
|
||||
.SUFFIXES: .cc
|
||||
|
||||
.cc.o: $(SRC)
|
||||
- $(CC) $(CFLAGS) -c $*.cc -o $@
|
||||
+ $(CC) $(CFLAGS) $(DEF_FLAGS) -c $*.cc -o $@
|
||||
|
||||
####### Build rules
|
||||
|
||||
@@ -62,16 +63,16 @@
|
||||
|
||||
$(TARGET): tarclean $(OBJ)
|
||||
@echo $(MY_MESSAGE_OF_THE_DAY)
|
||||
- $(CC) $(CFLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
+ $(CC) $(CFLAGS) $(DEF_FLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
|
||||
run: tarclean $(OBJ)
|
||||
@echo $(MY_MESSAGE_OF_THE_DAY)
|
||||
- $(CC) $(CFLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
+ $(CC) $(CFLAGS) $(DEF_FLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
./$(TARGET)
|
||||
|
||||
build: clean tarclean $(OBJ)
|
||||
@echo $(MY_MESSAGE_OF_THE_DAY)
|
||||
- $(CC) $(CFLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
+ $(CC) $(CFLAGS) $(DEF_FLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
|
||||
install: all
|
||||
install -d $(BIN_DIR) $(DRILL_DIR) $(MAN_DIR)
|
63
misc/langdrill/050_install.diff
Normal file
63
misc/langdrill/050_install.diff
Normal file
|
@ -0,0 +1,63 @@
|
|||
diff -ur langdrill-0.3/src/Makefile langdrill-0.3/src/Makefile
|
||||
--- langdrill-0.3/src/Makefile 2018-03-19 09:36:36.277390675 -0700
|
||||
+++ langdrill-0.3/src/Makefile 2018-03-19 09:55:06.065284069 -0700
|
||||
@@ -1,6 +1,5 @@
|
||||
###### Files & Directories
|
||||
DESTDIR=
|
||||
-MY_DEBIAN_SYSTEM=
|
||||
|
||||
|
||||
SRC = main.cc\
|
||||
@@ -20,21 +19,10 @@
|
||||
`vdk-config-2 --cflags` \
|
||||
-Wall
|
||||
|
||||
-###### Test for Debian GNU/Linux
|
||||
-# If your system is not Debian GNU/Linux please modify the values after
|
||||
-# "else" statement. Modifying the values before else is useless, unless
|
||||
-# you also set MY_DEBIAN_SYSTEM=1
|
||||
-ifeq ($(MY_DEBIAN_SYSTEM),1)
|
||||
- MY_MESSAGE_OF_THE_DAY=">>" $(TARGET) compilled for Debian GNU/Linux system. "<<"
|
||||
- DRILL_DIR=$(DESTDIR)/usr/share/langdrill
|
||||
- BIN_DIR=$(DESTDIR)/usr/bin
|
||||
- MAN_DIR=$(DESTDIR)/usr/share/man/man1
|
||||
-else
|
||||
- MY_MESSAGE_OF_THE_DAY=">>" $(TARGET) compilled for NON-Debian GNU/Linux system. "<<"
|
||||
- DRILL_DIR=$(DESTDIR)/usr/local/share/langdrill
|
||||
- BIN_DIR=$(DESTDIR)/usr/local/bin
|
||||
- MAN_DIR=$(DESTDIR)/usr/local/man/man1
|
||||
-endif
|
||||
+PREFIX ?= /usr/local
|
||||
+DRILL_DIR ?= $(PREFIX)/share/langdrill
|
||||
+BIN_DIR ?= $(PREFIX)/bin
|
||||
+MAN_DIR ?= $(PREFIX)/share/man
|
||||
|
||||
CC = g++
|
||||
CFLAGS = -g
|
||||
@@ -62,21 +50,18 @@
|
||||
rm -f $(TARGET) core *~
|
||||
|
||||
$(TARGET): tarclean $(OBJ)
|
||||
- @echo $(MY_MESSAGE_OF_THE_DAY)
|
||||
$(CC) $(CFLAGS) $(DEF_FLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
|
||||
run: tarclean $(OBJ)
|
||||
- @echo $(MY_MESSAGE_OF_THE_DAY)
|
||||
$(CC) $(CFLAGS) $(DEF_FLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
./$(TARGET)
|
||||
|
||||
build: clean tarclean $(OBJ)
|
||||
- @echo $(MY_MESSAGE_OF_THE_DAY)
|
||||
$(CC) $(CFLAGS) $(DEF_FLAGS) -o $(TARGET) $(OBJ) $(LFLAGS)
|
||||
|
||||
install: all
|
||||
- install -d $(BIN_DIR) $(DRILL_DIR) $(MAN_DIR)
|
||||
- install ./$(TARGET) $(BIN_DIR)
|
||||
- install -m644 $(DRILL_SUP) $(DRILL_DIR)
|
||||
- ln -sf japanese.drill $(DRILL_DIR)/$(DRILL_DEF)
|
||||
- install -m644 $(MAN_PAGE) $(MAN_DIR)
|
||||
+ install -d $(DESTDIR)$(BIN_DIR) $(DESTDIR)$(DRILL_DIR) $(DESTDIR)$(MAN_DIR)/man1
|
||||
+ install ./$(TARGET) $(DESTDIR)$(BIN_DIR)
|
||||
+ install -m644 $(DRILL_SUP) $(DESTDIR)$(DRILL_DIR)
|
||||
+ ln -sf japanese.drill $(DESTDIR)$(DRILL_DIR)/$(DRILL_DEF)
|
||||
+ install -m644 $(MAN_PAGE) $(DESTDIR)$(MAN_DIR)/man1
|
2
misc/langdrill/README
Normal file
2
misc/langdrill/README
Normal file
|
@ -0,0 +1,2 @@
|
|||
This is langrill, a language drill program. It is used to test your
|
||||
vocabulary in foreign languages.
|
100
misc/langdrill/langdrill.SlackBuild
Normal file
100
misc/langdrill/langdrill.SlackBuild
Normal file
|
@ -0,0 +1,100 @@
|
|||
#!/bin/sh
|
||||
|
||||
# Slackware build script for langdrill
|
||||
|
||||
# Copyright 2018 Hunter Sezen California, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=langdrill
|
||||
VERSION=${VERSION:-0.3}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -eu
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/${PRGNAM}_$VERSION.orig.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
for patch in $CWD/0?0_*.diff; do
|
||||
patch -p1 < "$patch"
|
||||
done
|
||||
|
||||
make \
|
||||
PREFIX=/usr \
|
||||
CFLAGS="$SLKCFLAGS"
|
||||
|
||||
make install \
|
||||
DESTDIR=$PKG \
|
||||
PREFIX=/usr \
|
||||
MAN_DIR=/usr/man
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a AUTHORS BUGS COPYING INSTALL NEWS README THANKS TODO \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
misc/langdrill/langdrill.info
Normal file
10
misc/langdrill/langdrill.info
Normal file
|
@ -0,0 +1,10 @@
|
|||
PRGNAM="langdrill"
|
||||
VERSION="0.3"
|
||||
HOMEPAGE="https://tracker.debian.org/pkg/langdrill"
|
||||
DOWNLOAD="http://http.debian.net/debian/pool/main/l/langdrill/langdrill_0.3.orig.tar.gz"
|
||||
MD5SUM="70afbf1d33ead7cec4dbf5d2d0782c4c"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="vdk"
|
||||
MAINTAINER="Hunter Sezen"
|
||||
EMAIL="orbea@fredslev.dk"
|
19
misc/langdrill/slack-desc
Normal file
19
misc/langdrill/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
langdrill: langdrill (language drill tests)
|
||||
langdrill:
|
||||
langdrill: This is langrill, a language drill program. It is used to test your
|
||||
langdrill: vocabulary in foreign languages.
|
||||
langdrill:
|
||||
langdrill: Homepage: https://tracker.debian.org/pkg/langdrill
|
||||
langdrill:
|
||||
langdrill:
|
||||
langdrill:
|
||||
langdrill:
|
||||
langdrill:
|
Loading…
Reference in a new issue