misc/xdelta3: Updated for version 3.1.0.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Hunter Sezen 2019-07-20 09:24:33 +07:00 committed by Willy Sudiarto Raharjo
parent 3557fcd162
commit 12c3455364
No known key found for this signature in database
GPG key ID: 887B8374D7333381
3 changed files with 49 additions and 6 deletions

39
misc/xdelta3/c11.patch Normal file
View file

@ -0,0 +1,39 @@
From 483bafb4179229714d920de49ba964170c212ef9 Mon Sep 17 00:00:00 2001
From: Weida Hong <wdhongtw@gmail.com>
Date: Thu, 29 Mar 2018 18:37:20 +0800
Subject: [PATCH] Fix assertion related compile failure
static_assert is declared in assert.h and should only be used after c11.
---
xdelta3/Makefile.am | 2 +-
xdelta3/xdelta3.h | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/xdelta3/Makefile.am b/xdelta3/Makefile.am
index 2280083..2d41213 100644
--- a/xdelta3/Makefile.am
+++ b/xdelta3/Makefile.am
@@ -73,7 +73,7 @@ WFLAGS = -Wall -Wshadow -fno-builtin -Wextra -Wsign-compare \
# -Wno-variadic-macros \
# -Wno-c++98-compat-pedantic
-C_WFLAGS = $(WFLAGS) -pedantic -std=c99
+C_WFLAGS = $(WFLAGS) -pedantic -std=c11
CXX_WFLAGS = $(WFLAGS) -pedantic -std=c++11
common_CFLAGS = \
diff --git a/xdelta3/xdelta3.h b/xdelta3/xdelta3.h
index 0c1ae0d..7d5e230 100644
--- a/xdelta3/xdelta3.h
+++ b/xdelta3/xdelta3.h
@@ -32,6 +32,7 @@
#include "config.h"
#endif
+#include <assert.h>
#include <errno.h>
#include <stdarg.h>
#include <stddef.h>
--
2.22.0

View file

@ -24,8 +24,8 @@
PRGNAM=xdelta3
SRCNAM=${PRGNAM%3}
VERSION=${VERSION:-3.0.11}
BUILD=${BUILD:-2}
VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -64,7 +64,7 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd $SRCNAM-$VERSION
# dangling symlink
rm -f ./$PRGNAM/py-compile
rm -f ./$PRGNAM/install-sh
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@ -72,6 +72,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix assertion related compile failure
# https://github.com/jmacd/xdelta/pull/241
patch -p1 < $CWD/c11.patch
cd $PRGNAM
autoreconf -fi

View file

@ -1,8 +1,8 @@
PRGNAM="xdelta3"
VERSION="3.0.11"
VERSION="3.1.0"
HOMEPAGE="http://xdelta.org/"
DOWNLOAD="https://github.com/jmacd/xdelta/archive/v3.0.11/xdelta-3.0.11.tar.gz"
MD5SUM="6ed23efecea471dfa0ed5c00216fe31e"
DOWNLOAD="https://github.com/jmacd/xdelta/archive/v3.1.0/xdelta-3.1.0.tar.gz"
MD5SUM="fa9b598194d82adeaec2f3c30e827dd6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""