graphics/digikam: Fix build with latest libpgf.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2019-03-17 17:42:18 +07:00
parent e9fbb2a4ff
commit 126d8cb7dc
2 changed files with 37 additions and 2 deletions

View file

@ -3,7 +3,7 @@
# Slackware build script for digiKam
# Copyright 2007-2011 Frank Caraballo <fecaraballo{at}gmail{dot}com>
# Copyright 2013-2015 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# Copyright 2013-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@ -25,7 +25,7 @@
PRGNAM=digikam
VERSION=${VERSION:-4.14.0}
BUILD=${BUILD:-3}
BUILD=${BUILD:-4}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@ -74,6 +74,8 @@ patch -p1 < $CWD/lensfun-0.3.2.patch
sed -e '/fno-tree-pre/d' -i CMakeLists.txt
cd ..
patch -p0 < $CWD/libpgf.patch
mkdir -p build
cd build
cmake \

View file

@ -0,0 +1,33 @@
--- core/libs/dimg/loaders/pgfloader.cpp.orig 2019-03-17 16:52:40.102888509 +0700
+++ core/libs/dimg/loaders/pgfloader.cpp 2019-03-17 16:52:51.404020146 +0700
@@ -442,14 +442,6 @@
}
}
-#ifdef PGFCodecVersionID
-# if PGFCodecVersionID < 0x061142
- header.background.rgbtBlue = 0;
- header.background.rgbtGreen = 0;
- header.background.rgbtRed = 0;
-# endif
-#endif
-
pgf.SetHeader(header);
// NOTE: see bug #273765 : Loading PGF thumbs with OpenMP support through a separated thread do not work properlly with libppgf 6.11.24
--- core/libs/threadimageio/pgfutils.cpp.orig 2019-03-17 17:07:35.586244318 +0700
+++ core/libs/threadimageio/pgfutils.cpp 2019-03-17 17:07:47.110376670 +0700
@@ -262,13 +262,6 @@
header.mode = ImageModeRGBA;
header.usedBitsPerChannel = 0; // Auto
-#ifdef PGFCodecVersionID
-# if PGFCodecVersionID < 0x061142
- header.background.rgbtBlue = 0;
- header.background.rgbtGreen = 0;
- header.background.rgbtRed = 0;
-# endif
-#endif
pgfImg.SetHeader(header);
// NOTE: see bug #273765 : Loading PGF thumbs with OpenMP support through a separated thread do not work properlly with libppgf 6.11.24