mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-22 19:44:21 +01:00
libraries/grantlee-qt5: Added (template engine written in Qt5).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
This commit is contained in:
parent
91be75add6
commit
1214131e1d
5 changed files with 181 additions and 0 deletions
8
libraries/grantlee-qt5/README
Normal file
8
libraries/grantlee-qt5/README
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
Grantlee is a set of Free Software libraries written using the Qt
|
||||||
|
framework. Currently two libraries are shipped with Grantlee: Grantlee
|
||||||
|
Templates and Grantlee TextDocument.
|
||||||
|
|
||||||
|
The goal of Grantlee Templates is to make it easier for application
|
||||||
|
developers to separate the structure of documents from the data they
|
||||||
|
contain, opening the door for theming and advanced generation of other
|
||||||
|
text such as code.
|
|
@ -0,0 +1,40 @@
|
||||||
|
diff -up grantlee-5.1.0/CMakeLists.txt.orig grantlee-5.1.0/CMakeLists.txt
|
||||||
|
--- grantlee-5.1.0/CMakeLists.txt.orig 2016-04-19 01:33:17.000000000 -0500
|
||||||
|
+++ grantlee-5.1.0/CMakeLists.txt 2016-04-19 06:44:06.371122149 -0500
|
||||||
|
@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
|
||||||
|
set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
|
||||||
|
set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
|
||||||
|
set( BIN_INSTALL_DIR bin )
|
||||||
|
-set( INCLUDE_INSTALL_DIR include )
|
||||||
|
+set( INCLUDE_INSTALL_DIR include/Grantlee5 )
|
||||||
|
set( DATA_INSTALL_DIR share/apps )
|
||||||
|
|
||||||
|
# set up RPATH/install_name_dir
|
||||||
|
diff -up grantlee-5.1.0/templates/lib/CMakeLists.txt.orig grantlee-5.1.0/templates/lib/CMakeLists.txt
|
||||||
|
--- grantlee-5.1.0/templates/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
|
||||||
|
+++ grantlee-5.1.0/templates/lib/CMakeLists.txt 2016-04-19 06:44:55.763336264 -0500
|
||||||
|
@@ -107,6 +107,10 @@ if (Qt5Script_FOUND)
|
||||||
|
|
||||||
|
target_sources(Grantlee_Templates PRIVATE ${scriptabletags_SRCS})
|
||||||
|
target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
|
||||||
|
+ target_include_directories(Grantlee_Templates
|
||||||
|
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
||||||
|
+ )
|
||||||
|
+
|
||||||
|
target_link_libraries(Grantlee_Templates
|
||||||
|
LINK_PRIVATE Qt5::Script
|
||||||
|
)
|
||||||
|
diff -up grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig grantlee-5.1.0/textdocument/lib/CMakeLists.txt
|
||||||
|
--- grantlee-5.1.0/textdocument/lib/CMakeLists.txt.orig 2016-04-19 06:44:06.371122149 -0500
|
||||||
|
+++ grantlee-5.1.0/textdocument/lib/CMakeLists.txt 2016-04-19 06:45:56.268598553 -0500
|
||||||
|
@@ -43,6 +43,10 @@ if (CMAKE_GENERATOR MATCHES "Visual Stud
|
||||||
|
endforeach()
|
||||||
|
endif()
|
||||||
|
|
||||||
|
+target_include_directories(Grantlee_TextDocument
|
||||||
|
+ INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>"
|
||||||
|
+)
|
||||||
|
+
|
||||||
|
target_link_libraries(Grantlee_TextDocument
|
||||||
|
LINK_PUBLIC Qt5::Gui
|
||||||
|
)
|
104
libraries/grantlee-qt5/grantlee-qt5.SlackBuild
Normal file
104
libraries/grantlee-qt5/grantlee-qt5.SlackBuild
Normal file
|
@ -0,0 +1,104 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# Slackware build script for grantlee-qt5
|
||||||
|
|
||||||
|
# Copyright 2016 Larry Hajali <larryhaja[at]gmail[dot]com>
|
||||||
|
# All rights reserved.
|
||||||
|
#
|
||||||
|
# Redistribution and use of this script, with or without modification, is
|
||||||
|
# permitted provided that the following conditions are met:
|
||||||
|
#
|
||||||
|
# 1. Redistributions of this script must retain the above copyright
|
||||||
|
# notice, this list of conditions and the following disclaimer.
|
||||||
|
#
|
||||||
|
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||||
|
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||||
|
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||||
|
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||||
|
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||||
|
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||||
|
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||||
|
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||||
|
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||||
|
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||||
|
|
||||||
|
PRGNAM=grantlee-qt5
|
||||||
|
SRCNAM=grantlee
|
||||||
|
VERSION=${VERSION:-5.1.0}
|
||||||
|
BUILD=${BUILD:-1}
|
||||||
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
if [ -z "$ARCH" ]; then
|
||||||
|
case "$( uname -m )" in
|
||||||
|
i?86) ARCH=i586 ;;
|
||||||
|
arm*) ARCH=arm ;;
|
||||||
|
*) ARCH=$( uname -m ) ;;
|
||||||
|
esac
|
||||||
|
fi
|
||||||
|
|
||||||
|
CWD=$(pwd)
|
||||||
|
TMP=${TMP:-/tmp/SBo}
|
||||||
|
PKG=$TMP/package-$PRGNAM
|
||||||
|
OUTPUT=${OUTPUT:-/tmp}
|
||||||
|
|
||||||
|
if [ "$ARCH" = "i586" ]; then
|
||||||
|
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
elif [ "$ARCH" = "i686" ]; then
|
||||||
|
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
elif [ "$ARCH" = "x86_64" ]; then
|
||||||
|
SLKCFLAGS="-O2 -fPIC"
|
||||||
|
LIBDIRSUFFIX="64"
|
||||||
|
else
|
||||||
|
SLKCFLAGS="-O2"
|
||||||
|
LIBDIRSUFFIX=""
|
||||||
|
fi
|
||||||
|
|
||||||
|
set -e
|
||||||
|
|
||||||
|
rm -rf $PKG
|
||||||
|
mkdir -p $TMP $PKG $OUTPUT
|
||||||
|
cd $TMP
|
||||||
|
rm -rf $SRCNAM-$VERSION
|
||||||
|
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
|
||||||
|
cd $SRCNAM-$VERSION
|
||||||
|
chown -R root:root .
|
||||||
|
find -L . \
|
||||||
|
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||||
|
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||||
|
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||||
|
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||||
|
|
||||||
|
## upstreamable patches
|
||||||
|
# Install headers into a versioned directory to be parallel-installable
|
||||||
|
# based on:
|
||||||
|
# https://github.com/steveire/grantlee/pull/1
|
||||||
|
patch -p1 < $CWD/grantlee-5.1.0-install_headers_into_versioned_directory.patch
|
||||||
|
|
||||||
|
mkdir build
|
||||||
|
cd build
|
||||||
|
cmake -G "Unix Makefiles" \
|
||||||
|
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
|
||||||
|
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
|
||||||
|
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
|
||||||
|
-DBUILD_TESTS:BOOL=FALSE \
|
||||||
|
-DLIB_SUFFIX:STRING="$LIBDIRSUFFIX" \
|
||||||
|
-DCMAKE_BUILD_TYPE=Release ..
|
||||||
|
|
||||||
|
make VERBOSE=1
|
||||||
|
make install DESTDIR=$PKG
|
||||||
|
cd -
|
||||||
|
|
||||||
|
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||||
|
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||||
|
|
||||||
|
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cp -a AUTHORS CHANGELOG COPYING.LIB README.md $PKG/usr/doc/$PRGNAM-$VERSION
|
||||||
|
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||||
|
|
||||||
|
mkdir -p $PKG/install
|
||||||
|
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||||
|
|
||||||
|
cd $PKG
|
||||||
|
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
|
10
libraries/grantlee-qt5/grantlee-qt5.info
Normal file
10
libraries/grantlee-qt5/grantlee-qt5.info
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
PRGNAM="grantlee-qt5"
|
||||||
|
VERSION="5.1.0"
|
||||||
|
HOMEPAGE="https://github.com/steveire/grantlee"
|
||||||
|
DOWNLOAD="https://github.com/steveire/grantlee/archive/v5.1.0/grantlee-5.1.0.tar.gz"
|
||||||
|
MD5SUM="3ce1e53cca2b5cad27d07ee82880e4c3"
|
||||||
|
DOWNLOAD_x86_64=""
|
||||||
|
MD5SUM_x86_64=""
|
||||||
|
REQUIRES="qt5"
|
||||||
|
MAINTAINER="Larry Hajali"
|
||||||
|
EMAIL="larryhaja[at]gmail[dot]com"
|
19
libraries/grantlee-qt5/slack-desc
Normal file
19
libraries/grantlee-qt5/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
# HOW TO EDIT THIS FILE:
|
||||||
|
# The "handy ruler" below makes it easier to edit a package description.
|
||||||
|
# Line up the first '|' above the ':' following the base package name, and
|
||||||
|
# the '|' on the right side marks the last column you can put a character in.
|
||||||
|
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||||
|
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||||
|
|
||||||
|
|-----handy-ruler------------------------------------------------------|
|
||||||
|
grantlee-qt5: grantlee-qt5 (A string template engine written in Qt5)
|
||||||
|
grantlee-qt5:
|
||||||
|
grantlee-qt5: Grantlee is a set of Free Software libraries written using the Qt
|
||||||
|
grantlee-qt5: framework. Currently two libraries are shipped with Grantlee:
|
||||||
|
grantlee-qt5: Grantlee Templates and Grantlee TextDocument.
|
||||||
|
grantlee-qt5:
|
||||||
|
grantlee-qt5: The goal of Grantlee Templates is to make it easier for application
|
||||||
|
grantlee-qt5: developers to separate the structure of documents from the data they
|
||||||
|
grantlee-qt5: contain, opening the door for theming and advanced generation of other
|
||||||
|
grantlee-qt5: text such as code.
|
||||||
|
grantlee-qt5: Homepage: https://github.com/steveire/grantlee
|
Loading…
Reference in a new issue