system/ink: Initial import

This commit is contained in:
Robby Workman 2010-05-11 15:18:39 +02:00 committed by Robby Workman
parent 39850cb367
commit 118d28ca86
5 changed files with 98 additions and 0 deletions

11
system/ink/Makefile.diff Normal file
View file

@ -0,0 +1,11 @@
--- ink/Makefile.orig 2006-08-22 16:26:25.132141803 -0500
+++ ink/Makefile 2006-08-22 16:27:15.018192620 -0500
@@ -5,7 +5,7 @@
install: all
mkdir -p $(DESTDIR)/bin
- install -m 755 -o root -g root ink $(DESTDIR)/bin/ink
+ install -m 755 ink $(DESTDIR)/bin/ink
clean:
rm -fr ink *~

3
system/ink/README Normal file
View file

@ -0,0 +1,3 @@
Ink is a command line tool for checking the ink level of your printer
on a system which runs Linux. It makes use of libinklevel. As such,
you must have libinklevel installed in order to build the ink package.

67
system/ink/ink.SlackBuild Normal file
View file

@ -0,0 +1,67 @@
#!/bin/sh
# Slackware build script for ink
# Copyright 2006 Robby Workman (http://rlworkman.net)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by the SlackBuilds.org project
PRGNAM=ink
VERSION=0.3.1
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=`pwd`
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP || exit 1
rm -rf $PRGNAM
tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
cd $PRGNAM || exit 1
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
# Don't set uid and gid during install; we'll handle it in the build script
cat $CWD/Makefile.diff | patch -p1 || exit 1
make || exit 1
make install DESTDIR=$PKG/usr || exit 1
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
# No man pages
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
chown -R root.root .
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz

8
system/ink/ink.info Normal file
View file

@ -0,0 +1,8 @@
PRGNAM="ink"
VERSION="0.3.1"
HOMEPAGE="http://ink.sourceforge.net/"
DOWNLOAD="http://dl.sourceforge.net/ink/ink-0.3.1.tar.gz"
MD5SUM="3f1df6868b7a7503b7551b3017e11f2d"
MAINTAINER="Robby Workman"
EMAIL="rw@rlworkman.net"
APPROVED="robw810,elohim"

9
system/ink/slack-desc Normal file
View file

@ -0,0 +1,9 @@
ink: printer ink level monitor
ink:
ink: Ink is a command line tool for checking the ink level of your printer
ink: on a system which runs Linux. It makes use of libinklevel.
ink:
ink: Homepage: http://ink.sourceforge.net/
ink:
ink: