mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
system/vice: Updated for version 2.3.22.
Rewritten x86_64 patch, added another to fix docs building, explicitly disabled ffmpeg (not yet compatible). Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
This commit is contained in:
parent
4e256db06b
commit
111c0170c7
6 changed files with 176 additions and 129 deletions
|
@ -1,105 +0,0 @@
|
|||
diff -urpN vice-2.1/configure vice-2.1-64/configure
|
||||
--- vice-2.1/configure 2008-12-15 21:18:47.000000000 +0100
|
||||
+++ vice-2.1-64/configure 2009-10-11 00:02:00.763205494 +0200
|
||||
@@ -960,7 +960,7 @@ htmldir='${docdir}'
|
||||
dvidir='${docdir}'
|
||||
pdfdir='${docdir}'
|
||||
psdir='${docdir}'
|
||||
-libdir='${exec_prefix}/lib'
|
||||
+libdir='${exec_prefix}/lib64'
|
||||
localedir='${datarootdir}/locale'
|
||||
mandir='${datarootdir}/man'
|
||||
|
||||
@@ -1445,7 +1445,7 @@ Installation directories:
|
||||
[PREFIX]
|
||||
|
||||
By default, \`make install' will install all the files in
|
||||
-\`$ac_default_prefix/bin', \`$ac_default_prefix/lib' etc. You can specify
|
||||
+\`$ac_default_prefix/bin', \`$ac_default_prefix/lib64' etc. You can specify
|
||||
an installation prefix other than \`$ac_default_prefix' using \`--prefix',
|
||||
for instance \`--prefix=\$HOME'.
|
||||
|
||||
@@ -1458,7 +1458,7 @@ Fine tuning of the installation director
|
||||
--sysconfdir=DIR read-only single-machine data [PREFIX/etc]
|
||||
--sharedstatedir=DIR modifiable architecture-independent data [PREFIX/com]
|
||||
--localstatedir=DIR modifiable single-machine data [PREFIX/var]
|
||||
- --libdir=DIR object code libraries [EPREFIX/lib]
|
||||
+ --libdir=DIR object code libraries [EPREFIX/lib64]
|
||||
--includedir=DIR C header files [PREFIX/include]
|
||||
--oldincludedir=DIR C header files for non-gcc [/usr/include]
|
||||
--datarootdir=DIR read-only arch.-independent data root [PREFIX/share]
|
||||
@@ -5583,7 +5583,7 @@ if test -z "$CPP"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
# Double quotes because CPP needs to be expanded
|
||||
- for CPP in "$CC -E" "$CC -E -traditional-cpp" "/lib/cpp"
|
||||
+ for CPP in "$CC -E" "$CC -E -traditional-cpp" "/lib64/cpp"
|
||||
do
|
||||
ac_preproc_ok=false
|
||||
for ac_c_preproc_warn_flag in '' yes
|
||||
@@ -6369,7 +6369,7 @@ if test -z "$CPP"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
# Double quotes because CPP needs to be expanded
|
||||
- for CPP in "$CC -E" "$CC -E -traditional-cpp" "/lib/cpp"
|
||||
+ for CPP in "$CC -E" "$CC -E -traditional-cpp" "/lib64/cpp"
|
||||
do
|
||||
ac_preproc_ok=false
|
||||
for ac_c_preproc_warn_flag in '' yes
|
||||
@@ -8652,7 +8652,7 @@ if test -z "$CXXCPP"; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
# Double quotes because CXXCPP needs to be expanded
|
||||
- for CXXCPP in "$CXX -E" "/lib/cpp"
|
||||
+ for CXXCPP in "$CXX -E" "/lib64/cpp"
|
||||
do
|
||||
ac_preproc_ok=false
|
||||
for ac_cxx_preproc_warn_flag in '' yes
|
||||
@@ -8911,7 +8911,7 @@ _ACEOF
|
||||
else
|
||||
no_recursion=yes
|
||||
|
||||
- LDFLAGS="$LDFLAGS -L$with_resid/lib"
|
||||
+ LDFLAGS="$LDFLAGS -L$with_resid/lib64"
|
||||
CPPFLAGS="$CPPFLAGS -I$with_resid/include"
|
||||
|
||||
|
||||
@@ -9131,7 +9131,7 @@ cat >>confdefs.h <<\_ACEOF
|
||||
_ACEOF
|
||||
|
||||
RESID_DIR=
|
||||
- RESID_LIBS="$with_resid/lib/libresid.a"
|
||||
+ RESID_LIBS="$with_resid/lib64/libresid.a"
|
||||
RESID_INCLUDES="-I$with_resid/include"
|
||||
fi
|
||||
|
||||
@@ -23284,7 +23284,7 @@ _ACEOF
|
||||
*) test -f "$ac_im_incroot/X11/Xos.h" && ac_x_includes=$ac_im_incroot;;
|
||||
esac
|
||||
case $ac_im_usrlibdir in
|
||||
- /usr/lib | /lib) ;;
|
||||
+ /usr/lib64 | /lib64) ;;
|
||||
*) test -d "$ac_im_usrlibdir" && ac_x_libraries=$ac_im_usrlibdir ;;
|
||||
esac
|
||||
fi
|
||||
@@ -28704,7 +28704,7 @@ fi
|
||||
|
||||
;;
|
||||
*)
|
||||
- VICEDIR="$PREFIX/lib/vice";
|
||||
+ VICEDIR="$PREFIX/lib64/vice";
|
||||
|
||||
|
||||
if false; then
|
||||
diff -urpN vice-2.1/src/arch/unix/archdep.h vice-2.1-64/src/arch/unix/archdep.h
|
||||
--- vice-2.1/src/arch/unix/archdep.h 2008-10-10 21:08:31.000000000 +0200
|
||||
+++ vice-2.1-64/src/arch/unix/archdep.h 2009-10-11 00:03:04.366722924 +0200
|
||||
@@ -116,7 +116,7 @@ extern const char *archdep_pref_path;
|
||||
#ifdef __NetBSD__
|
||||
#define LIBDIR PREFIX "/share/vice"
|
||||
#else
|
||||
-#define LIBDIR PREFIX "/lib/vice"
|
||||
+#define LIBDIR PREFIX "/lib64/vice"
|
||||
#endif
|
||||
|
||||
#if defined(__FreeBSD__) || defined(__NetBSD__)
|
129
system/vice/patches/vice-2.3.21-64bit.patch
Normal file
129
system/vice/patches/vice-2.3.21-64bit.patch
Normal file
|
@ -0,0 +1,129 @@
|
|||
diff -Naur vice-2.3.21.orig/doc/vice.guide vice-2.3.21/doc/vice.guide
|
||||
--- vice-2.3.21.orig/doc/vice.guide 2012-08-06 00:41:54.000000000 +0200
|
||||
+++ vice-2.3.21/doc/vice.guide 2012-08-06 09:44:36.288562655 +0200
|
||||
@@ -1292,7 +1292,7 @@
|
||||
`Directory' resource, which is a colon (`:')-separated search path
|
||||
list, like the UNIX `PATH' environment variable. The default value is
|
||||
|
||||
- PREFIX/lib/vice/EMU:$HOME/.vice/EMU:BOOTPATH/EMU
|
||||
+ PREFIX/lib64/vice/EMU:$HOME/.vice/EMU:BOOTPATH/EMU
|
||||
|
||||
Where `PREFIX' is the installation prefix (usually `/usr/local'), `EMU'
|
||||
is the name of the emulated machine (`C64', `C64DTV', `C128', `PET',
|
||||
@@ -1306,12 +1306,12 @@
|
||||
|
||||
then the value will be
|
||||
|
||||
- /usr/local/lib/vice/C64:$HOME/.vice/C64:/usr/local/bin/C64
|
||||
+ /usr/local/lib64/vice/C64:$HOME/.vice/C64:/usr/local/bin/C64
|
||||
|
||||
And system files will be searched for under the following directories,
|
||||
in the specified order:
|
||||
|
||||
- 1. `/usr/local/lib/VICE/C64'
|
||||
+ 1. `/usr/local/lib64/VICE/C64'
|
||||
|
||||
2. `$HOME/.vice/C64'
|
||||
|
||||
@@ -4010,7 +4010,7 @@
|
||||
where:
|
||||
|
||||
* `LIBDIR' is the VICE installation directory (usually
|
||||
- `/usr/local/lib/vice', `/usr/lib/vice' or `/opt/vice/lib');
|
||||
+ `/usr/local/lib64/vice', `/usr/lib64/vice' or `/opt/vice/lib');
|
||||
|
||||
* `EMUID' is the emulation identification string (`C64',
|
||||
`C128', `VIC20' or `PET');
|
||||
diff -Naur vice-2.3.21.orig/doc/vice.texi vice-2.3.21/doc/vice.texi
|
||||
--- vice-2.3.21.orig/doc/vice.texi 2012-07-24 04:08:09.000000000 +0200
|
||||
+++ vice-2.3.21/doc/vice.texi 2012-08-06 09:44:36.291562619 +0200
|
||||
@@ -1364,7 +1364,7 @@
|
||||
default value is
|
||||
|
||||
@example
|
||||
-PREFIX/lib/vice/EMU:$HOME/.vice/EMU:BOOTPATH/EMU
|
||||
+PREFIX/lib64/vice/EMU:$HOME/.vice/EMU:BOOTPATH/EMU
|
||||
@end example
|
||||
|
||||
Where @code{PREFIX} is the installation prefix (usually
|
||||
@@ -1383,7 +1383,7 @@
|
||||
then the value will be
|
||||
|
||||
@example
|
||||
-/usr/local/lib/vice/C64:$HOME/.vice/C64:/usr/local/bin/C64
|
||||
+/usr/local/lib64/vice/C64:$HOME/.vice/C64:/usr/local/bin/C64
|
||||
@end example
|
||||
|
||||
And system files will be searched for under the following directories,
|
||||
@@ -1391,7 +1391,7 @@
|
||||
|
||||
@enumerate 1
|
||||
@item
|
||||
-@code{/usr/local/lib/VICE/C64}
|
||||
+@code{/usr/local/lib64/VICE/C64}
|
||||
@item
|
||||
@code{$HOME/.vice/C64}
|
||||
@item
|
||||
diff -Naur vice-2.3.21.orig/doc/vice.txt vice-2.3.21/doc/vice.txt
|
||||
--- vice-2.3.21.orig/doc/vice.txt 2012-08-06 02:23:21.000000000 +0200
|
||||
+++ vice-2.3.21/doc/vice.txt 2012-08-06 09:44:36.296562563 +0200
|
||||
@@ -1056,7 +1056,7 @@
|
||||
`Directory' resource, which is a colon (`:')-separated search path
|
||||
list, like the UNIX `PATH' environment variable. The default value is
|
||||
|
||||
-PREFIX/lib/vice/EMU:$HOME/.vice/EMU:BOOTPATH/EMU
|
||||
+PREFIX/lib64/vice/EMU:$HOME/.vice/EMU:BOOTPATH/EMU
|
||||
|
||||
Where `PREFIX' is the installation prefix (usually `/usr/local'), `EMU'
|
||||
is the name of the emulated machine (`C64', `C64DTV', `C128', `PET',
|
||||
@@ -1070,12 +1070,12 @@
|
||||
|
||||
then the value will be
|
||||
|
||||
-/usr/local/lib/vice/C64:$HOME/.vice/C64:/usr/local/bin/C64
|
||||
+/usr/local/lib64/vice/C64:$HOME/.vice/C64:/usr/local/bin/C64
|
||||
|
||||
And system files will be searched for under the following directories,
|
||||
in the specified order:
|
||||
|
||||
-1. `/usr/local/lib/VICE/C64'
|
||||
+1. `/usr/local/lib64/VICE/C64'
|
||||
|
||||
2. `$HOME/.vice/C64'
|
||||
|
||||
diff -Naur vice-2.3.21.orig/INSTALL vice-2.3.21/INSTALL
|
||||
--- vice-2.3.21.orig/INSTALL 2011-01-29 14:17:50.000000000 +0100
|
||||
+++ vice-2.3.21/INSTALL 2012-08-06 09:44:36.299562529 +0200
|
||||
@@ -301,7 +301,7 @@
|
||||
|
||||
make install
|
||||
|
||||
- The binaries and support files will all go under PREFIX/lib/vice.
|
||||
+ The binaries and support files will all go under PREFIX/lib64/vice.
|
||||
You must of course have write permissions for the directories where
|
||||
VICE is to be installed. Normally only the system administrator
|
||||
has write access to /usr/local, the default PREFIX. Either ask
|
||||
diff -Naur vice-2.3.21.orig/src/arch/sdl/archdep_unix.h vice-2.3.21/src/arch/sdl/archdep_unix.h
|
||||
--- vice-2.3.21.orig/src/arch/sdl/archdep_unix.h 2011-07-21 05:10:28.000000000 +0200
|
||||
+++ vice-2.3.21/src/arch/sdl/archdep_unix.h 2012-08-06 09:42:11.970323196 +0200
|
||||
@@ -88,7 +88,7 @@
|
||||
#ifdef __NetBSD__
|
||||
#define LIBDIR PREFIX "/share/vice"
|
||||
#else
|
||||
-#define LIBDIR PREFIX "/lib/vice"
|
||||
+#define LIBDIR PREFIX "/lib64/vice"
|
||||
#endif
|
||||
|
||||
#if defined(__FreeBSD__) || defined(__NetBSD__)
|
||||
diff -Naur vice-2.3.21.orig/src/arch/unix/archdep.h vice-2.3.21/src/arch/unix/archdep.h
|
||||
--- vice-2.3.21.orig/src/arch/unix/archdep.h 2010-10-06 18:17:43.000000000 +0200
|
||||
+++ vice-2.3.21/src/arch/unix/archdep.h 2012-08-06 09:42:46.474902531 +0200
|
||||
@@ -127,7 +127,7 @@
|
||||
#ifdef __NetBSD__
|
||||
#define LIBDIR PREFIX "/share/vice"
|
||||
#else
|
||||
-#define LIBDIR PREFIX "/lib/vice"
|
||||
+#define LIBDIR PREFIX "/lib64/vice"
|
||||
#endif
|
||||
|
||||
#if defined(__FreeBSD__) || defined(__NetBSD__)
|
32
system/vice/patches/vice-2.3.21-docs-fixes.patch
Normal file
32
system/vice/patches/vice-2.3.21-docs-fixes.patch
Normal file
|
@ -0,0 +1,32 @@
|
|||
diff -Naur vice-2.3.21.orig/configure.in vice-2.3.21/configure.in
|
||||
--- vice-2.3.21.orig/configure.in 2012-08-06 02:23:21.000000000 +0200
|
||||
+++ vice-2.3.21/configure.in 2012-08-06 11:35:40.509403194 +0200
|
||||
@@ -288,13 +288,7 @@
|
||||
|
||||
AC_CHECK_PROGS(MAKEINFO, makeinfo, no)
|
||||
|
||||
-AC_CHECK_PROGS(TEXI2DVI, texi2dvi, no)
|
||||
-AC_CHECK_PROGS(PDFTEX, pdftex, no)
|
||||
-if test x"$TEXI2DVI" = "xno" -o x"$PDFTEX" = "xno"; then
|
||||
- AM_CONDITIONAL(BUILD_PDF, false)
|
||||
-else
|
||||
- AM_CONDITIONAL(BUILD_PDF, true)
|
||||
-fi
|
||||
+AM_CONDITIONAL(BUILD_PDF, false)
|
||||
|
||||
AC_CHECK_PROGS(DOS2UNIX, dos2unix, dos2unix)
|
||||
|
||||
diff -Naur vice-2.3.21.orig/doc/html/Makefile.am vice-2.3.21/doc/html/Makefile.am
|
||||
--- vice-2.3.21.orig/doc/html/Makefile.am 2012-06-30 05:31:11.000000000 +0200
|
||||
+++ vice-2.3.21/doc/html/Makefile.am 2012-08-06 11:32:11.953905072 +0200
|
||||
@@ -45,10 +45,6 @@
|
||||
vice_14.html \
|
||||
vice_15.html \
|
||||
vice_16.html \
|
||||
- vice_17.html \
|
||||
- vice_18.html \
|
||||
- vice_19.html \
|
||||
- vice_20.html \
|
||||
vice_toc.html
|
||||
|
||||
EXTRA_DIST = $(doc_DATA) \
|
|
@ -1,11 +0,0 @@
|
|||
--- src/arch/unix/joy.c
|
||||
+++ src/arch/unix/joy.c
|
||||
@@ -124,7 +124,7 @@
|
||||
#define JS_DATA_TYPE joystick
|
||||
#define JS_RETURN sizeof(struct joystick)
|
||||
int use_old_api=1;
|
||||
-#elif
|
||||
+#else
|
||||
#error Unknown Joystick
|
||||
#endif
|
||||
|
|
@ -23,7 +23,7 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=vice
|
||||
VERSION=2.1
|
||||
VERSION=${VERSION:-2.3.22}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -49,7 +49,7 @@ elif [ "$ARCH" = "i686" ]; then
|
|||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
SLKCFLAGS="-O2 -fPIC -pipe"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
|
@ -62,7 +62,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find . \
|
||||
|
@ -75,11 +75,13 @@ find . \
|
|||
# folder (the folder set up by "make install" is quite broken).
|
||||
patch -p1 <$CWD/patches/vice-fix-help.patch
|
||||
|
||||
# Use /usr/lib64 on 64-bit Slackware
|
||||
[ "$ARCH" == "x86_64" ] && patch -p1 < $CWD/patches/vice-2.1-64bit.patch
|
||||
# Small fixes for html doc building, avoid pdf (broken)
|
||||
patch -p1 < $CWD/patches/vice-2.3.21-docs-fixes.patch
|
||||
|
||||
# patch for gcc 4.4
|
||||
patch -p0 < $CWD/patches/vice-gcc-4.4.patch
|
||||
# Use /usr/lib64 on 64-bit Slackware
|
||||
[ "$ARCH" == "x86_64" ] && patch -p1 < $CWD/patches/vice-2.3.21-64bit.patch
|
||||
|
||||
sh autogen.sh || true
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
|
@ -89,6 +91,7 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--enable-gnomeui \
|
||||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--disable-ffmpeg \
|
||||
--build=$ARCH-slackware-linux
|
||||
|
||||
make
|
||||
|
@ -97,9 +100,8 @@ make install DESTDIR=$PKG
|
|||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
)
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
|
||||
rm -f $PKG/usr/info/dir
|
||||
gzip -9 $PKG/usr/info/*
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="vice"
|
||||
VERSION="2.1"
|
||||
VERSION="2.3.22"
|
||||
HOMEPAGE="http://www.viceteam.org/"
|
||||
DOWNLOAD="http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/vice-2.1.tar.gz"
|
||||
MD5SUM="a4cca1aad12e12ac7f37d6c85310ade8"
|
||||
DOWNLOAD="http://ponce.cc/slackware/sources/repo/vice-2.3.22.tar.xz"
|
||||
MD5SUM="44290700d30fca06f8655bab8c2ce86f"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
Loading…
Reference in a new issue