games/vbam: Updated for version 2.0.2.

Signed-off-by: B. Watson <yalhcru@gmail.com>
This commit is contained in:
B. Watson 2018-06-12 15:01:53 -04:00 committed by David Spencer
parent 9ae010546d
commit 100f515545
4 changed files with 11 additions and 150 deletions

View file

@ -1,87 +0,0 @@
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 00000000..c24ac560
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,81 @@
+# Changelog
+All notable changes to this project will be documented in this file.
+
+The format is based on [Keep a Changelog](http://keepachangelog.com/en/1.0.0/)
+and this project adheres to [Semantic Versioning](http://semver.org/spec/v2.0.0.html).
+
+## [Unreleased]
+
+## [2.0.1] - 10/11/2017
+### Added
+- initial installer script
+- gitter.im badge in readme
+- 32bit cross compiling support on 64bit linux
+- added support for GNUInstallDirs to cmake
+- Include new translations from transifex
+- Added WxWidgets ABI compiler check
+- Add linux Joystick reference to issue template
+- Add #ubckyde <cmath> fir std::cell()
+-
+
+### Changed
+- Fix 2xSaImmx.asm linking issue
+- cmake: default to ENABLE_ASM_CORE=OFF
+- libretro merging from upstream libretro fork.
+- better fix for clipped video in GL Fullscreen.
+- Fix flibc crash: add log message on fopen failure
+- fix gameboy header-detection in libretro interface
+- hotfix for potential buffer-overflow
+- delete memory in common/array.h on destruction
+- SDL: improve error msg for unwritable config
+- SDL: fix deflt bat saving, improve dir checking
+- fix portability issue with strerror_r()
+- Windows doesn't have sterror_r
+- wx/wxvbam: fix GetAbsolutePath
+- fix a memory leak due to wrong syntax
+- regenerate translation files
+- fix errors reported by SUSE's post build linter
+- SUSE Lint: fix a few classes of warnings
+- let cmake escape -D preproc. definitions
+- fix memory viewer xrc on wx 3.1+
+- Improving README
+- SoundSDL: lock conditional code cleanup
+- remove the default F11 keybinding for save state
+- hopefully fix resize artifacts on game panel
+- soundSDL: write silence when paused
+- cleanup SoundSDL #139 #130 #97 #67 #65 #46 #47
+- document how to provice symbolic backtraces
+- "no throttle" fixes/cleanup
+- only use -mtune=generic on x86/amd64
+- installdeps: use -j$(nproc) not -j8 in info
+- use -fabi-version=2 for GCC turn off LTO
+- installdeps: minor refactoring/cleanup
+- improve Wx GCC ABI check
+- minor improvements for Wx Compile tests
+- fix wx ABI check for Win32/MinGW
+- installdeps: fedora fixes, including m32
+- cmake: wx and cross compiling fixes
+- restore wx 2.7 compat, improve string processing
+- rename CMakeScripts/ to cmake/
+- work around gcc lto wrappers bug with gcc 7.x
+- update README.md
+- remove doctoc title from README.md TOC
+- improve win32 dependencies git submodule handling
+- use num cpu cores to parallelize LTO link with gcc
+- fix huge app icon in Win volume settings
+- fix deadlock in SoundSDL:deinit()
+- added executable extension for sdl binary
+- default LTO to off on 64bit MinGW
+- minor code cleanup
+- deps: dont check result of apt-get update
+- read version and subversion info from Git
+- fix error and version info in shallow git clones
+- refactor/cleanup GitTagVersion.cmake
+
+### Removed
+- Cairo Renderer: it never performed well to begin with
+
+
+
+[2.0.1]: https://github.com/olivierlacan/keep-a-changelog/compare/throttle...v2.0.1
+

View file

@ -1,54 +0,0 @@
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd09527d..4ad859b2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -112,15 +112,12 @@ if(GIT_FOUND AND EXISTS "${CMAKE_SOURCE_DIR}/.git")
# of files that depend on version.h
include(GetGitRevisionDescription)
get_git_head_revision(REFSPEC COMMITHASH)
-else()
- message(WARNING "Git not found, cannot set version info")
endif()
-# no git or no tags
+# no git or no tags, use ChangeLog
if(NOT VERSION)
- set(VERSION 2.0.0)
- set(REVISION "unknown")
- set(VERSION_RELEASE 0)
+ include(ChangeLogVersion)
+ changelog_version(VERSION REVISION VERSION_RELEASE)
endif()
# generate version.h
diff --git a/cmake/ChangeLogVersion.cmake b/cmake/ChangeLogVersion.cmake
new file mode 100644
index 00000000..101d23bd
--- /dev/null
+++ b/cmake/ChangeLogVersion.cmake
@@ -0,0 +1,25 @@
+function(changelog_version version revision version_release)
+ set(${version} "" CACHE STRING "Latest ChangeLog Version" FORCE)
+ set(${revision} "" CACHE STRING "Latest ChangeLog Revision" FORCE)
+ set(${version_release} 0 CACHE STRING "Is this a versioned release without revision" FORCE)
+
+ file(READ CHANGELOG.md changelog_file)
+
+ if(NOT changelog_file)
+ return()
+ endif()
+
+ string(REGEX MATCH "\n## +\\[([0-9.]+)(-([^] ]+))?\\] +- +[0-9][0-9]?/" match_out "${changelog_file}")
+
+ set(changelog_version "${CMAKE_MATCH_1}")
+
+ set(is_version_release 0)
+ set(changelog_revision "${CMAKE_MATCH_3}")
+ if(NOT changelog_revision)
+ set(is_version_release 1)
+ endif()
+
+ set(${version} "${changelog_version}" CACHE STRING "Latest ChangeLog Version" FORCE)
+ set(${revision} "${changelog_revision}" CACHE STRING "Latest ChangeLog Revision" FORCE)
+ set(${version_release} "${is_version_release}" CACHE STRING "Is this a versioned release without revision" FORCE)
+endfunction()

View file

@ -23,6 +23,8 @@
# Modified by the SlackBuilds.org project.
# 20180612 bkw: updated for 2.0.2.
# 20171219 bkw: updated for 2.0.1.
# 20170302 bkw: use long-format github URL
@ -43,7 +45,7 @@
# - Correct README, plus cosmetic reformatting.
PRGNAM=vbam
VERSION=${VERSION:-2.0.1}
VERSION=${VERSION:-2.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@ -104,11 +106,11 @@ find -L . \
# confusion, force the correct version.
WXCONF=${WXCONF:-/usr/lib$LIBDIRSUFFIX/wx/config/gtk2-unicode-3.0}
# Upstream says: "Note to distro packagers: If you build from a tarball
# rather than from git, please include 30b6ecf and 4648638 as patches. These
# didn't make it into the tag."
patch -p1 < $CWD/30b6ecf.diff
patch -p1 < $CWD/4648638.diff
# upstream cleverly parses their own ChangeLog to get the version number
# that gets compiled into the binary. They un-cleverly failed to follow
# their own formatting rules for v2.0.2, meaning the 2.0.2 executable
# says 2.0.1 in its window title. So:
sed -i '/\[2\.0\.2\]/s,Bug fix release,-,' CHANGELOG.md
mkdir -p build
cd build

View file

@ -1,8 +1,8 @@
PRGNAM="vbam"
VERSION="2.0.1"
VERSION="2.0.2"
HOMEPAGE="http://vba-m.com/"
DOWNLOAD="https://github.com/visualboyadvance-m/visualboyadvance-m/archive/v2.0.1/visualboyadvance-m-2.0.1.tar.gz"
MD5SUM="b5147a34de3e2cd878c354aac37a7bcc"
DOWNLOAD="https://github.com/visualboyadvance-m/visualboyadvance-m/archive/v2.0.2/visualboyadvance-m-2.0.2.tar.gz"
MD5SUM="6dbe6116fb9fdca40c80a709d9a3f330"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="SDL2 SFML wxGTK3"