mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-20 19:41:34 +01:00
development/llvm: Updated for version 2.7.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
parent
10af232047
commit
0e3997a439
4 changed files with 17 additions and 392 deletions
|
@ -1,361 +0,0 @@
|
|||
From 5a380ce5d1c8d5a1474764a7a54a1e2072fddb03 Mon Sep 17 00:00:00 2001
|
||||
From: Erick Tryzelaar <idadesub@users.sourceforge.net>
|
||||
Date: Fri, 21 Aug 2009 11:59:01 -0700
|
||||
Subject: [PATCH] Rewrite makefiles to explicitly reference DESTDIR so we can not bake DESTDIR
|
||||
into the O'Caml symlinks.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: multipart/mixed; boundary="------------1.6.4"
|
||||
|
||||
This is a multi-part message in MIME format.
|
||||
--------------1.6.4
|
||||
Content-Type: text/plain; charset=UTF-8; format=fixed
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
---
|
||||
Makefile.config.in | 16 +++++++-------
|
||||
Makefile.rules | 46 ++++++++++++++++++++++----------------------
|
||||
docs/CommandGuide/Makefile | 6 ++--
|
||||
docs/Makefile | 24 +++++++++++-----------
|
||||
docs/tutorial/Makefile | 2 +-
|
||||
lib/VMCore/Makefile | 4 +-
|
||||
tools/gccas/Makefile | 4 +-
|
||||
tools/gccld/Makefile | 4 +-
|
||||
tools/llvm-config/Makefile | 4 +-
|
||||
9 files changed, 55 insertions(+), 55 deletions(-)
|
||||
|
||||
|
||||
--------------1.6.4
|
||||
Content-Type: text/x-patch; name="0001-Rewrite-makefiles-to-explicitly-reference-DESTDIR-so.patch"
|
||||
Content-Transfer-Encoding: 8bit
|
||||
Content-Disposition: attachment; filename="0001-Rewrite-makefiles-to-explicitly-reference-DESTDIR-so.patch"
|
||||
|
||||
diff --git Makefile.config.in Makefile.config.in
|
||||
index ecd0595..73656f7 100644
|
||||
--- Makefile.config.in
|
||||
+++ Makefile.config.in
|
||||
@@ -76,14 +76,14 @@ endif
|
||||
|
||||
LLVMMAKE := $(LLVM_SRC_ROOT)/make
|
||||
|
||||
-PROJ_bindir := $(DESTDIR)$(PROJ_prefix)/bin
|
||||
-PROJ_libdir := $(DESTDIR)$(PROJ_prefix)/lib
|
||||
-PROJ_datadir := $(DESTDIR)$(PROJ_prefix)/share
|
||||
-PROJ_docsdir := $(DESTDIR)$(PROJ_prefix)/docs/llvm
|
||||
-PROJ_etcdir := $(DESTDIR)$(PROJ_prefix)/etc/llvm
|
||||
-PROJ_includedir := $(DESTDIR)$(PROJ_prefix)/include
|
||||
-PROJ_infodir := $(DESTDIR)$(PROJ_prefix)/info
|
||||
-PROJ_mandir := $(DESTDIR)$(PROJ_prefix)/share/man
|
||||
+PROJ_bindir := $(PROJ_prefix)/bin
|
||||
+PROJ_libdir := $(PROJ_prefix)/lib
|
||||
+PROJ_datadir := $(PROJ_prefix)/share
|
||||
+PROJ_docsdir := $(PROJ_prefix)/docs/llvm
|
||||
+PROJ_etcdir := $(PROJ_prefix)/etc/llvm
|
||||
+PROJ_includedir := $(PROJ_prefix)/include
|
||||
+PROJ_infodir := $(PROJ_prefix)/info
|
||||
+PROJ_mandir := $(PROJ_prefix)/share/man
|
||||
|
||||
# Determine if we're on a unix type operating system
|
||||
LLVM_ON_UNIX:=@LLVM_ON_UNIX@
|
||||
diff --git Makefile.rules Makefile.rules
|
||||
index 5556684..08965f3 100644
|
||||
--- Makefile.rules
|
||||
+++ Makefile.rules
|
||||
@@ -720,7 +720,7 @@ ObjectsBC := $(BaseNameSources:%=$(ObjDir)/%.bc)
|
||||
# in the file so they get built before dependencies
|
||||
#---------------------------------------------------------
|
||||
|
||||
-$(PROJ_bindir) $(PROJ_libdir) $(PROJ_includedir) $(PROJ_etcdir)::
|
||||
+$(DESTDIR)$(PROJ_bindir) $(DESTDIR)$(PROJ_libdir) $(DESTDIR)$(PROJ_includedir) $(DESTDIR)$(PROJ_etcdir)::
|
||||
$(Verb) $(MKDIR) $@
|
||||
|
||||
# To create other directories, as needed, and timestamp their creation
|
||||
@@ -842,22 +842,22 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) UnInstall circumvented with NO_INSTALL
|
||||
else
|
||||
-install-local:: $(PROJ_etcdir) $(CONFIG_FILES)
|
||||
- $(Echo) Installing Configuration Files To $(PROJ_etcdir)
|
||||
+install-local:: $(DESTDIR)$(PROJ_etcdir) $(CONFIG_FILES)
|
||||
+ $(Echo) Installing Configuration Files To $(DESTDIR)$(PROJ_etcdir)
|
||||
$(Verb)for file in $(CONFIG_FILES); do \
|
||||
if test -f $(PROJ_OBJ_DIR)/$${file} ; then \
|
||||
- $(DataInstall) $(PROJ_OBJ_DIR)/$${file} $(PROJ_etcdir) ; \
|
||||
+ $(DataInstall) $(PROJ_OBJ_DIR)/$${file} $(DESTDIR)$(PROJ_etcdir) ; \
|
||||
elif test -f $(PROJ_SRC_DIR)/$${file} ; then \
|
||||
- $(DataInstall) $(PROJ_SRC_DIR)/$${file} $(PROJ_etcdir) ; \
|
||||
+ $(DataInstall) $(PROJ_SRC_DIR)/$${file} $(DESTDIR)$(PROJ_etcdir) ; \
|
||||
else \
|
||||
$(ECHO) Error: cannot find config file $${file}. ; \
|
||||
fi \
|
||||
done
|
||||
|
||||
uninstall-local::
|
||||
- $(Echo) Uninstalling Configuration Files From $(PROJ_etcdir)
|
||||
+ $(Echo) Uninstalling Configuration Files From $(DESTDIR)$(PROJ_etcdir)
|
||||
$(Verb)for file in $(CONFIG_FILES); do \
|
||||
- $(RM) -f $(PROJ_etcdir)/$${file} ; \
|
||||
+ $(RM) -f $(DESTDIR)$(PROJ_etcdir)/$${file} ; \
|
||||
done
|
||||
endif
|
||||
|
||||
@@ -944,7 +944,7 @@ endif
|
||||
ifdef BYTECODE_DESTINATION
|
||||
ModuleDestDir := $(BYTECODE_DESTINATION)
|
||||
else
|
||||
-ModuleDestDir := $(PROJ_libdir)
|
||||
+ModuleDestDir := $(DESTDIR)$(PROJ_libdir)
|
||||
endif
|
||||
|
||||
ifdef NO_INSTALL
|
||||
@@ -1023,17 +1023,17 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) Uninstall circumvented with NO_INSTALL
|
||||
else
|
||||
-DestSharedLib = $(PROJ_libdir)/lib$(LIBRARYNAME)$(SHLIBEXT)
|
||||
+DestSharedLib = $(DESTDIR)$(PROJ_libdir)/lib$(LIBRARYNAME)$(SHLIBEXT)
|
||||
|
||||
install-local:: $(DestSharedLib)
|
||||
|
||||
-$(DestSharedLib): $(LibName.SO) $(PROJ_libdir)
|
||||
+$(DestSharedLib): $(LibName.SO) $(DESTDIR)$(PROJ_libdir)
|
||||
$(Echo) Installing $(BuildMode) Shared Library $(DestSharedLib)
|
||||
$(Verb) $(INSTALL) $(LibName.SO) $(DestSharedLib)
|
||||
|
||||
uninstall-local::
|
||||
$(Echo) Uninstalling $(BuildMode) Shared Library $(DestSharedLib)
|
||||
- -$(Verb) $(RM) -f $(PROJ_libdir)/lib$(LIBRARYNAME).*
|
||||
+ -$(Verb) $(RM) -f $(DESTDIR)$(PROJ_libdir)/lib$(LIBRARYNAME).*
|
||||
endif
|
||||
endif
|
||||
|
||||
@@ -1078,7 +1078,7 @@ endif
|
||||
ifdef BYTECODE_DESTINATION
|
||||
BytecodeDestDir := $(BYTECODE_DESTINATION)
|
||||
else
|
||||
-BytecodeDestDir := $(PROJ_libdir)
|
||||
+BytecodeDestDir := $(DESTDIR)$(PROJ_libdir)
|
||||
endif
|
||||
|
||||
DestBytecodeLib = $(BytecodeDestDir)/lib$(LIBRARYNAME).bca
|
||||
@@ -1141,13 +1141,13 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) Uninstall circumvented with NO_INSTALL
|
||||
else
|
||||
-DestArchiveLib := $(PROJ_libdir)/lib$(LIBRARYNAME).a
|
||||
+DestArchiveLib := $(DESTDIR)$(PROJ_libdir)/lib$(LIBRARYNAME).a
|
||||
|
||||
install-local:: $(DestArchiveLib)
|
||||
|
||||
-$(DestArchiveLib): $(LibName.A) $(PROJ_libdir)
|
||||
+$(DestArchiveLib): $(LibName.A) $(DESTDIR)$(PROJ_libdir)
|
||||
$(Echo) Installing $(BuildMode) Archive Library $(DestArchiveLib)
|
||||
- $(Verb) $(MKDIR) $(PROJ_libdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_libdir)
|
||||
$(Verb) $(INSTALL) $(LibName.A) $(DestArchiveLib)
|
||||
|
||||
uninstall-local::
|
||||
@@ -1225,11 +1225,11 @@ install-local::
|
||||
uninstall-local::
|
||||
$(Echo) Uninstall circumvented with NO_INSTALL
|
||||
else
|
||||
-DestTool = $(PROJ_bindir)/$(TOOLNAME)$(EXEEXT)
|
||||
+DestTool = $(DESTDIR)$(PROJ_bindir)/$(TOOLNAME)$(EXEEXT)
|
||||
|
||||
install-local:: $(DestTool)
|
||||
|
||||
-$(DestTool): $(ToolBuildPath) $(PROJ_bindir)
|
||||
+$(DestTool): $(ToolBuildPath) $(DESTDIR)$(PROJ_bindir)
|
||||
$(Echo) Installing $(BuildMode) $(DestTool)
|
||||
$(Verb) $(ProgInstall) $(ToolBuildPath) $(DestTool)
|
||||
|
||||
@@ -1824,25 +1824,25 @@ uninstall-local::
|
||||
else
|
||||
install-local::
|
||||
$(Echo) Installing include files
|
||||
- $(Verb) $(MKDIR) $(PROJ_includedir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_includedir)
|
||||
$(Verb) if test -d "$(PROJ_SRC_ROOT)/include" ; then \
|
||||
cd $(PROJ_SRC_ROOT)/include && \
|
||||
for hdr in `find . -type f '!' '(' -name '*~' \
|
||||
-o -name '.#*' -o -name '*.in' ')' -print | grep -v CVS | \
|
||||
grep -v .svn` ; do \
|
||||
- instdir=`dirname "$(PROJ_includedir)/$$hdr"` ; \
|
||||
+ instdir=`dirname "$(DESTDIR)$(PROJ_includedir)/$$hdr"` ; \
|
||||
if test \! -d "$$instdir" ; then \
|
||||
$(EchoCmd) Making install directory $$instdir ; \
|
||||
$(MKDIR) $$instdir ;\
|
||||
fi ; \
|
||||
- $(DataInstall) $$hdr $(PROJ_includedir)/$$hdr ; \
|
||||
+ $(DataInstall) $$hdr $(DESTDIR)$(PROJ_includedir)/$$hdr ; \
|
||||
done ; \
|
||||
fi
|
||||
ifneq ($(PROJ_SRC_ROOT),$(PROJ_OBJ_ROOT))
|
||||
$(Verb) if test -d "$(PROJ_OBJ_ROOT)/include" ; then \
|
||||
cd $(PROJ_OBJ_ROOT)/include && \
|
||||
for hdr in `find . -type f -print | grep -v CVS` ; do \
|
||||
- $(DataInstall) $$hdr $(PROJ_includedir)/$$hdr ; \
|
||||
+ $(DataInstall) $$hdr $(DESTDIR)$(PROJ_includedir)/$$hdr ; \
|
||||
done ; \
|
||||
fi
|
||||
endif
|
||||
@@ -1854,10 +1854,10 @@ uninstall-local::
|
||||
$(RM) -f `find . -path '*/Internal' -prune -o '(' -type f \
|
||||
'!' '(' -name '*~' -o -name '.#*' \
|
||||
-o -name '*.in' ')' -print ')' | \
|
||||
- grep -v CVS | sed 's#^#$(PROJ_includedir)/#'` ; \
|
||||
+ grep -v CVS | sed 's#^#$(DESTDIR)$(PROJ_includedir)/#'` ; \
|
||||
cd $(PROJ_SRC_ROOT)/include && \
|
||||
$(RM) -f `find . -path '*/Internal' -prune -o '(' -type f -name '*.in' \
|
||||
- -print ')' | sed 's#\.in$$##;s#^#$(PROJ_includedir)/#'` ; \
|
||||
+ -print ')' | sed 's#\.in$$##;s#^#$(DESTDIR)$(PROJ_includedir)/#'` ; \
|
||||
fi
|
||||
endif
|
||||
endif
|
||||
diff --git docs/CommandGuide/Makefile docs/CommandGuide/Makefile
|
||||
index cf77e6a..28835ac 100644
|
||||
--- docs/CommandGuide/Makefile
|
||||
+++ docs/CommandGuide/Makefile
|
||||
@@ -71,9 +71,9 @@ EXTRA_DIST := $(POD) index.html
|
||||
clean-local::
|
||||
$(Verb) $(RM) -f pod2htm*.*~~ $(HTML) $(MAN) $(PS)
|
||||
|
||||
-HTML_DIR := $(PROJ_docsdir)/html/CommandGuide
|
||||
-MAN_DIR := $(PROJ_mandir)/man1
|
||||
-PS_DIR := $(PROJ_docsdir)/ps
|
||||
+HTML_DIR := $(DESTDIR)$(PROJ_docsdir)/html/CommandGuide
|
||||
+MAN_DIR := $(DESTDIR)$(PROJ_mandir)/man1
|
||||
+PS_DIR := $(DESTDIR)$(PROJ_docsdir)/ps
|
||||
|
||||
install-local:: $(HTML) $(MAN) $(PS)
|
||||
$(Echo) Installing HTML CommandGuide Documentation
|
||||
diff --git docs/Makefile docs/Makefile
|
||||
index 310c4bd..30cd8a7 100644
|
||||
--- docs/Makefile
|
||||
+++ docs/Makefile
|
||||
@@ -48,11 +48,11 @@ generated:: doxygen ocamldoc
|
||||
|
||||
install-html: $(PROJ_OBJ_DIR)/html.tar.gz
|
||||
$(Echo) Installing HTML documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html/img
|
||||
- $(Verb) $(DataInstall) $(HTML) $(PROJ_docsdir)/html
|
||||
- $(Verb) $(DataInstall) $(IMAGES) $(PROJ_docsdir)/html/img
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/img
|
||||
+ $(Verb) $(DataInstall) $(HTML) $(DESTDIR)$(PROJ_docsdir)/html
|
||||
+ $(Verb) $(DataInstall) $(IMAGES) $(DESTDIR)$(PROJ_docsdir)/html/img
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/html.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
|
||||
$(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
|
||||
$(Echo) Packaging HTML documentation
|
||||
@@ -63,11 +63,11 @@ $(PROJ_OBJ_DIR)/html.tar.gz: $(HTML)
|
||||
|
||||
install-doxygen: doxygen
|
||||
$(Echo) Installing doxygen documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/html/doxygen
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/html/doxygen
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/doxygen.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
$(Verb) cd $(PROJ_OBJ_DIR)/doxygen && \
|
||||
$(FIND) . -type f -exec \
|
||||
- $(DataInstall) {} $(PROJ_docsdir)/html/doxygen \;
|
||||
+ $(DataInstall) {} $(DESTDIR)$(PROJ_docsdir)/html/doxygen \;
|
||||
|
||||
doxygen: regendoc $(PROJ_OBJ_DIR)/doxygen.tar.gz
|
||||
|
||||
@@ -94,11 +94,11 @@ $(LLVM_SRC_ROOT)/docs/userloc.html:
|
||||
|
||||
install-ocamldoc: ocamldoc
|
||||
$(Echo) Installing ocamldoc documentation
|
||||
- $(Verb) $(MKDIR) $(PROJ_docsdir)/ocamldoc/html
|
||||
- $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/ocamldoc.tar.gz $(PROJ_docsdir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_docsdir)/ocamldoc/html
|
||||
+ $(Verb) $(DataInstall) $(PROJ_OBJ_DIR)/ocamldoc.tar.gz $(DESTDIR)$(PROJ_docsdir)
|
||||
$(Verb) cd $(PROJ_OBJ_DIR)/ocamldoc && \
|
||||
$(FIND) . -type f -exec \
|
||||
- $(DataInstall) {} $(PROJ_docsdir)/ocamldoc/html \;
|
||||
+ $(DataInstall) {} $(DESTDIR)$(PROJ_docsdir)/ocamldoc/html \;
|
||||
|
||||
ocamldoc: regen-ocamldoc $(PROJ_OBJ_DIR)/ocamldoc.tar.gz
|
||||
|
||||
@@ -122,4 +122,4 @@ $(PROJ_OBJ_DIR)/ocamldoc.tar.gz:
|
||||
|
||||
uninstall-local::
|
||||
$(Echo) Uninstalling Documentation
|
||||
- $(Verb) $(RM) -rf $(PROJ_docsdir)
|
||||
+ $(Verb) $(RM) -rf $(DESTDIR)$(PROJ_docsdir)
|
||||
diff --git docs/tutorial/Makefile docs/tutorial/Makefile
|
||||
index 6169bb8..9082ad4 100644
|
||||
--- docs/tutorial/Makefile
|
||||
+++ docs/tutorial/Makefile
|
||||
@@ -12,7 +12,7 @@ include $(LEVEL)/Makefile.common
|
||||
|
||||
HTML := $(wildcard $(PROJ_SRC_DIR)/*.html)
|
||||
EXTRA_DIST := $(HTML) index.html
|
||||
-HTML_DIR := $(PROJ_docsdir)/html/tutorial
|
||||
+HTML_DIR := $(DESTDIR)$(PROJ_docsdir)/html/tutorial
|
||||
|
||||
install-local:: $(HTML)
|
||||
$(Echo) Installing HTML Tutorial Documentation
|
||||
diff --git lib/VMCore/Makefile lib/VMCore/Makefile
|
||||
index e9d3dc8..c4817a5 100644
|
||||
--- lib/VMCore/Makefile
|
||||
+++ lib/VMCore/Makefile
|
||||
@@ -29,5 +29,5 @@ $(GENFILE): $(ObjDir)/Intrinsics.gen.tmp
|
||||
changed significantly. )
|
||||
|
||||
install-local:: $(GENFILE)
|
||||
- $(Echo) Installing $(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
- $(Verb) $(DataInstall) $(GENFILE) $(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
+ $(Echo) Installing $(DESTDIR)$(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
+ $(Verb) $(DataInstall) $(GENFILE) $(DESTDIR)$(PROJ_includedir)/llvm/Intrinsics.gen
|
||||
diff --git tools/gccas/Makefile tools/gccas/Makefile
|
||||
index ff84d96..594f9e4 100644
|
||||
--- tools/gccas/Makefile
|
||||
+++ tools/gccas/Makefile
|
||||
@@ -10,9 +10,9 @@ LEVEL = ../..
|
||||
|
||||
include $(LEVEL)/Makefile.common
|
||||
|
||||
-install-local:: $(PROJ_bindir)/gccas
|
||||
+install-local:: $(DESTDIR)$(PROJ_bindir)/gccas
|
||||
|
||||
-$(PROJ_bindir)/gccas : gccas.sh Makefile
|
||||
+$(DESTDIR)$(PROJ_bindir)/gccas : gccas.sh Makefile
|
||||
$(Echo) Installing gccas shell script.
|
||||
$(Verb) sed "s#@TOOLDIR@#$(PROJ_bindir)#" $< > $@
|
||||
$(Verb) chmod 0755 $@
|
||||
diff --git tools/gccld/Makefile tools/gccld/Makefile
|
||||
index b2d3f73..8ec0307 100644
|
||||
--- tools/gccld/Makefile
|
||||
+++ tools/gccld/Makefile
|
||||
@@ -11,9 +11,9 @@ LEVEL = ../..
|
||||
|
||||
include $(LEVEL)/Makefile.common
|
||||
|
||||
-install-local:: $(PROJ_bindir)/gccld
|
||||
+install-local:: $(DESTDIR)$(PROJ_bindir)/gccld
|
||||
|
||||
-$(PROJ_bindir)/gccld : gccld.sh Makefile
|
||||
+$(DESTDIR)$(PROJ_bindir)/gccld : gccld.sh Makefile
|
||||
$(Echo) Installing gccld shell script.
|
||||
$(Verb) sed "s#@TOOLDIR@#$(PROJ_bindir)#" $< > $@
|
||||
$(Verb) chmod 0755 $@
|
||||
diff --git tools/llvm-config/Makefile tools/llvm-config/Makefile
|
||||
index 6eedca0..8659681 100644
|
||||
--- tools/llvm-config/Makefile
|
||||
+++ tools/llvm-config/Makefile
|
||||
@@ -87,6 +87,6 @@ clean-local::
|
||||
$(LibDeps) GenLibDeps.out
|
||||
install-local:: all-local
|
||||
$(Echo) Installing llvm-config
|
||||
- $(Verb) $(MKDIR) $(PROJ_bindir)
|
||||
- $(Verb) $(ScriptInstall) $(ToolDir)/llvm-config $(PROJ_bindir)
|
||||
+ $(Verb) $(MKDIR) $(DESTDIR)$(PROJ_bindir)
|
||||
+ $(Verb) $(ScriptInstall) $(ToolDir)/llvm-config $(DESTDIR)$(PROJ_bindir)
|
||||
|
||||
|
||||
--------------1.6.4--
|
||||
|
||||
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for llvm
|
||||
|
||||
# Copyright 2008-2010 Heinz Wiesinger <pprkut@liwjatan.at>
|
||||
# Copyright 2008-2010 Heinz Wiesinger, Amsterdam, The Netherlands
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,16 +23,14 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=llvm
|
||||
VERSION=2.6
|
||||
VERSION=2.7
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
# Automatically determine the architecture we're building on:
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i486 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
# Unless $ARCH is already set, use uname -m for all other archs:
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
@ -62,15 +60,13 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tgz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go+r-w,a-s .
|
||||
|
||||
# use destdir correctly
|
||||
patch -p0 -i $CWD/llvm-2.6-destdir.patch
|
||||
|
||||
# --mandir doesn't work currently
|
||||
# need to disable assertions to make llvm thread-safe
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
|
@ -79,30 +75,24 @@ CXXFLAGS="$SLKCFLAGS" \
|
|||
--sysconfdir=/etc \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/man \
|
||||
--enable-optimizations \
|
||||
--enable-assertions \
|
||||
--enable-optimized \
|
||||
--disable-assertions \
|
||||
--enable-pic \
|
||||
--build=$ARCH-slackware-linux \
|
||||
--host=$ARCH-slackware-linux
|
||||
|
||||
# Correct libdir setting
|
||||
sed -i "s|\$(PROJ_prefix)/lib|\$(PROJ_prefix)/lib$LIBDIRSUFFIX|" \
|
||||
Makefile.config
|
||||
sed -i "s|\$(PROJ_prefix)/lib|\$(PROJ_prefix)/lib$LIBDIRSUFFIX|" Makefile.config
|
||||
|
||||
make
|
||||
|
||||
# make install doesn't support more than one concurrent job
|
||||
make \
|
||||
MAKEFLAGS="-j1"\
|
||||
DESTDIR=$PKG \
|
||||
install
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
# Remove example libraries
|
||||
rm -f $PKG/usr/lib$LIBDIRSUFFIX/LLVMHello*
|
||||
|
||||
# Fix wrong libdir
|
||||
sed -i -e "s|ABS_RUN_DIR/lib\"|ABS_RUN_DIR/lib$LIBDIRSUFFIX\"|" \
|
||||
$PKG/usr/bin/llvm-config
|
||||
$PKG/usr/bin/llvm-config
|
||||
|
||||
mv $PKG/usr/share/* $PKG/usr/
|
||||
rmdir $PKG/usr/share
|
||||
|
@ -110,14 +100,10 @@ rmdir $PKG/usr/share
|
|||
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
( cd $PKG/usr/man
|
||||
find . -type f -exec gzip -9 {} \;
|
||||
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
|
||||
)
|
||||
find $PKG/usr/man -type f -exec gzip -9 {} \;
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a CREDITS* LICENSE* README* \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a CREDITS* LICENSE* README* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
mv $PKG/usr/docs/llvm/* $PKG/usr/doc/$PRGNAM-$VERSION
|
||||
rm -rf $PKG/usr/docs
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
PRGNAM="llvm"
|
||||
VERSION="2.6"
|
||||
HOMEPAGE="http://llvm.cs.uiuc.edu/"
|
||||
DOWNLOAD="http://llvm.org/releases/2.6/llvm-2.6.tar.gz"
|
||||
MD5SUM="34a11e807add0f4555f691944e1a404a"
|
||||
VERSION="2.7"
|
||||
HOMEPAGE="http://llvm.org/"
|
||||
DOWNLOAD="http://llvm.org/releases/2.7/llvm-2.7.tgz"
|
||||
MD5SUM="ac322661f20e7d6c810b1869f886ad9b"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
MAINTAINER="Heinz Wiesinger"
|
||||
EMAIL="pprkut@liwjatan.at"
|
||||
APPROVED="Erik Hanson"
|
||||
APPROVED="rworkman"
|
||||
|
|
|
@ -12,7 +12,7 @@ llvm: Low Level Virtual Machine is a toolkit for the construction of
|
|||
llvm: highly optimized compilers, optimizers, and runtime
|
||||
llvm: environments.
|
||||
llvm:
|
||||
llvm: Homepage: http://llvm.cs.uiuc.edu/
|
||||
llvm: Homepage: http://llvm.org/
|
||||
llvm:
|
||||
llvm:
|
||||
llvm:
|
||||
|
|
Loading…
Reference in a new issue