mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-04 20:29:09 +01:00
development/openjdk: Updated for version 7u75b13.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
61bda44f3f
commit
0d8d22f6a9
5 changed files with 20 additions and 52 deletions
|
@ -1,11 +0,0 @@
|
|||
--- icedtea-2.5.3/Makefile.am 2014-10-15 06:57:54.000000000 +0300
|
||||
+++ icedtea-2.5.3.patched/Makefile.am 2015-01-17 22:36:01.000000000 +0200
|
||||
@@ -242,7 +242,7 @@
|
||||
|
||||
# Patch list
|
||||
|
||||
-ICEDTEA_PATCHES =
|
||||
+ICEDTEA_PATCHES = patches/currencyexpire.patch
|
||||
|
||||
# Conditional patches
|
||||
|
Binary file not shown.
|
@ -1,14 +0,0 @@
|
|||
diff -Nru openjdk.orig/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java
|
||||
--- openjdk.orig/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java 2015-01-17 19:19:33.000000000 +0200
|
||||
+++ openjdk/jdk/make/tools/src/build/tools/generatecurrencydata/GenerateCurrencyData.java 2015-01-17 22:29:32.000000000 +0200
|
||||
@@ -281,8 +281,8 @@
|
||||
checkCurrencyCode(newCurrency);
|
||||
String timeString = currencyInfo.substring(4, length - 4);
|
||||
long time = format.parse(timeString).getTime();
|
||||
- if (Math.abs(time - System.currentTimeMillis()) > ((long) 10) * 365 * 24 * 60 * 60 * 1000) {
|
||||
- throw new RuntimeException("time is more than 10 years from present: " + time);
|
||||
+ if (Math.abs(time - System.currentTimeMillis()) > ((long) 20) * 365 * 24 * 60 * 60 * 1000) {
|
||||
+ throw new RuntimeException("time is more than 20 years from present: " + time);
|
||||
}
|
||||
specialCaseCutOverTimes[specialCaseCount] = time;
|
||||
specialCaseOldCurrencies[specialCaseCount] = oldCurrency;
|
|
@ -23,12 +23,12 @@
|
|||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
PRGNAM=openjdk
|
||||
VERSION=${VERSION:-7u71b14}
|
||||
VERSION=${VERSION:-7u75b13}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
DVER=1.7.0_$(printf $VERSION | cut -du -f2)
|
||||
ICEDTEA=icedtea-2.5.3
|
||||
ICEDTEA=icedtea-2.5.4
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
|
@ -58,15 +58,8 @@ rm -rf $BUILD_DIR $PKG
|
|||
mkdir -p $TMP $BUILD_DIR $PKG $OUTPUT
|
||||
cd $BUILD_DIR
|
||||
|
||||
tar -xvf $CWD/${ICEDTEA}.tar.gz
|
||||
tar -xvf $CWD/${ICEDTEA}.tar.xz
|
||||
|
||||
cd $ICEDTEA
|
||||
patch Makefile.am $CWD/Makefile.am.patch
|
||||
cp $CWD/currencyexpire.patch ./patches
|
||||
aclocal
|
||||
autoconf
|
||||
|
||||
cd ..
|
||||
mkdir icedtea-build
|
||||
cd icedtea-build
|
||||
|
||||
|
|
|
@ -1,22 +1,22 @@
|
|||
PRGNAM="openjdk"
|
||||
VERSION="7u71b14"
|
||||
VERSION="7u75b13"
|
||||
HOMEPAGE="http://openjdk.java.net"
|
||||
DOWNLOAD="http://icedtea.classpath.org/download/source/icedtea-2.5.3.tar.gz \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/openjdk.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/corba.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/jaxp.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/jaxws.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/jdk.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/hotspot.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.3/langtools.tar.bz2"
|
||||
MD5SUM="dfd8f5f356a5fc05e63bb38e7c4c030a \
|
||||
730679eec8f645c05c0c518ae73a6f6d \
|
||||
b7dbab5f1ca314d613a9e7cf0a5939e1 \
|
||||
40e6d2e0e6b35a671bf1b0908c63ef9d \
|
||||
1615b1c82ac6a189d6805eedb8692402 \
|
||||
7cc129b8ff8f195583cf40620588e013 \
|
||||
e58128728b81b99bf94d9cac39015975 \
|
||||
fd28b781a95a609cd966c7048486e4ca"
|
||||
DOWNLOAD="http://icedtea.classpath.org/download/source/icedtea-2.5.4.tar.xz \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.4/openjdk.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.4/corba.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.4/jaxp.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.4/jaxws.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.4/jdk.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.4/langtools.tar.bz2 \
|
||||
http://icedtea.classpath.org/download/drops/icedtea7/2.5.4/hotspot.tar.bz2"
|
||||
MD5SUM="fe4556eff2a0021349e36bb07b09fa3e \
|
||||
90c83c73214a083b24adfee9a1be56a4 \
|
||||
06235b1e4b024402d6ec5cf0672cc353 \
|
||||
d3ffad8f8b415f002fd0f308279accbc \
|
||||
03bb3aa6f03765816adf3d312feed05e \
|
||||
4e848b426d98b60523f71e9f35edfff8 \
|
||||
ffc690fecd801662d4b4f8874aecbc68 \
|
||||
c3bbd2ff7bf67eae93f9c55ad3ff3b91"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES="apache-ant"
|
||||
|
|
Loading…
Reference in a new issue