mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-21 19:42:24 +01:00
desktop/gnome-icon-theme: Added (default icons used by GTK+)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
65915e0419
commit
0cbb911dff
6 changed files with 222 additions and 0 deletions
2
desktop/gnome-icon-theme/README
Normal file
2
desktop/gnome-icon-theme/README
Normal file
|
@ -0,0 +1,2 @@
|
|||
The default icon theme used by the GNOME desktop. Some themes still use
|
||||
this as a fallback, for example Tango.
|
6
desktop/gnome-icon-theme/doinst.sh
Normal file
6
desktop/gnome-icon-theme/doinst.sh
Normal file
|
@ -0,0 +1,6 @@
|
|||
if [ -e /usr/share/icons/gnome/icon-theme.cache ]; then
|
||||
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||
/usr/bin/gtk-update-icon-cache /usr/share/icons/gnome 1> /dev/null 2> /dev/null
|
||||
fi
|
||||
fi
|
||||
|
12
desktop/gnome-icon-theme/fix_gits_configure.patch
Normal file
12
desktop/gnome-icon-theme/fix_gits_configure.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -pruN old/configure new/configure
|
||||
--- old/configure 2014-03-25 06:59:37.000000000 +0200
|
||||
+++ new/configure 2021-05-15 13:03:58.289210537 +0300
|
||||
@@ -2828,7 +2828,7 @@ fi
|
||||
|
||||
|
||||
|
||||
-ac_config_files="$ac_config_files gnome-icon-theme-symbolic.pc Makefile src/Makefile"
|
||||
+ac_config_files="$ac_config_files Makefile src/Makefile"
|
||||
|
||||
|
||||
cat >confcache <<\_ACEOF
|
169
desktop/gnome-icon-theme/gnome-icon-theme.SlackBuild
Normal file
169
desktop/gnome-icon-theme/gnome-icon-theme.SlackBuild
Normal file
|
@ -0,0 +1,169 @@
|
|||
#!/bin/bash
|
||||
|
||||
# Slackware build script for gnome-icon-theme
|
||||
|
||||
# Copyright 2023 Petar Petrov slackalaxy@gmail.com
|
||||
# Using Slackware 14.1 SlackBuild as a guide...
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
# permitted provided that the following conditions are met:
|
||||
#
|
||||
# 1. Redistributions of this script must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
|
||||
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
|
||||
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
|
||||
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
|
||||
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
|
||||
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
|
||||
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
|
||||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
cd $(dirname $0) ; CWD=$(pwd)
|
||||
|
||||
PRGNAM=gnome-icon-theme
|
||||
VERSION=${VERSION:-3.12.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
PKGTYPE=${PKGTYPE:-tgz}
|
||||
|
||||
EXTRAS=$PRGNAM-extras
|
||||
SYMBOL=$PRGNAM-symbolic
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
case "$( uname -m )" in
|
||||
i?86) ARCH=i586 ;;
|
||||
arm*) ARCH=arm ;;
|
||||
*) ARCH=$( uname -m ) ;;
|
||||
esac
|
||||
fi
|
||||
|
||||
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
|
||||
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|
||||
exit 0
|
||||
fi
|
||||
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
if [ "$ARCH" = "i586" ]; then
|
||||
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "i686" ]; then
|
||||
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
|
||||
LIBDIRSUFFIX=""
|
||||
elif [ "$ARCH" = "x86_64" ]; then
|
||||
SLKCFLAGS="-O2 -fPIC"
|
||||
LIBDIRSUFFIX="64"
|
||||
else
|
||||
SLKCFLAGS="-O2"
|
||||
LIBDIRSUFFIX=""
|
||||
fi
|
||||
|
||||
set -e
|
||||
|
||||
rm -rf $PKG
|
||||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
rm -rf $EXTRAS-$VERSION
|
||||
rm -rf $SYMBOL-$VERSION
|
||||
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
|
||||
tar xvf $CWD/$EXTRAS-$VERSION.tar.xz
|
||||
tar xvf $CWD/$SYMBOL-$VERSION.tar.xz
|
||||
|
||||
cd $TMP/$PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--enable-icon-mapping \
|
||||
--localstatedir=/var/lib
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
cd $TMP/$EXTRAS-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--enable-icon-mapping \
|
||||
--localstatedir=/var/lib
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
cd $TMP/$SYMBOL-$VERSION
|
||||
chown -R root:root .
|
||||
find -L . \
|
||||
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
|
||||
-o -perm 511 \) -exec chmod 755 {} \; -o \
|
||||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Same fix as in Slackware 14.1, updated for 3.12
|
||||
patch -p1 -i $CWD/fix_gits_configure.patch
|
||||
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
CXXFLAGS="$SLKCFLAGS" \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${LIBDIRSUFFIX} \
|
||||
--sysconfdir=/etc \
|
||||
--enable-icon-mapping \
|
||||
--localstatedir=/var/lib
|
||||
|
||||
make
|
||||
make install DESTDIR=$PKG
|
||||
|
||||
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
|
||||
|
||||
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
|
||||
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
|
||||
|
||||
# As in the original SlackBuild, we don't want icon caches:
|
||||
find $PKG/usr/share/icons -type f -name "icon-theme.cache" -exec rm -f {} \+
|
||||
|
||||
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/{extras,symbolic}
|
||||
cp -a \
|
||||
$TMP/$PRGNAM-$VERSION/{AUTHORS,COPYING,NEWS,README} \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION
|
||||
cp -a \
|
||||
$TMP/$EXTRAS-$VERSION/{AUTHORS,COPYING,NEWS,README} \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION/extras
|
||||
cp -a $TMP/$SYMBOL-$VERSION/{AUTHORS,COPYING,NEWS,README} \
|
||||
$PKG/usr/doc/$PRGNAM-$VERSION/symbolic
|
||||
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
|
||||
|
||||
mkdir -p $PKG/install
|
||||
cat $CWD/slack-desc > $PKG/install/slack-desc
|
||||
cat $CWD/doinst.sh > $PKG/install/doinst.sh
|
||||
|
||||
cd $PKG
|
||||
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|
14
desktop/gnome-icon-theme/gnome-icon-theme.info
Normal file
14
desktop/gnome-icon-theme/gnome-icon-theme.info
Normal file
|
@ -0,0 +1,14 @@
|
|||
PRGNAM="gnome-icon-theme"
|
||||
VERSION="3.12.0"
|
||||
HOMEPAGE="https://download.gnome.org"
|
||||
DOWNLOAD="https://download.gnome.org/sources/gnome-icon-theme/3.12/gnome-icon-theme-3.12.0.tar.xz \
|
||||
https://download.gnome.org/sources/gnome-icon-theme-extras/3.12/gnome-icon-theme-extras-3.12.0.tar.xz \
|
||||
https://download.gnome.org/sources/gnome-icon-theme-symbolic/3.12/gnome-icon-theme-symbolic-3.12.0.tar.xz"
|
||||
MD5SUM="f14bed7f804e843189ffa7021141addd \
|
||||
91f8f7e35a3d8d926716d88b8b1e9a29 \
|
||||
3c9c0e6b9fa04b3cbbb84da825a26fd9"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
MAINTAINER="Petar Petrov"
|
||||
EMAIL="slackalaxy@gmail.com"
|
19
desktop/gnome-icon-theme/slack-desc
Normal file
19
desktop/gnome-icon-theme/slack-desc
Normal file
|
@ -0,0 +1,19 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
gnome-icon-theme: gnome-icon-theme (default icons used by GTK+)
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme: A set of default icons used by many GTK+ applications.
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme:
|
||||
gnome-icon-theme:
|
Loading…
Reference in a new issue