mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-24 10:02:29 +01:00
office/zathura-cb: Updated for version 0.1.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
4f36fb5807
commit
0bd33ceef2
3 changed files with 5 additions and 69 deletions
|
@ -1,59 +0,0 @@
|
||||||
diff -Naur zathura-cb-0.1.0/cb.c zathura-cb-0.1.0.patched/cb.c
|
|
||||||
--- zathura-cb-0.1.0/cb.c 2012-06-09 17:48:13.000000000 -0400
|
|
||||||
+++ zathura-cb-0.1.0.patched/cb.c 2012-07-22 15:06:18.000000000 -0400
|
|
||||||
@@ -1,7 +1,9 @@
|
|
||||||
/* See LICENSE file for license and copyright information */
|
|
||||||
|
|
||||||
-#include <stdlib.h>
|
|
||||||
#include <stdio.h>
|
|
||||||
+#include <unistd.h>
|
|
||||||
+#include <limits.h>
|
|
||||||
+#include <stdlib.h>
|
|
||||||
#include <glib.h>
|
|
||||||
#include <gtk/gtk.h>
|
|
||||||
#include <glib/gstdio.h>
|
|
||||||
@@ -11,7 +13,7 @@
|
|
||||||
#include "utils.h"
|
|
||||||
|
|
||||||
struct cb_document_s {
|
|
||||||
- char* directory; /**< Path to the directory */
|
|
||||||
+ char directory[4096]; /**< Path to the directory */
|
|
||||||
girara_list_t* page_paths; /**< List of page paths */
|
|
||||||
};
|
|
||||||
|
|
||||||
@@ -58,8 +60,8 @@
|
|
||||||
cb_document_t* cb_document = g_malloc0(sizeof(cb_document));
|
|
||||||
|
|
||||||
/* create temp directory */
|
|
||||||
- cb_document->directory = g_dir_make_tmp("zathura-cb-XXXXXX", NULL);
|
|
||||||
- if (cb_document->directory == NULL) {
|
|
||||||
+ sprintf(cb_document->directory, "%s/zathura-cb-XXXXXX", g_get_tmp_dir());
|
|
||||||
+ if(mkdtemp(cb_document->directory) == NULL) {
|
|
||||||
goto error_free;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -148,18 +150,18 @@
|
|
||||||
return ZATHURA_ERROR_INVALID_ARGUMENTS;
|
|
||||||
}
|
|
||||||
|
|
||||||
- /* remove temp directory */
|
|
||||||
- if (cb_document->directory != NULL) {
|
|
||||||
- g_remove(cb_document->directory);
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
/* remove page list */
|
|
||||||
if (cb_document->page_paths != NULL) {
|
|
||||||
+ char *path;
|
|
||||||
+ GIRARA_LIST_FOREACH(cb_document->page_paths, char*, iter, path)
|
|
||||||
+ g_remove(path);
|
|
||||||
+ GIRARA_LIST_FOREACH_END(cb_document->page_paths, char*, iter, path);
|
|
||||||
girara_list_free(cb_document->page_paths);
|
|
||||||
}
|
|
||||||
|
|
||||||
+ /* remove temp directory */
|
|
||||||
if (cb_document->directory != NULL) {
|
|
||||||
- g_free(cb_document->directory);
|
|
||||||
+ g_remove(cb_document->directory);
|
|
||||||
}
|
|
||||||
|
|
||||||
g_free(cb_document);
|
|
|
@ -7,7 +7,7 @@
|
||||||
# Licensed under the WTFPL. See http://sam.zoy.org/wtfpl/ for details.
|
# Licensed under the WTFPL. See http://sam.zoy.org/wtfpl/ for details.
|
||||||
|
|
||||||
PRGNAM=zathura-cb
|
PRGNAM=zathura-cb
|
||||||
VERSION=${VERSION:-0.1.0}
|
VERSION=${VERSION:-0.1.2}
|
||||||
BUILD=${BUILD:-1}
|
BUILD=${BUILD:-1}
|
||||||
TAG=${TAG:-_SBo}
|
TAG=${TAG:-_SBo}
|
||||||
|
|
||||||
|
@ -53,11 +53,6 @@ find -L . \
|
||||||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||||
-exec chmod 644 {} \;
|
-exec chmod 644 {} \;
|
||||||
|
|
||||||
# as shipped, the source uses g_dir_make_tmp(), which was introduced in
|
|
||||||
# glib-2.30. Slack 13.37 ships with glib-2.28, so we make the code use
|
|
||||||
# g_mkdtemp() instead.
|
|
||||||
patch -p1 < $CWD/glib228compat.diff
|
|
||||||
|
|
||||||
sed -i "s,-fPIC,$SLKCFLAGS," config.mk
|
sed -i "s,-fPIC,$SLKCFLAGS," config.mk
|
||||||
|
|
||||||
make VERBOSE=1
|
make VERBOSE=1
|
||||||
|
|
|
@ -1,10 +1,10 @@
|
||||||
PRGNAM="zathura-cb"
|
PRGNAM="zathura-cb"
|
||||||
VERSION="0.1.0"
|
VERSION="0.1.2"
|
||||||
HOMEPAGE="http://www.pwmt.org/projects/zathura/plugins/zathura-cb/"
|
HOMEPAGE="http://www.pwmt.org/projects/zathura/plugins/zathura-cb/"
|
||||||
DOWNLOAD="http://www.pwmt.org/projects/zathura/plugins/download/zathura-cb-0.1.0.tar.gz"
|
DOWNLOAD="http://www.pwmt.org/projects/zathura/plugins/download/zathura-cb-0.1.2.tar.gz"
|
||||||
DOWNLOAD_x86_64=""
|
DOWNLOAD_x86_64=""
|
||||||
MD5SUM="be34b699862f4c1c9f5ef4347d1dfdef"
|
MD5SUM="56aad6e0ac0a256abc6a4fd441ea45ce"
|
||||||
MD5SUM_x86_64=""
|
MD5SUM_x86_64=""
|
||||||
REQUIRES="p7zip unrar zathura"
|
REQUIRES="zathura"
|
||||||
MAINTAINER="B. Watson"
|
MAINTAINER="B. Watson"
|
||||||
EMAIL="yalhcru@gmail.com"
|
EMAIL="yalhcru@gmail.com"
|
||||||
|
|
Loading…
Reference in a new issue