mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-26 22:06:35 +01:00
libraries/xblas: Use a versioned tarball.
Signed-off-by: Kyle Guinn <elyk03@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
bc54ebe435
commit
0b3fab7a43
3 changed files with 9 additions and 10 deletions
|
@ -1,7 +1,7 @@
|
|||
diff --git a/configure.ac b/configure.ac
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1,10 +1,12 @@
|
||||
@@ -1,10 +1,13 @@
|
||||
dnl Copyright (c) 2005, Regents of the University of California
|
||||
-AC_INIT(xblas, 1.0, extended_blas@cs.berkeley.edu)
|
||||
-AC_PREREQ(2.59)
|
||||
|
@ -15,11 +15,12 @@ diff --git a/configure.ac b/configure.ac
|
|||
+AC_CONFIG_AUX_DIR([config])
|
||||
AC_CANONICAL_TARGET
|
||||
+AM_INIT_AUTOMAKE([foreign subdir-objects])
|
||||
+LT_INIT
|
||||
+AM_SILENT_RULES([yes])
|
||||
+LT_INIT([disable-static])
|
||||
|
||||
AC_PROG_CC
|
||||
|
||||
@@ -148,6 +150,6 @@
|
||||
@@ -148,6 +151,6 @@
|
||||
[$M4 $M4_OPTS Makefile.m4 >Makefile], [M4=$M4; M4_OPTS="$M4_OPTS"])
|
||||
|
||||
AC_SUBST(EXTRA_LIBS, $EXTRA_LIBS)
|
||||
|
|
|
@ -2,7 +2,7 @@
|
|||
|
||||
# Slackware build script for XBLAS
|
||||
|
||||
# Copyright 2017 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# Copyright 2017-2021 Kyle Guinn <elyk03@gmail.com>, USA
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -24,7 +24,7 @@
|
|||
|
||||
PRGNAM=xblas
|
||||
VERSION=${VERSION:-1.0.248}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -37,7 +37,7 @@ fi
|
|||
|
||||
CWD=$(pwd)
|
||||
TMP=${TMP:-/tmp/SBo}
|
||||
PKG=$TMP/package-$PRGNAM
|
||||
PKG=$TMP/package-$PRGNAM-$VERSION
|
||||
OUTPUT=${OUTPUT:-/tmp}
|
||||
|
||||
DOCS="LICENSE README* doc/report.ps"
|
||||
|
@ -65,7 +65,7 @@ rm -rf $PKG
|
|||
mkdir -p $TMP $PKG $OUTPUT
|
||||
cd $TMP
|
||||
rm -rf $PRGNAM-$VERSION
|
||||
tar xvf $CWD/$PRGNAM.tar.gz
|
||||
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
|
||||
cd $PRGNAM-$VERSION
|
||||
chown -R root:root .
|
||||
chmod -R u+w,go-w,a+rX-st .
|
||||
|
@ -85,8 +85,6 @@ autoreconf -vif
|
|||
--mandir=/usr/man \
|
||||
--infodir=/usr/info \
|
||||
--docdir=/usr/doc/$PRGNAM-$VERSION \
|
||||
--enable-shared \
|
||||
--disable-static \
|
||||
--disable-dependency-tracking \
|
||||
--build=$ARCH-slackware-linux \
|
||||
CFLAGS="$SLKCFLAGS" \
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
PRGNAM="xblas"
|
||||
VERSION="1.0.248"
|
||||
HOMEPAGE="https://www.netlib.org/xblas/"
|
||||
DOWNLOAD="https://www.netlib.org/xblas/xblas.tar.gz"
|
||||
DOWNLOAD="https://www.netlib.org/xblas/xblas-1.0.248.tar.gz"
|
||||
MD5SUM="990c680fb5e446bb86c10936e4cd7f88"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
|
|
Loading…
Reference in a new issue