system/unalz: Removed (build failure)

g++    -c -o UnAlz.o UnAlz.cpp
UnAlz.cpp: In member function ‘UINT32 UNALZ::CUnAlz::CRC32(UINT32, BYTE)’:
UnAlz.cpp:1910:49: error: invalid conversion from ‘const z_crc_t* {aka const unsigned int*}’ to ‘const long unsigned int*’ [-fpermissive]
  const unsigned long *CRC_TABLE = get_crc_table();
                                                 ^
make: *** [UnAlz.o] Error 1

Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Robby Workman 2013-11-13 00:13:39 -06:00
parent 40b6c78aea
commit 0b0ee1c456
5 changed files with 0 additions and 133 deletions

View file

@ -1,9 +0,0 @@
unalz (A decompression utility for alz)
unalz is an open source program that can decompress alz files.
alz is an archive format developed for alzip.
Alzip is an archiver that can compress/decompress in such formats
as zip, rar, alz, and etc.
Here is a tip : UHC is the same as CP949, and CP949 contains the
EUCKR character set.

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
unalz: unalz (decompression utility for alz)
unalz:
unalz: unalz is an open source program that can decompress alz files.
unalz: alz is an archive format developed for alzip.
unalz: Alzip is an archiver that can compress/decompress in such formats
unalz: as zip, rar, alz, and etc.
unalz:
unalz: Tip: UHC is the same as CP949 and CP949 contains EUCKR charset.
unalz:
unalz: Website : http://www.kippler.com/win/unalz/
unalz:

View file

@ -1,82 +0,0 @@
#!/bin/sh
# Slackware build script for unalz
# Written by crocket (crockabiscuit@gmail.com)
PRGNAM=unalz
VERSION=${VERSION:-0.65}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tgz
mv $PRGNAM $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
chown -R root:root .
# the permissions are completely wrong.
find . -type f -exec chmod 644 '{}' \; -o \
-type d -exec chmod 755 '{}' \;
patch -p1 < $CWD/unalz_makefile.diff
# convert the encoding from CP949 to UTF8
# CP949 == UHC, and CP949 contains EUCKR character set.
# So using CP949 or UHC takes care of texts in EUCKR encoding
for file in $(find . -type f)
do
iconv -f CP949 -t UTF8 $file > $file.tmp
mv $file.tmp $file
done
# Use our CFLAGS
sed -i "s/^CFLAGS =/CFLAGS +=/" Makefile
CFLAGS="$SLKCFLAGS" \
make linux-utf8
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +0,0 @@
PRGNAM="unalz"
VERSION="0.65"
HOMEPAGE="http://www.kippler.com/win/unalz/"
DOWNLOAD="http://www.kippler.com/win/unalz/unalz-0.65.tgz"
MD5SUM="e4db2c4e3c8f6f5ee414b68bc55288e5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
MAINTAINER="crocket"
EMAIL="crockabiscuit@gmail.com"

View file

@ -1,13 +0,0 @@
diff -Naur unalz/Makefile unalz-patched/Makefile
--- unalz/Makefile 2009-01-20 10:42:59.000000000 +0900
+++ unalz-patched/Makefile 2010-10-03 22:08:17.862000012 +0900
@@ -38,7 +38,8 @@
$(CPP) $(OBJ) $(LDFLAGS) -o $(BIN)
install:
- cp unalz /usr/local/bin/
+ mkdir -p $(DESTDIR)/usr/bin
+ cp unalz $(DESTDIR)/usr/bin
clean:
rm -f $(OBJ) $(BIN)