mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-18 22:06:04 +01:00
system/lbench: Updated for version 2.0.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
This commit is contained in:
parent
26c349cd24
commit
0a5abead0f
4 changed files with 13 additions and 47 deletions
|
@ -3,7 +3,7 @@
|
|||
# Slackware build script for lbench
|
||||
# simple Linux multithread benchmarking tool
|
||||
|
||||
# Copyright 2010-2012 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# Copyright 2010-2013 Niels Horn, Rio de Janeiro, RJ, Brazil
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use of this script, with or without modification, is
|
||||
|
@ -23,10 +23,10 @@
|
|||
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
|
||||
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
# Revision date 2012/09/13
|
||||
# Revision date 2013/03/25
|
||||
|
||||
PRGNAM=lbench
|
||||
VERSION=${VERSION:-1.9}
|
||||
VERSION=${VERSION:-2.0}
|
||||
BUILD=${BUILD:-1}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
|
@ -72,9 +72,6 @@ find . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
|
||||
-exec chmod 644 {} \;
|
||||
|
||||
# Patch source to remove hardcoded location for userguide
|
||||
patch -p1 < $CWD/lbench_userguide.patch
|
||||
|
||||
# Fix makefile to not "install" the .desktop file
|
||||
# and accept LIBS variable
|
||||
sed \
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
PRGNAM="lbench"
|
||||
VERSION="1.9"
|
||||
HOMEPAGE="http://kornelix.squarespace.com/lbench/"
|
||||
DOWNLOAD="http://www.kornelix.com/uploads/1/3/0/3/13035936/lbench-1.9.tar.gz"
|
||||
MD5SUM="6a46b57765058af2562146a36500a62b"
|
||||
VERSION="2.0"
|
||||
HOMEPAGE="http://www.kornelix.com/lbench.html"
|
||||
DOWNLOAD="http://www.kornelix.com/uploads/1/3/0/3/13035936/lbench-2.0.tar.gz"
|
||||
MD5SUM="e7ff06fdae84a8ee10c55aa4c1ce6b41"
|
||||
DOWNLOAD_x86_64=""
|
||||
MD5SUM_x86_64=""
|
||||
REQUIRES=""
|
||||
|
|
|
@ -1,31 +0,0 @@
|
|||
--- lbench-1.9/zfuncs.cc 2012-07-29 08:48:24.000000000 -0300
|
||||
+++ lbench-1.9_patched/zfuncs.cc 2012-09-13 19:00:01.000000000 -0300
|
||||
@@ -3232,6 +3232,7 @@
|
||||
using namespace zfuncs;
|
||||
|
||||
char work[200];
|
||||
+ char doc[200];
|
||||
char logfile[200], oldlog[200];
|
||||
cchar *appfile;
|
||||
int secs, err;
|
||||
@@ -3254,7 +3255,8 @@
|
||||
strncatv(zdatadir,199,work,"/share/",zappname,"/data",null); // /prefix/share/appname/data
|
||||
strncatv(zicondir,199,work,"/share/",zappname,"/icons",null); // /prefix/share/appname/icons
|
||||
strncatv(zlocalesdir,199,work,"/share/",zappname,"/locales",null); // /prefix/share/appname/locales
|
||||
- strncatv(zdocdir,199,work,"/share/doc/",zappname,null); // /prefix/share/doc/appname
|
||||
+ strncpy0(doc,DOCDIR,199);
|
||||
+ strcpy(zdocdir,doc); // as defined in Makefile
|
||||
|
||||
snprintf(zuserdir,199,"%s/.%s",getenv("HOME"),zappname); // /home/user/.appname/
|
||||
err = stat(zuserdir,&statdat); // does it exist already?
|
||||
--- lbench-1.9/Makefile 2012-07-29 08:48:24.000000000 -0300
|
||||
+++ lbench-1.9_patched/Makefile 2012-09-13 18:54:12.000000000 -0300
|
||||
@@ -28,7 +28,7 @@
|
||||
$(CXX) $(CFLAGS) -o $(PROGRAM).o $(SOURCE)
|
||||
|
||||
zfuncs.o: zfuncs.cc
|
||||
- $(CXX) $(CFLAGS) zfuncs.cc -D PREFIX=\"$(PREFIX)\"
|
||||
+ $(CXX) $(CFLAGS) zfuncs.cc -D PREFIX=\"$(PREFIX)\" -D DOCDIR=\"$(DOCDIR)\"
|
||||
|
||||
install: $(PROGRAM)
|
||||
mkdir -p $(DESTDIR)$(BINDIR)
|
|
@ -1,9 +1,9 @@
|
|||
# HOW TO EDIT THIS FILE:
|
||||
# The "handy ruler" below makes it easier to edit a package description. Line
|
||||
# up the first '|' above the ':' following the base package name, and the '|'
|
||||
# on the right side marks the last column you can put a character in. You must
|
||||
# make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':'.
|
||||
# The "handy ruler" below makes it easier to edit a package description.
|
||||
# Line up the first '|' above the ':' following the base package name, and
|
||||
# the '|' on the right side marks the last column you can put a character in.
|
||||
# You must make exactly 11 lines for the formatting to be correct. It's also
|
||||
# customary to leave one space after the ':' except on otherwise blank lines.
|
||||
|
||||
|-----handy-ruler------------------------------------------------------|
|
||||
lbench: lbench (simple Linux multithread benchmarking tool)
|
||||
|
@ -13,7 +13,7 @@ lbench: some obscure performance issues. The performance increase from using
|
|||
lbench: multiple processor cores can be nearly 100% per core in some cases,
|
||||
lbench: and negative (an overall slowdown) in others.
|
||||
lbench:
|
||||
lbench: Homepage: http://kornelix.squarespace.com/lbench/
|
||||
lbench: Homepage: http://www.kornelix.com/lbench.html
|
||||
lbench:
|
||||
lbench:
|
||||
lbench:
|
||||
|
|
Loading…
Reference in a new issue