system/gnome-commander: Removed (no SBo or upstream maintainer)

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
This commit is contained in:
Willy Sudiarto Raharjo 2013-11-20 08:39:48 +07:00 committed by Robby Workman
parent 2056321731
commit 099bba9e52
7 changed files with 0 additions and 189 deletions

View file

@ -1,4 +0,0 @@
GNOME Commander is a "two-pane" graphical file manager for the GNOME desktop
environment. GNOME Commander aims to fulfill the demands of more advanced
users who like to focus on file management, their work through special
applications, and running smart commands.

View file

@ -1,4 +0,0 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi

View file

@ -1,16 +0,0 @@
diff -Naur gnome-commander-20120801_2f83e80.orig/src/gnome-cmd-collection.h gnome-commander-20120801_2f83e80/src/gnome-cmd-collection.h
--- gnome-commander-20120801_2f83e80.orig/src/gnome-cmd-collection.h 2012-08-01 21:05:40.000000000 +0200
+++ gnome-commander-20120801_2f83e80/src/gnome-cmd-collection.h 2012-09-28 20:41:46.264480154 +0200
@@ -35,9 +35,9 @@
template <typename T>
struct Collection<T *>: std::set<T *>
{
- void add(T *t) { insert(t); }
- void remove(T *t) { erase(t); }
- bool contain(T *t) const { return find(t)!=Collection::end(); }
+ void add(T *t) { this->insert(t); }
+ void remove(T *t) { this->erase(t); }
+ bool contain(T *t) const { return this->find(t)!=Collection::end(); }
GList *get_list();
};

View file

@ -1,41 +0,0 @@
diff -Naur gnome-commander-20120801_2f83e80.orig/configure.in gnome-commander-20120801_2f83e80/configure.in
--- gnome-commander-20120801_2f83e80.orig/configure.in 2012-08-01 21:05:40.000000000 +0200
+++ gnome-commander-20120801_2f83e80/configure.in 2012-09-28 20:30:08.952474818 +0200
@@ -259,6 +259,9 @@
if pkg-config --max-version=0.11.2 poppler; then
AC_DEFINE(POPPLER_HAS_GET_PDF_VERSION, 1, [Define to 1 if poppler has support for PDFDoc::getPDFVersion()])
fi
+ if pkg-config --atleast-version=0.19.0 poppler; then
+ AC_DEFINE(POPPLER_HAS_SET_ERROR_CALLBACK, 1, [Define to 1 if poppler has support for setErrorCallback()])
+ fi
fi
if test "x$have_pdf" = "xyes"; then
AC_DEFINE(HAVE_PDF, 1, [Define to 1 if you have PDF support])
diff -Naur gnome-commander-20120801_2f83e80.orig/src/tags/gnome-cmd-tags-poppler.cc gnome-commander-20120801_2f83e80/src/tags/gnome-cmd-tags-poppler.cc
--- gnome-commander-20120801_2f83e80.orig/src/tags/gnome-cmd-tags-poppler.cc 2012-08-01 21:05:40.000000000 +0200
+++ gnome-commander-20120801_2f83e80/src/tags/gnome-cmd-tags-poppler.cc 2012-09-28 20:32:21.602458163 +0200
@@ -41,7 +41,11 @@
static regex_t rxDate;
static gboolean rxDate_OK;
+#ifdef POPPLER_HAS_SET_ERROR_CALLBACK
+static void noErrorReporting(void *, ErrorCategory, int pos, char *msg)
+#else
static void noErrorReporting(int pos, char *msg, va_list args)
+#endif
{
}
#endif
@@ -52,8 +56,12 @@
#ifdef HAVE_PDF
rxDate_OK = regcomp (&rxDate, "^(D:)?([12][019][0-9][0-9]([01][0-9]([0-3][0-9]([012][0-9]([0-5][0-9]([0-5][0-9])?)?)?)?)?)", REG_EXTENDED)==0;
+#ifdef POPPLER_HAS_SET_ERROR_CALLBACK
+ setErrorCallback(noErrorReporting, NULL);
+#else
setErrorFunction(noErrorReporting);
#endif
+#endif
}

View file

@ -1,95 +0,0 @@
#!/bin/sh
# Slackware build script for <gnome-commander>
PRGNAM=gnome-commander
VERSION=${VERSION:-20120801_2f83e80}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
#PYTHON_ROOT=/usr/lib$LIBDIRSUFFIX/python2.7/config
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
# Fix for the new poppler
patch -p1 < $CWD/gnome-commander-poppler020.patch
# Another for gcc-4.7.x
patch -p1 < $CWD/gcc47.patch
# This helps autodetecting pyton
sed -i "s|PY_EXEC_PREFIX/lib|PY_EXEC_PREFIX/lib${LIBDIRSUFFIX}|" configure.in
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./autogen.sh \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--disable-scrollkeeper \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS BUGS COPYING ChangeLog INSTALL README README.commits TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}

View file

@ -1,10 +0,0 @@
PRGNAM="gnome-commander"
VERSION="20120801_2f83e80"
HOMEPAGE="http://www.nongnu.org/gcmd/"
DOWNLOAD="http://ponce.cc/slackware/sources/repo/gnome-commander-20120801_2f83e80.tar.xz"
MD5SUM="45c499bc494e9c398ef827b8281ec993"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libgnomeui libunique"
MAINTAINER="Bogdan Tatarov"
EMAIL="bogdan.tatarov@gmail.com"

View file

@ -1,19 +0,0 @@
# HOW TO EDIT THIS FILE:
# The "handy ruler" below makes it easier to edit a package description. Line
# up the first '|' above the ':' following the base package name, and the '|'
# on the right side marks the last column you can put a character in. You must
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
|-----handy-ruler------------------------------------------------------|
gnome-commander: GNOME Commander (NC-like file manager for gnome)
gnome-commander:
gnome-commander: GNOME Commander is a "two-pane" graphical file manager for the
gnome-commander: GNOME desktop environment. GNOME Commander aims to fulfill the
gnome-commander: demands of more advanced users who like to focus on file management,
gnome-commander: their work through special applications, and running smart commands.
gnome-commander:
gnome-commander:
gnome-commander:
gnome-commander:
gnome-commander: