mirror of
https://github.com/Ponce/slackbuilds
synced 2024-11-07 20:27:02 +01:00
development/snappy: Fix build with gtest installed.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
This commit is contained in:
parent
6547be4996
commit
094df1d521
2 changed files with 27 additions and 1 deletions
23
development/snappy/73.patch
Normal file
23
development/snappy/73.patch
Normal file
|
@ -0,0 +1,23 @@
|
|||
From 89342ecf34894461cc64c9cbe3f8bc0d18df5073 Mon Sep 17 00:00:00 2001
|
||||
From: "liangyukun.lyk" <lyk19961210@gmail.com>
|
||||
Date: Mon, 27 Aug 2018 18:08:46 +0800
|
||||
Subject: [PATCH] fix cmake build error
|
||||
|
||||
---
|
||||
CMakeLists.txt | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 41a2124..2a822dd 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -145,6 +145,9 @@ if(SNAPPY_BUILD_TESTS)
|
||||
target_compile_definitions(snappy_unittest PRIVATE -DHAVE_CONFIG_H)
|
||||
target_link_libraries(snappy_unittest snappy ${GFLAGS_LIBRARIES})
|
||||
|
||||
+ if(HAVE_GTEST)
|
||||
+ target_link_libraries(snappy_unittest gtest)
|
||||
+ endif(HAVE_GTEST)
|
||||
if(HAVE_LIBZ)
|
||||
target_link_libraries(snappy_unittest z)
|
||||
endif(HAVE_LIBZ)
|
|
@ -5,7 +5,7 @@
|
|||
|
||||
PRGNAM=snappy
|
||||
VERSION=${VERSION:-1.1.8}
|
||||
BUILD=${BUILD:-1}
|
||||
BUILD=${BUILD:-2}
|
||||
TAG=${TAG:-_SBo}
|
||||
|
||||
if [ -z "$ARCH" ]; then
|
||||
|
@ -52,6 +52,9 @@ find -L . \
|
|||
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
|
||||
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
|
||||
|
||||
# Fix build with gtest installed
|
||||
patch -p1 < $CWD/73.patch
|
||||
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
|
|
Loading…
Reference in a new issue