SlackBuildsOrg/system/dar/dar.SlackBuild
B. Watson fa35f8fbe8
system/dar: Updated for version 2.7.15, new maintainer.
Signed-off-by: B. Watson <urchlay@slackware.uk>

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
2024-08-31 07:56:38 +07:00

149 lines
4.4 KiB
Bash

#!/bin/bash
# Slackware Package Build Script for Disk ARchive (DAR)
# Home Page http://dar.linux.free.fr/
# Copyright (c) 2007-2019, Nishant Limbachia, Hoffman Estates, IL, USA
# Copyright (c) 2024 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of script must retain the above copyright notice,
# this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by Robby Workman <rworkman@slackbuilds.org> for better
# consistency with other scripts in our repository
# No additional license terms added :-)
# 20240826 bkw:
# - new maintainer.
# - update for v2.7.15.
# - tweak README and slack-desc.
# - document optional librsync and pybind11 deps.
# - fix samples/ path, for default config file.
# 20220409 bkw: Modified by SlackBuilds.org, BUILD=2:
# - remove useless INSTALL from doc dir.
# - fix permissions in doc dir, add missing SlackBuild.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM="dar"
VERSION=${VERSION:-2.7.15}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
fi
set -e
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
# 20240826 bkw: --disable-upx doesn't affect compile options, it
# prevents the dar executables from being compressed with upx
# when installed.
LDFLAGS="-L/usr/lib${LIBDIRSUFFIX} -L/lib${LIBDIRSUFFIX}" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--localstatedir=/var \
--mandir=/usr/man \
--docdir=/usr/doc \
--enable-shared \
--disable-static \
--disable-upx \
--disable-dar-static \
--disable-build-html \
--build=$ARCH-slackware-linux
make
make install-strip DESTDIR=$PKG
gzip -9 $PKG/usr/man/man*/*
# 20240826 bkw: sbopkglint hates it if we don't do this:
if [ -d $PKG/usr/lib$LIBDIRSUFFIX/python3 ]; then
strip $PKG/usr/lib*/python3/*/*.so
chmod 755 $PKG/usr/lib*/python3/*/*.so
fi
mv $PKG/etc/darrc $PKG/etc/darrc.new
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKG/usr/doc
mv $PKG/usr/share/$PRGNAM $PKGDOC
# 20240827 bkw: the config file wants to source stuff from
# samples/, which it expects to find in /usr/share/dar.
# Also the permissions are awful.
mkdir -p $PKG/usr/share/$PRGNAM
mv $PKGDOC/samples $PKG/usr/share/$PRGNAM
ln -s ../../share/$PRGNAM/samples $PKGDOC/samples
chmod 644 $PKGDOC/samples/*
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
cp -a AUTHORS ChangeLog COPYING NEWS README TODO THANKS $PKGDOC
chmod 644 $PKGDOC/samples/*
chown -R root:root $PKG/usr/doc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE